Adobe warns of Reader X security holes

Adobe ships patches for flaws that could cause the application to crash and potentially allow an attacker to take control of the affected system.

Adobe's flagship PDF Reader/Acrobat software contains multiple security vulnerabilities that expose computer users to dangerous hacker attacks.

Adobe warned about the vulnerabilities in a security bulletin that contained patches for Windows, Mac OS X and Linux users.

"These updates address vulnerabilities in the software that could cause the application to crash and potentially allow an attacker to take control of the affected system," the company said.

Technical details on these vulnerabilities are not available.  Here's a brief glimpse from Adobe:

  • These updates resolve an integer overflow in the True Type Font (TTF) handling that could lead to code execution (CVE-2012-0774).
  • These updates resolve a memory corruption in the JavaScript handling that could lead to code execution (CVE-2012-0775).
  • These updates resolve a security bypass via the Adobe Reader installer that could lead to code execution (CVE-2012-0776).
  • These updates resolve a memory corruption in the JavaScript API that could lead to code execution (CVE-2012-0777) (Macintosh and Linux only).

The Adobe Reader X (10.1.3) and Adobe Acrobat X (10.1.3) updates also incorporate fixes for security holes in the ever-present Flash Player software.

Newsletters

You have been successfully signed up. To sign up for more newsletters or to manage your account, visit the Newsletter Subscription Center.
Subscription failed.
See All
See All