Windows Vista - Here I go again!

Summary:Well, I must be completely daft. But I've said it before - I want Vista to work.

Well, I must be completely daft. But I've said it before - I want Vista to work. I want it to be better, faster, more secure, or whatever, than Windows XP - or at least as good. So, after reading all of the recent posts about Vista SP1 being available "Real Soon Now" (which made me aware that there are some Vista updates that must be installed before SP1 will install), and reading David Long's good article about ReadyBoost (which reminded me that I have 1 GB of Intel TurboMemory in this laptop which XP Pro isn't able to use)... I have now take the XP Professional disk out, and put the Vista disk back into this Lifebook S6510. Sigh. I really must be insane!

I've spent the morning getting it up to date again. First, installing the Vista updates which were released while I was running XP; then a couple of driver updates. Therein lies a typical story... The Marvell ethernet adapter drivers were updated, and I was able to install the update with no problem. The Intel Graphic Adapter drivers were updated, but when I tried to install them, it said that those drivers were not certified for my system, even though it was the correct chipset, so I should get driver updates from the system supplier. Laptop owners beware, this is quite common, and the laptop manufacturers all too often "abandon" their products (stop posting custom driver updates) long before the device manufacturers do. I checked Fujitsu's web page, and sure enough, no graphic driver updates there. Finally, there is supposed to be a Realtek audio driver update available, but Realtek seems to have some serious problems with their web page at the moment. Either I can't get the download page to load at all (something about a log file being full on their server), or I get error messages when I try to download the new drivers. I assume they will sort this out today sometime.

Once Windows and its device drivers were up to date (as much as possible), it was time to update the Video IM applications. First completely uninstall Gizmo, because of their "rebranding", and then install the latest version. No problem... Then update ooVoo, again no problem. Then Skype... hmmm. no, thanks, I'm much happier without that rubbish on my main laptop. My brother came online just after I was done with the updates, so I was able to test Gizmo and ooVoo with him, both worked just fine.

So, I'm going to be running Vista in this laptop for a while again. Bring on SP1, I'm ready!

One other note about Skype. Their "Presence Reporting" has been known to be "unreliable" (to be charitable) for a long time. With the latest release (3.6.0.248), it has gotten dramatically worse. Despite that, they tried to close an outstanding bug report on it, with the comment "This problem has been fixed in 3.6.0.248". This was met with a chorus of "No it certainly hasn't" replies. It appears that Skype "Development" might be going the same route as Skype "Support". Sigh. If you are still using Skype, do yourself a favor, have a look at one of the alternatives.

Topics: Linux

About

I started working with what we called "analog computers" in aircraft maintenance with the United States Air Force in 1970. After finishing military service and returning to university, I was introduced to microprocessors and machine language programming on Intel 4040 processors. After that I also worked on, operated and programmed Digital... Full Bio

Kick off your day with ZDNet's daily email newsletter. It's the freshest tech news and opinion, served hot. Get it.

Related Stories

The best of ZDNet, delivered

You have been successfully signed up. To sign up for more newsletters or to manage your account, visit the Newsletter Subscription Center.
Subscription failed.