
        
        
    





    
        <!DOCTYPE html>
<html lang="en" xmlns:fb="http://ogp.me/ns/fb#"><head><meta http-equiv="x-dns-prefetch-control" content="on"><link rel="dns-prefetch" href="//s0.2mdn.net" pr="0.7"><link rel="dns-prefetch" href="//api.viglink.com" pr="0.7"><link rel="dns-prefetch" href="//c2.taboola.com" pr="0.9"><link rel="dns-prefetch" href="//cdn.viglink.com" pr="0.7"><link rel="dns-prefetch" href="//tru.am" pr="0.7"><link rel="dns-prefetch" href="//urs.zdnet.com" pr="0.9"><link rel="dns-prefetch" href="//cdn.taboola.com" pr="1"><link rel="dns-prefetch" href="//platform.linkedin.com" pr="0.8"><link rel="dns-prefetch" href="//www.lightboxcdn.com" pr="0.7"><link rel="preconnect" href="//zdnet1.cbsistatic.com" pr="1"><link rel="preconnect" href="//zdnet2.cbsistatic.com" pr="1"><link rel="preconnect" href="//zdnet3.cbsistatic.com" pr="1"><link rel="preconnect" href="//zdnet4.cbsistatic.com" pr="1"><link rel="preconnect" href="//www.googletagservices.com" pr="1"><link rel="preconnect" href="//native.sharethrough.com" pr="1"><link rel="preconnect" href="//www.googleadservices.com" pr="1"><link rel="preconnect" href="//z.moatads.com" pr="1"><link rel="preconnect" href="//partner.googleadservices.com" pr="0.9"><link rel="preconnect" href="//pagead2.googlesyndication.com" pr="0.9"><link rel="preconnect" href="//tpc.googlesyndication.com" pr="0.9"><link rel="preconnect" href="//securepubads.g.doubleclick.net" pr="0.9"><link rel="preconnect" href="//rev.cbsi.com" pr="0.9"><link rel="preconnect" href="//static.adsafeprotected.com" pr="0.9"><link rel="preconnect" href="//cbsi.demdex.net" pr="0.9"><link rel="preconnect" href="//fast.cbsi.demdex.net" pr="0.9"><link rel="preconnect" href="//ps.ns-cdn.com" pr="0.9"><link rel="preconnect" href="//pixel.adsafeprotected.com" pr="0.8"><link rel="preconnect" href="//c.go-mpulse.net" pr="1"><link rel="preconnect" href="//tags.tiqcdn.com" pr="1"><link rel="preconnect" href="//secure-us.imrworldwide.com" pr="0.9"><link rel="preconnect" href="//b.scorecardresearch.com" pr="0.9"><link rel="preconnect" href="//b2b.cbsimg.net" pr="0.9"><link rel="preconnect" href="//sb.scorecardresearch.com" pr="0.9"><link rel="preconnect" href="//secure.quantserve.com" pr="0.9"><link rel="preconnect" href="//trc.taboola.com" pr="0.8"><meta content="text/html; charset=utf-8" http-equiv="Content-Type"><meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible"><meta content="en" http-equiv="Content-Language"><title>With the fullest measure of courage, DevOps holds true to its objective | ZDNet</title><meta name="description" content="Quest for the One True DevOps, Part III: Where one of the world's most recognized broadcasters makes a technological breakthrough that could save it from obsolescence, and the facilitators of that breakthrough discuss whether it did so the right way."><link rel="canonical" href="http://www.zdnet.com/article/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective/"><meta property="og:site_name" content="ZDNet"><meta property="og:type" content="article"><meta property="og:url" content="http://www.zdnet.com/article/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective/"><meta property="og:title" content="With the fullest measure of courage, DevOps holds true to its objective | ZDNet"><meta property="og:description" content="Quest for the One True DevOps, Part III: Where one of the world's most recognized broadcasters makes a technological breakthrough that could save it from obsolescence, and the facilitators of that breakthrough discuss whether it did so the right way."><meta property="og:image" content="https://zdnet1.cbsistatic.com/hub/i/r/2018/01/05/b851f335-f062-4720-9873-d24bc10ffd2c/thumbnail/770x578/a5ea17e7e8cc3f27bc3fae9c7eace367/180105-m03-scale-w3-fig-01.jpg"><meta name="author" content="Scott Fulton III"><meta property="article:author" content="https://www.facebook.com/https://www.facebook.com/scott.fultoniii.5"><meta name="viewport" content="width=device-width, user-scalable=no, maximum-scale=1, minimum-scale=1"><meta name="theme-color" content="#080e14"><link rel="icon" sizes="192x192" href="https://zdnet2.cbsistatic.com/fly/bundles/zdnetcss/images/logos/logo-192x192.png"><link rel="amphtml" href="http://www.zdnet.com/google-amp/article/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective/"><link rel="stylesheet" href="https://zdnet2.cbsistatic.com/fly/1080-fly/css/core/main-221837f4a3-rev.css"><!--[if (lt IE 9)&(!IEMobile)]>
        <link rel="stylesheet" href="https://zdnet4.cbsistatic.com/fly/1080-fly/css/core/ie8-159624f3f9-rev.css" media="screen">
        <![endif]--><script type="text/javascript">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</script><!-- Start of Soasta mPulse Script --><script>
(function(){
    if (window.BOOMR && window.BOOMR.version) { return; }
    var dom, doc, where, iframe = document.createElement("iframe"), win = window;

    function boomerangSaveLoadTime(e) {
        win.BOOMR_onload=(e && e.timeStamp) || new Date().getTime();
    }

    if (win.addEventListener) {
        win.addEventListener("load", boomerangSaveLoadTime, false);
    } else if (win.attachEvent) {
        win.attachEvent("onload", boomerangSaveLoadTime);
    }

    iframe.src = "javascript:void(0)";
    iframe.title = "";
    iframe.role = "presentation";
    (iframe.frameElement || iframe).style.cssText = "width:0;height:0;border:0;display:none;";
    where = document.getElementsByTagName("script")[0];
    where.parentNode.insertBefore(iframe, where);

    try {
        doc = iframe.contentWindow.document;
    } catch(e) {
        dom = document.domain;
        iframe.src = "javascript:var d=document.open();d.domain='"+dom+"';void(0);";
        doc = iframe.contentWindow.document;
    }

    doc.open()._l = function() {
        var js = this.createElement("script");
        if (dom) { this.domain = dom; }
        js.id = "boomr-if-as";
        js.src = "//c.go-mpulse.net/boomerang/" +
        "YZ2TK-PC7PJ-K64DL-L53CR-P2G4E";
        BOOMR_lstart = new Date().getTime();
        this.body.appendChild(js);
    };
    doc.write('<body onload="document._l();">');
    doc.close();
})();
</script><!-- End of Soasta mPulse Script --><script type="text/javascript" async src="//js-sec.indexww.com/ht/ls-zdnet.js"></script><script src="https://zdnet1.cbsistatic.com/fly/bundles/zdnetjs/js/libs/mpulse-1.0.2.js"></script><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--><link rel="alternate" type="application/rss+xml" title="Latest stories for ZDNet related to US" href="http://www.zdnet.com/us/rss.xml"></head><body class="	
">

    <div id="cookie-policy" class="alert optBeta" data-component="cookiePolicy">
	<p>
		<a class="close" data-close="cookie-policy">
			<svg viewbox="0 0 28 28"><polygon points="28,1.9 26.1,0 14,12.1 1.9,0 0,1.9 12.1,14 0,26.1 1.9,28 14,15.9 26.1,28 28,26.1 15.9,14 	"></polygon></svg></a>
		This web site uses cookies to improve your experience. By viewing our content, you are accepting the use of cookies. To find out more and change your cookie settings, please
		<a href="http://legalterms.cbsinteractive.com/cookies" target="_blank">view our cookie policy</a>.
	</p>
</div>
            <svg class="svg-symbol"><symbol id="comment-bubble" viewbox="0 0 32 27.4"><path d="M16,0c8.8,0,16,5.3,16,11.9c0,2.9-2.2,6.3-4.6,8.3l2.3,7.2l-6.9-4.7c-2.1,0.7-4.3,1.1-6.8,1.1
        c-8.8,0-16-5.3-16-11.9C0,5.3,7.2,0,16,0z"></path></symbol><symbol id="email" viewbox="0 0 32 21"><g><polygon points="32,19.5 32,1.3 23.1,10.4"></polygon></g><g><path d="M16.9,13.8L30.4,0h-29l13.5,13.9C15.4,14.4,16.3,14.4,16.9,13.8z"></path></g><g><polygon points="0,1.5 0,19.4 8.7,10.5"></polygon></g><g><path d="M18.3,15.3c-0.7,0.7-1.6,1-2.4,1c-0.9,0-1.7-0.3-2.4-1L10.2,12l-8.8,9h29.2l-8.9-9.2L18.3,15.3z"></path></g><g><polygon points="32,21 32,21 32,21"></polygon></g></symbol><symbol id="facebook" viewbox="0 0 15.2 32"><path d="M15.2,11.1H9.6V7c0-1.2,1.3-1.5,1.9-1.5c0.6,0,3.6,0,3.6,0V0L11,0C5.4,0,4.1,4.1,4.1,6.7v4.4H0v5.6h4.1
        c0,7.3,0,15.2,0,15.2h5.5c0,0,0-8.1,0-15.2h4.7L15.2,11.1z"></path></symbol><symbol id="googleplus" viewbox="0 0 32 32"><path d="M18.8,1c1.1-0.6,1.6-1,1.6-1H9.9C7.8,0,2,2.4,2,7.9c0,5.5,6,6.7,8.2,6.6C9,16,10,17.4,10.7,18.1
        c0.7,0.7,0.5,0.9-0.3,0.9C9.7,19,0,19.1,0,26s12.8,7.4,17.1,3.7s3.3-8.9,0-11.2c-3.3-2.3-4.5-3.4-2.4-5.3
        c2.1-1.8,3.7-3.3,3.7-6.8s-2.8-5.2-2.8-5.2S17.7,1.6,18.8,1z M17.1,25.7c0,3-2.5,4.4-6.8,4.4c-4.3,0-6.6-2.1-6.6-5.4
        c0-3.2,3.1-4.8,9-4.8C14.3,21.2,17.1,22.7,17.1,25.7z M10.9,13.2c-5.2,0-7.5-12.1-1.4-12.1C14.2,0.9,17.8,13.2,10.9,13.2z
         M28.1,4V0.1h-2V4h-4v2h4V10h2V6.1H32V4H28.1z"></path></symbol><symbol id="linkedin" viewbox="0 0 31.9 32"><path d="M24,8c-5.1,0.1-7.7,3.8-8,4V8h-6v24h6V18c0-0.5,1.3-4.6,6-4c2.5,0.2,3.9,3.5,4,4v14l6,0V15.4
        C31.7,13,30.5,8.1,24,8z M0,32h6V8H0V32z M3,0C1.3,0,0,1.3,0,3s1.3,3,3,3c1.7,0,3-1.3,3-3S4.7,0,3,0z"></path></symbol><symbol id="more" viewbox="0 0 32 7.3"><circle cx="3.7" cy="3.7" r="3.7"></circle><circle cx="16" cy="3.7" r="3.7"></circle><circle cx="28.3" cy="3.7" r="3.7"></circle></symbol><symbol id="pinterest" viewbox="0 0 24.9 32"><path d="M13.2,0C4.4,0,0,6.3,0,11.5c0,3.2,1.2,6,3.8,7c0.4,0.2,0.8,0,0.9-0.5c0.1-0.3,0.3-1.1,0.4-1.5
        c0.1-0.5,0.1-0.6-0.3-1c-0.7-0.9-1.2-2-1.2-3.6c0-4.6,3.5-8.8,9.1-8.8c5,0,7.7,3,7.7,7c0,5.3-2.4,9.8-5.9,9.8
        c-1.9,0-3.4-1.6-2.9-3.5c0.6-2.3,1.6-4.8,1.6-6.5c0-1.5-0.8-2.8-2.5-2.8c-2,0-3.6,2-3.6,4.8c0,1.7,0.6,2.9,0.6,2.9s-2,8.5-2.4,10
        c-0.7,3-0.1,6.6-0.1,7c0,0.2,0.3,0.3,0.4,0.1c0.2-0.2,2.5-3.1,3.3-6c0.2-0.8,1.3-5.1,1.3-5.1c0.6,1.2,2.5,2.3,4.5,2.3
        c5.9,0,10-5.4,10-12.6C24.9,5.1,20.3,0,13.2,0z"></path></symbol><symbol id="reddit" viewbox="0 0 32 26.7"><path d="M22.9,14.5C23,14.7,23,15,23,15.2c0,0.4-0.2,0.9-0.4,1.2c-0.3,0.3-0.6,0.6-1,0.7h0c0,0,0,0,0,0c0,0,0,0,0,0
        c-0.2,0.1-0.4,0.1-0.6,0.1c-0.5,0-0.9-0.2-1.3-0.5c-0.4-0.3-0.6-0.7-0.7-1.2c0,0,0,0,0,0c0,0,0,0,0,0h0c0-0.1,0-0.2,0-0.4
        c0-0.4,0.1-0.8,0.4-1.2c0.2-0.3,0.6-0.6,1-0.7c0,0,0,0,0,0c0,0,0,0,0,0c0.2-0.1,0.5-0.1,0.7-0.1c0.4,0,0.8,0.1,1.2,0.4
        C22.5,13.8,22.7,14.1,22.9,14.5C22.9,14.5,22.9,14.5,22.9,14.5C22.9,14.5,22.9,14.5,22.9,14.5L22.9,14.5z M21.6,19.7
        c-0.2-0.1-0.4-0.2-0.6-0.2c-0.2,0-0.3,0-0.5,0.1c-1.4,0.8-3.1,1.3-4.7,1.3c-1.2,0-2.5-0.3-3.6-0.8l0,0l0,0
        c-0.2-0.1-0.4-0.2-0.6-0.4c-0.1-0.1-0.2-0.1-0.3-0.2c-0.1-0.1-0.3-0.1-0.4-0.1c-0.1,0-0.2,0-0.4,0.1c0,0,0,0,0,0
        c-0.2,0.1-0.3,0.2-0.4,0.4c-0.1,0.2-0.2,0.4-0.2,0.6c0,0.2,0,0.3,0.1,0.5c0.1,0.1,0.2,0.3,0.4,0.4c1.6,1.1,3.5,1.6,5.4,1.6
        c1.7,0,3.4-0.4,4.9-1.1l0,0l0,0c0.2-0.1,0.5-0.2,0.7-0.4c0.1-0.1,0.2-0.2,0.4-0.3c0.1-0.1,0.2-0.3,0.2-0.4c0-0.1,0-0.2,0-0.2
        c0-0.1,0-0.3-0.1-0.4C21.9,19.9,21.8,19.8,21.6,19.7L21.6,19.7z M10.4,17.1C10.4,17.1,10.4,17.1,10.4,17.1
        c0.2,0.1,0.4,0.1,0.6,0.1c0.5,0,1-0.2,1.4-0.6c0.4-0.3,0.6-0.8,0.6-1.4c0,0,0,0,0,0c0,0,0-0.1,0-0.1c0-0.6-0.3-1-0.6-1.4
        c-0.4-0.3-0.9-0.6-1.4-0.6c-0.1,0-0.3,0-0.4,0c0,0,0,0,0,0h0c-0.7,0.1-1.3,0.7-1.5,1.4c0,0,0,0,0,0C9,14.8,9,15,9,15.2
        c0,0.4,0.1,0.9,0.4,1.2C9.6,16.7,10,17,10.4,17.1C10.4,17.1,10.4,17.1,10.4,17.1L10.4,17.1z M32,12.1L32,12.1c0,0.1,0,0.1,0,0.2
        c0,0.8-0.2,1.5-0.7,2.2c-0.4,0.6-0.9,1.1-1.5,1.4c0,0.3,0.1,0.6,0.1,0.9c0,1.7-0.6,3.3-1.6,4.6v0h0c-1.9,2.5-4.7,3.9-7.6,4.7l0,0
        c-1.5,0.4-3.1,0.6-4.7,0.6c-2.4,0-4.7-0.4-6.9-1.3v0h0c-2.3-0.9-4.5-2.4-5.8-4.6c-0.7-1.2-1.1-2.5-1.1-3.9c0-0.3,0-0.6,0.1-0.9
        c-0.6-0.3-1.1-0.8-1.5-1.4C0.3,13.9,0,13.2,0,12.4v0c0-1.1,0.5-2.1,1.2-2.8c0.7-0.7,1.7-1.2,2.8-1.2h0c0.1,0,0.2,0,0.3,0
        c0.5,0,1.1,0.1,1.6,0.3l0,0h0C6.3,8.8,6.8,9,7.1,9.3c0.1-0.1,0.3-0.1,0.4-0.2c2.3-1.4,5-1.9,7.6-2c0-1.3,0.2-2.7,0.8-3.8
        c0.5-1,1.4-1.8,2.5-2l0,0h0c0.4-0.1,0.8-0.1,1.2-0.1c1.1,0,2.2,0.3,3.2,0.7c0.5-0.7,1.1-1.2,1.9-1.5l0,0l0,0
        C25.3,0.1,25.8,0,26.2,0c0.5,0,1,0.1,1.5,0.3v0c0,0,0,0,0,0c0,0,0,0,0,0C28.4,0.6,29,1,29.4,1.6C29.8,2.2,30,3,30,3.7
        c0,0.1,0,0.3,0,0.4l0,0c0,0,0,0,0,0c-0.1,1-0.6,1.8-1.2,2.4c-0.7,0.6-1.6,1-2.5,1c-0.1,0-0.3,0-0.4,0c-0.9-0.1-1.8-0.5-2.4-1.2
        c-0.6-0.7-1-1.5-1-2.5c0,0,0-0.1,0-0.1C21.6,3.3,20.7,3,19.8,3c-0.1,0-0.3,0-0.4,0h0c-0.7,0.1-1.3,0.5-1.6,1.1v0
        c-0.5,0.9-0.6,1.9-0.6,3c2.6,0.2,5.2,0.8,7.4,2.1h0l0,0c0,0,0.1,0.1,0.2,0.1C25,9.2,25.2,9,25.4,8.9c0.7-0.5,1.5-0.7,2.3-0.7
        c0.4,0,0.7,0,1.1,0.1h0l0,0c0,0,0,0,0,0c0.8,0.2,1.6,0.7,2.2,1.3C31.5,10.4,31.9,11.2,32,12.1L32,12.1L32,12.1z M24.4,3.6
        c0,0,0,0.1,0,0.1v0c0,0.4,0.2,0.9,0.6,1.2c0.3,0.3,0.8,0.5,1.2,0.5h0c0,0,0.1,0,0.1,0c0.4,0,0.9-0.2,1.2-0.5
        C27.8,4.6,28,4.2,28,3.8v0c0,0,0-0.1,0-0.1c0-0.5-0.2-0.9-0.6-1.2c-0.3-0.3-0.8-0.5-1.2-0.5c-0.1,0-0.3,0-0.4,0.1h0l0,0
        c-0.4,0.1-0.7,0.3-1,0.6C24.6,2.9,24.4,3.2,24.4,3.6L24.4,3.6z M5.4,10.5c-0.3-0.2-0.7-0.3-1.1-0.3c-0.1,0-0.1,0-0.2,0h0l0,0
        c-0.5,0-1,0.2-1.4,0.6c-0.4,0.4-0.6,0.8-0.7,1.4v0l0,0c0,0,0,0.1,0,0.1c0,0.3,0.1,0.6,0.3,0.9c0.1,0.2,0.3,0.4,0.5,0.6
        C3.4,12.6,4.3,11.5,5.4,10.5L5.4,10.5z M27.8,16.9c0-1.2-0.4-2.3-1.1-3.2c-1.3-1.9-3.4-3.1-5.6-3.8l0,0c-0.4-0.1-0.8-0.2-1.3-0.3
        c-1.3-0.3-2.6-0.4-3.9-0.4c-1.7,0-3.5,0.3-5.2,0.8c-2.2,0.7-4.3,1.9-5.6,3.8v0c-0.7,0.9-1.1,2.1-1.1,3.3c0,0.4,0.1,0.9,0.2,1.3
        l0,0c0.2,0.9,0.7,1.8,1.3,2.5c0.6,0.7,1.4,1.3,2.2,1.8c0.2,0.1,0.4,0.2,0.5,0.3c2.3,1.3,5,1.9,7.6,1.9c0.4,0,0.9,0,1.3,0
        c2.7-0.2,5.3-1,7.5-2.6v0c0.7-0.5,1.3-1.1,1.8-1.8c0.5-0.7,0.9-1.5,1-2.3v0C27.8,17.5,27.8,17.2,27.8,16.9L27.8,16.9z M29.9,12.3
        c0-0.3-0.1-0.6-0.2-0.8l0,0l0,0c-0.2-0.4-0.5-0.7-0.8-0.9c-0.4-0.2-0.8-0.3-1.2-0.3c-0.4,0-0.7,0.1-1.1,0.3c1.1,0.9,2,2,2.6,3.3
        c0.2-0.2,0.4-0.4,0.5-0.6C29.8,13,29.9,12.6,29.9,12.3L29.9,12.3z M29.9,12.3"></path></symbol><symbol id="stumble" viewbox="0 0 32 24"><path d="M17.8,8.6l2.1,1.5l3.3-1.5l0-1.6C23,3.3,19.9,0,16,0c-3.8,0-7,3.2-7.1,6.9v9.9c0,0.9-0.8,1.6-1.7,1.6
        c-0.9,0-1.9-0.4-1.9-1.3V12H0c0,0,0,5.1,0,5.1C0,20.9,3.2,24,7.1,24c3.9,0,7.1-3.1,7.1-6.9V6.9c0-0.9,0.8-1.7,1.8-1.7
        c0.9,0,1.8,0.8,1.8,1.7V8.6z M26.7,12v5.1c0,0.9-1,1.5-1.9,1.5c-0.9,0-1.7-0.7-1.7-1.6l0-5l-3.3,1.6L17.8,12v5.1
        c0,3.8,3.2,6.9,7.1,6.9c3.9,0,7.1-3.1,7.1-6.9c0,0,0-5.1,0-5.1H26.7z"></path></symbol><symbol id="tumblr" viewbox="0 0 20.9 32"><path d="M7,0C6.8,1.8,6.7,2.4,6.1,3.6C5.5,4.7,4.7,6.2,3.7,7.1C2.8,7.9,1.4,8.7,0,9.2v5.5h4.1v8.9
        c0,1.6,0.2,2.8,0.5,3.6c0.3,0.8,0.9,1.6,1.8,2.4c0.9,0.7,2.8,1.7,2.8,1.7s1.6,0.6,3.2,0.6c1.4,0,2.7-0.1,4-0.4c1.2-0.3,3-1,4.6-1.7
        v-5.5c-1.8,1.1-4,1.9-5.8,1.9c-1,0-1.9-0.2-2.7-0.7c-0.6-0.3-1-0.8-1.2-1.4c-0.2-0.6-0.7-1.9-0.7-3.9v-5.7H19V8.6h-8.5V0H7z"></path></symbol><symbol id="twitter" viewbox="0 0 32.5 28.4"><path d="M32.5,3.4c-0.5,0.3-2.2,1-3.7,1.1c1-0.6,2.4-2.4,2.8-3.9c-0.9,0.6-3.1,1.6-4.2,1.6c0,0,0,0,0,0
        C26.1,0.9,24.4,0,22.5,0c-3.7,0-6.7,3.2-6.7,7.2c0,0.6,0.1,1.1,0.2,1.6h0C11,8.7,5.1,6,1.8,1.3c-2,3.8-0.3,8,2,9.5
        c-0.8,0.1-2.2-0.1-2.9-0.8c0,2.5,1.1,5.8,5.2,7c-0.8,0.5-2.2,0.3-2.8,0.2c0.2,2.1,3,4.9,6,4.9c-1.1,1.3-4.7,3.8-9.3,3
        c3.1,2,6.7,3.2,10.5,3.2c10.8,0,19.2-9.4,18.7-21.1c0,0,0,0,0,0c0,0,0-0.1,0-0.1c0,0,0-0.1,0-0.1C30.2,6.4,31.5,5.1,32.5,3.4z"></path></symbol><symbol id="yahoo" viewbox="-133 141 30.3 20"><path d="M-107.7,146.7c0,0,1.2-0.7,2.1-0.7s2.1,0,2.1,0l0.8-1.9h-12.9l0.1,1.4l0.8,0.4l3.3,0.1c0,0,0.2,0.7-0.3,1.1
        c-0.6,0.4-5.4,4.7-5.4,4.7l-6.2-7.5c0,0,0.1-0.2,1-0.2c0.9,0,3.5,0,3.5,0V141H-133v3.1c0,0,1.8,0,2.7,0c0.9,0,1.9,1,2.8,1.8
        c0.9,0.9,7.1,7.4,7.1,7.4v5.4c0,0-0.5,0.8-2.2,0.8c-1.8,0-2.5,0.1-2.5,0.1v1.4h14.1v-1c0,0-0.4-0.6-0.8-0.6h-3.4
        c-0.4,0-0.5-0.5-0.5-1.1c0-0.6,0-4.7,0-4.7L-107.7,146.7z"></path></symbol><symbol id="whatsapp" viewbox="0 0 32 32"><path d="M16.2,0C7.6,0,0.6,7,0.6,15.6c0,4.3,2.3,8.1,2.3,8.1L0.2,32l8.5-2.7c0,0,3.2,1.9,7.5,1.9
        c8.6,0,15.6-7,15.6-15.6C31.8,7,24.8,0,16.2,0z M16.2,28.7c-4,0-7.2-2.2-7.2-2.2l-4.9,1.6l1.6-4.8c0,0-2.6-3.5-2.6-7.8
        C3.1,8.4,9,2.5,16.2,2.5c7.2,0,13.1,5.9,13.1,13.1C29.3,22.8,23.5,28.7,16.2,28.7z"></path><path d="M10.3,8.8c0,0,0.4-0.3,0.6-0.3c0.2,0,1.2,0,1.2,0s0.3,0.1,0.5,0.4c0.2,0.3,1.2,2.8,1.3,3
        c0.1,0.2,0.3,0.7,0,1.1c-0.3,0.4-1,1.2-1,1.2s-0.3,0.2,0,0.6c0.2,0.4,1,1.6,2.1,2.6c1.1,1,2.4,1.7,3,1.9c0.7,0.2,0.8-0.1,1-0.4
        c0.2-0.3,1-1.3,1-1.3s0.3-0.4,0.8-0.2c0.5,0.2,3.1,1.5,3.1,1.5s0.3,0.1,0.3,0.4c0,0.3,0.2,1.4-0.7,2.4c-0.9,1-2.9,1.5-3.8,1.2
        c-0.9-0.3-4-1.1-6-2.9s-3.6-3.8-4.3-5.3c-0.7-1.5-0.6-2.3-0.6-2.7S9,9.6,10.3,8.8z"></path></symbol></svg><svg class="svg-symbol"><symbol id="stars-full" viewbox="0 0 14 14"><polygon points="7,0 8.8,5.1 14,5.3 9.9,8.7 11.3,14 7,11 2.7,14 4.1,8.7 0,5.3 5.2,5.1"></polygon></symbol><symbol id="stars-half" viewbox="0 0 14 14"><polygon points="7.1,0 7.1,11 2.7,14 4.1,8.7 0,5.3 5.2,5.1"></polygon></symbol><symbol id="play" viewbox="0 0 24 24"><path d="M21 12l-18 12v-24z"></path></symbol><symbol id="circle" viewbox="0 0 24 24"><circle cx="12" cy="12" r="12"></circle></symbol><symbol id="playOverlay" viewbox="-99 101 100 100"><g><circle cx="-50" cy="151" r="33"></circle></g><path class="playOverlayBorder" d="M-50,118c18.2,0,33,14.8,33,33s-14.8,33-33,33s-33-14.8-33-33S-68.2,118-50,118 M-50,116c-19.3,0-35,15.7-35,35  s15.7,35,35,35s35-15.7,35-35S-30.7,116-50,116L-50,116z"></path><g><path class="playOverlayArrow" d="M-60.3,138.6c0-2.2,1.5-3.1,3.4-1.9l19.8,12.2c1.9,1.2,1.9,3,0,4.2l-19.8,12.2c-1.9,1.2-3.4,0.3-3.4-1.9C-60.3,163.4-60.3,138.6-60.3,138.6z"></path></g></symbol><symbol id="play_alt" viewbox="0 0 24 24"><g><path d="M12 2c5.514 0 10 4.486 10 10s-4.486 10-10 10-10-4.486-10-10 4.486-10 10-10zm0-2c-6.627 0-12 5.373-12 12s5.373 12 12 12 12-5.373 12-12-5.373-12-12-12zm-2 7v10l7-5-7-5z"></path></g></symbol><symbol id="video" viewbox="0 0 32 22"><g><path d="M29,2.2c-0.7,0.2-4.6,3-7.9,5.3V2.1C21.1,1,20.1,0,19,0H2.1C1,0,0,1,0,2.1v17.7C0,21,1,22,2.1,22H19c1.2,0,2.1-1,2.1-2.1
        v-5.9c3.3,2.4,7.4,5.4,8.2,5.6c1.4,0.4,2.7-0.1,2.7-0.1V2.2C32,2.2,30.1,1.8,29,2.2z"></path></g></symbol><symbol id="video-alt" viewbox="0 0 24 24"><path d="M19.615 3.184c-3.604-.246-11.631-.245-15.23 0-3.897.266-4.356 2.62-4.385 8.816.029 6.185.484 8.549 4.385 8.816 3.6.245 11.626.246 15.23 0 3.897-.266 4.356-2.62 4.385-8.816-.029-6.185-.484-8.549-4.385-8.816zm-10.615 12.816v-8l8 3.993-8 4.007z"></path></symbol><symbol id="photo" viewbox="0 0 32 24"><path d="M30,4h-6c-0.5,0-2.9-4-4-4h-8c-1.1,0-3.6,4-4,4H2C0.9,4,0,4.9,0,6v16c0,1.1,0.9,2,2,2h28c1.1,0,2-0.9,2-2V6
            C32,4.9,31.1,4,30,4z M16,20.3c-3.9,0-7-3.1-7-7c0-3.9,3.1-7,7-7c3.9,0,7,3.1,7,7C23,17.2,19.9,20.3,16,20.3z M16,19
            c-3.1,0-5.6-2.5-5.6-5.6c0-3.1,2.5-5.6,5.6-5.6c3.1,0,5.6,2.5,5.6,5.6C21.6,16.5,19.1,19,16,19z"></path></symbol><symbol id="arrow-round" viewbox="0 0 16 28"><g><path d="M0.6,27.4c0.8,0.8,2,0.8,2.8,0l12-12c0.8-0.8,0.8-2,0-2.8l-12-12C3,0.2,2.5,0,2,0C1.5,0,1,0.2,0.6,0.6
        c-0.8,0.8-0.8,2,0,2.8L11.2,14L0.6,24.6C-0.2,25.4-0.2,26.6,0.6,27.4z"></path></g></symbol><symbol id="envelope" viewbox="0 0 24 24"><g><path d="M12 12.713l-11.985-9.713h23.97l-11.985 9.713zm0 2.574l-12-9.725v15.438h24v-15.438l-12 9.725z"></path></g></symbol><symbol id="envelope-open-solid"><svg viewbox="0 0 24 24"><path d="M.026 24l11.974-11.607 11.974 11.607h-23.948zm11.964-23.961l-11.99 8.725v12.476l7.352-7.127-5.653-4.113 10.291-7.488 10.309 7.488-5.655 4.108 7.356 7.132v-12.476l-12.01-8.725z"></path></svg></symbol><symbol id="envelope-open-outline"><svg viewbox="0 0 24 24"><path d="M11.99 0l-11.99 8.723v15.277h24v-15.277l-12.01-8.723zm.001 2.472l9.793 7.113-6.735 4.588-3.049-2.47-3.049 2.471-6.737-4.589 9.777-7.113zm-9.991 9.386l5.329 3.63-5.329 4.318v-7.948zm.474 10.142l9.526-7.723 9.526 7.723h-19.052zm19.526-2.194l-5.329-4.317 5.329-3.631v7.948z"></path></svg></symbol><symbol id="padlock"><svg viewbox="0 0 1792 1792"><path d="M640 768h512v-192q0-106-75-181t-181-75-181 75-75 181v192zm832 96v576q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-576q0-40 28-68t68-28h32v-192q0-184 132-316t316-132 316 132 132 316v192h32q40 0 68 28t28 68z"></path></svg></symbol><symbol id="settings"><svg viewbox="0 0 24 24"><path d="M24 13.616v-3.232c-1.651-.587-2.694-.752-3.219-2.019v-.001c-.527-1.271.1-2.134.847-3.707l-2.285-2.285c-1.561.742-2.433 1.375-3.707.847h-.001c-1.269-.526-1.435-1.576-2.019-3.219h-3.232c-.582 1.635-.749 2.692-2.019 3.219h-.001c-1.271.528-2.132-.098-3.707-.847l-2.285 2.285c.745 1.568 1.375 2.434.847 3.707-.527 1.271-1.584 1.438-3.219 2.02v3.232c1.632.58 2.692.749 3.219 2.019.53 1.282-.114 2.166-.847 3.707l2.285 2.286c1.562-.743 2.434-1.375 3.707-.847h.001c1.27.526 1.436 1.579 2.019 3.219h3.232c.582-1.636.75-2.69 2.027-3.222h.001c1.262-.524 2.12.101 3.698.851l2.285-2.286c-.744-1.563-1.375-2.433-.848-3.706.527-1.271 1.588-1.44 3.221-2.021zm-12 2.384c-2.209 0-4-1.791-4-4s1.791-4 4-4 4 1.791 4 4-1.791 4-4 4z"></path></svg></symbol><symbol id="bell" viewbox="0 0 24 24"><g><path d="M15.137 3.945c-.644-.374-1.042-1.07-1.041-1.82v-.003c.001-1.172-.938-2.122-2.096-2.122s-2.097.95-2.097 2.122v.003c.001.751-.396 1.446-1.041 1.82-4.667 2.712-1.985 11.715-6.862 13.306v1.749h20v-1.749c-4.877-1.591-2.195-10.594-6.863-13.306zm-3.137-2.945c.552 0 1 .449 1 1 0 .552-.448 1-1 1s-1-.448-1-1c0-.551.448-1 1-1zm3 20c0 1.598-1.392 3-2.971 3s-3.029-1.402-3.029-3h6z"></path></g></symbol><symbol id="user_alt" viewbox="0 0 24 24"><g><path d="M20.822 18.096c-3.439-.794-6.64-1.49-5.09-4.418 4.72-8.912 1.251-13.678-3.732-13.678-5.082 0-8.464 4.949-3.732 13.678 1.597 2.945-1.725 3.641-5.09 4.418-3.073.71-3.188 2.236-3.178 4.904l.004 1h23.99l.004-.969c.012-2.688-.092-4.222-3.176-4.935z"></path></g></symbol><symbol id="paperclip" viewbox="0 0 24 24"><g><path d="M21.586 10.461l-10.05 10.075c-1.95 1.949-5.122 1.949-7.071 0s-1.95-5.122 0-7.072l10.628-10.585c1.17-1.17 3.073-1.17 4.243 0 1.169 1.17 1.17 3.072 0 4.242l-8.507 8.464c-.39.39-1.024.39-1.414 0s-.39-1.024 0-1.414l7.093-7.05-1.415-1.414-7.093 7.049c-1.172 1.172-1.171 3.073 0 4.244s3.071 1.171 4.242 0l8.507-8.464c.977-.977 1.464-2.256 1.464-3.536 0-2.769-2.246-4.999-5-4.999-1.28 0-2.559.488-3.536 1.465l-10.627 10.583c-1.366 1.368-2.05 3.159-2.05 4.951 0 3.863 3.13 7 7 7 1.792 0 3.583-.684 4.95-2.05l10.05-10.075-1.414-1.414z"></path></g></symbol><symbol id="book" viewbox="0 0 24 24"><g><path d="M5.495 4c-1.375 0-1.375-2 0-2h16.505v-2h-17c-1.657 0-3 1.343-3 3v18c0 1.657 1.343 3 3 3h17v-20h-16.505z"></path></g></symbol><symbol id="caret" viewbox="0 0 16 28"><g><path d="M0.6,27.4c0.8,0.8,2,0.8,2.8,0l12-12c0.8-0.8,0.8-2,0-2.8l-12-12C3,0.2,2.5,0,2,0C1.5,0,1,0.2,0.6,0.6
        c-0.8,0.8-0.8,2,0,2.8L11.2,14L0.6,24.6C-0.2,25.4-0.2,26.6,0.6,27.4z"></path></g></symbol><symbol id="info" viewbox="0 0 24 24"><g><path d="M12 2c5.514 0 10 4.486 10 10s-4.486 10-10 10-10-4.486-10-10 4.486-10 10-10zm0-2c-6.627 0-12 5.373-12 12s5.373 12 12 12 12-5.373 12-12-5.373-12-12-12zm-.001 5.75c.69 0 1.251.56 1.251 1.25s-.561 1.25-1.251 1.25-1.249-.56-1.249-1.25.559-1.25 1.249-1.25zm2.001 12.25h-4v-1c.484-.179 1-.201 1-.735v-4.467c0-.534-.516-.618-1-.797v-1h3v6.265c0 .535.517.558 1 .735v.999z"></path></g></symbol><symbol id="mag-red" viewbox="0 0 26 26"><g><circle fill="none" stroke="#DE1400" stroke-miterlimit="10" cx="12.312" cy="12.312" r="10.804"></circle><line fill="none" stroke="#DE1400" stroke-miterlimit="10" x1="19.77" y1="19.77" x2="24.688" y2="24.688"></line></g></symbol><symbol id="close-gray" viewbox="0 0 26 26"><g><line fill="none" stroke="#768089" stroke-miterlimit="10" x1="1.426" y1="1.426" x2="24.688" y2="24.688"></line><line fill="none" stroke="#768089" stroke-miterlimit="10" x1="24.689" y1="1.426" x2="1.427" y2="24.688"></line></g></symbol><symbol id="info" viewbox="0 0 24 24"><path d="M12 2c5.514 0 10 4.486 10 10s-4.486 10-10 10-10-4.486-10-10 4.486-10 10-10zm0-2c-6.627 0-12 5.373-12 12s5.373 12 12 12 12-5.373 12-12-5.373-12-12-12zm-.001 5.75c.69 0 1.251.56 1.251 1.25s-.561 1.25-1.251 1.25-1.249-.56-1.249-1.25.559-1.25 1.249-1.25zm2.001 12.25h-4v-1c.484-.179 1-.201 1-.735v-4.467c0-.534-.516-.618-1-.797v-1h3v6.265c0 .535.517.558 1 .735v.999z"></path></symbol><symbol id="close" viewbox="0 0 28 28"><g><polygon points="28,1.9 26.1,0 14,12.1 1.9,0 0,1.9 12.1,14 0,26.1 1.9,28 14,15.9 26.1,28 28,26.1 15.9,14    "></polygon></g></symbol><symbol id="rss" viewbox="0 0 24 24"><path d="M6.503 20.752c0 1.794-1.456 3.248-3.251 3.248-1.796 0-3.252-1.454-3.252-3.248 0-1.794 1.456-3.248 3.252-3.248 1.795.001 3.251 1.454 3.251 3.248zm-6.503-12.572v4.811c6.05.062 10.96 4.966 11.022 11.009h4.817c-.062-8.71-7.118-15.758-15.839-15.82zm0-3.368c10.58.046 19.152 8.594 19.183 19.188h4.817c-.03-13.231-10.755-23.954-24-24v4.812z"></path></symbol><symbol id="download" viewbox="0 0 24 24"><path d="M16 11h5l-9 10-9-10h5v-11h8v11zm1 11h-10v2h10v-2z"></path></symbol><symbol id="users" viewbox="0 0 24 24"><path d="M10.118 16.064c2.293-.529 4.428-.993 3.394-2.945-3.146-5.942-.834-9.119 2.488-9.119 3.388 0 5.644 3.299 2.488 9.119-1.065 1.964 1.149 2.427 3.394 2.945 1.986.459 2.118 1.43 2.118 3.111l-.003.825h-15.994c0-2.196-.176-3.407 2.115-3.936zm-10.116 3.936h6.001c-.028-6.542 2.995-3.697 2.995-8.901 0-2.009-1.311-3.099-2.998-3.099-2.492 0-4.226 2.383-1.866 6.839.775 1.464-.825 1.812-2.545 2.209-1.49.344-1.589 1.072-1.589 2.333l.002.619z"></path></symbol></svg><header id="mainHeader" class="page-header"><div id="secondary">
            <div class="editions">
                <ul><li class="editionsDrop">
                        <a aria-haspopup="true" class="arrow">
                            Edition: <span data-label="edition"></span>
                        </a>
                        
<ul data-component="editionToggler" class="menu-editions"><li>
        <a class="editionSwitch" data-edition="as" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Asia
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="au" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Australia
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="eu" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Europe
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="in" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            India
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="uk" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            United Kingdom
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="us" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            United States
        </a>
    </li>

    <li class="subDiv"><span class="label">ZDNet around the globe:</span></li>
                    <li class="subDiv">
        <a href="http://www.zdnet.be/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Belgium
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.com.cn/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet China
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.fr/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet France
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.de/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Germany
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.co.kr/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Korea
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://japan.zdnet.com/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Japan
        </a>
    </li>

</ul></li>
                </ul></div>

                            <div class="headerTextAd">
                    

                        <div class="sponsored-text-link">
        <div id="sponsored-text-link-5a6f291459b15" class="ad-sponsored-text-link" data-ad="sponsored-text-link">
    <script>
        window.console && console.log && console.log("ADS: queuing sponsored-text-link-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("sponsored-text-link-5a6f291459b15");
    </script></div>

    </div>
                    </div>
                    </div>

        <div class="fixation" data-component="fixate" data-fixate-options='{"offset":{"top":0,"bottom":0},"guideTop":"#secondary"}'>
    
                    <div id="ticker-5a6f291459b15" class="ad-ticker" data-ad="ticker">
    <script>
        window.console && console.log && console.log("ADS: queuing ticker-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("ticker-5a6f291459b15");
    </script></div>

    
    <div id="primary" data-component="smartSearch">
        <a id="zdLogoLarge" title="ZDNet" href="/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Logo", "pageType": "article"}'>
            <svg class="svg-logo-header" viewbox="0 0 120 84" enable-background="new 0 0 120 84"><lineargradient id="zdlogo" gradientunits="userSpaceOnUse" x1="38.9038" y1="-1.7476" x2="38.9038" y2="81.0522" gradienttransform="matrix(0.9997 0.025 -0.025 0.9997 4.1309 1.418)"><stop offset="0" style="stop-color:#07111A;stop-opacity:0"></stop><stop offset="0.7998" style="stop-color:#07111A"></stop><stop offset="1" style="stop-color:#000000;stop-opacity:0"></stop></lineargradient><path opacity="0.4" fill="url(#zdlogo)" d="M81.783,59.255c1.078-0.467,1.573-1.732,1.106-2.81L59.259,2.28
	c-0.467-1.077-1.733-1.573-2.811-1.102L2.281,24.8c-1.076,0.47-1.574,1.734-1.104,2.813l23.627,54.168
	c0.472,1.075,1.736,1.571,2.813,1.103L81.783,59.255z"></path><path fill="#DE1400" d="M75.949,56.728c0.919-0.399,1.343-1.479,0.943-2.398L56.731,8.114c-0.399-0.919-1.479-1.342-2.4-0.941
			L8.116,27.329c-0.918,0.401-1.343,1.48-0.942,2.4l20.16,46.216c0.402,0.919,1.481,1.343,2.4,0.941L75.949,56.728z"></path><path fill="#FFFFFF" d="M53.456,23.18H42.001v19.714h-13.74L41.573,23.18H21.364l-3.731,5.568h12.238l-13.38,19.714H43.77
				l4.803-7.087V28.748h3.677c4.225,0,7.208,2.544,7.208,7.071c0,4.932-3.354,7.075-7.276,7.075h-2.904v5.568h4.178
				c7.006,0,12.842-5.534,12.842-12.643S60.498,23.18,53.456,23.18z"></path><path fill="#D4DEE4" d="M68.52,22.892h5.684l4.872,10.188c1.287,2.712,2.274,5.389,2.786,7.219c-0.185-1.978-0.366-5.241-0.403-7
			L81.35,22.892h4.874v25.473H80.87l-4.359-9.751c-1.391-3.188-2.97-6.778-3.447-8.355c0.186,2.09,0.225,5.096,0.258,7.221
			l0.147,10.886H68.52V22.892z"></path><path fill="#D4DEE4" d="M102.745,43.38l1.906,2.933c-2.163,1.757-4.436,2.604-7.074,2.604c-5.388,0-8.869-3.812-8.869-9.714
			c0-3.371,0.695-5.608,2.344-7.442c1.541-1.722,3.41-2.53,5.902-2.53c2.161,0,4.216,0.734,5.423,1.983
			c1.722,1.758,2.493,4.287,2.493,8.211c0,0.4,0,0.546,0,1.133H94.02v0.148c0,2.893,1.432,4.544,3.961,4.544
			C99.667,45.25,101.242,44.627,102.745,43.38z M94.096,36.966h5.682v-0.219c0-1.392-0.147-2.126-0.588-2.824
			c-0.479-0.732-1.174-1.1-2.163-1.1c-1.867,0-2.931,1.466-2.931,4.07V36.966z"></path><path fill="#D4DEE4" d="M117.733,29.564l-1.244,3.258h-3.153v9.57c0,2.382,0.44,3.007,2.127,3.007c0.439,0,0.878-0.114,1.76-0.37
			l0.623,2.931c-1.429,0.589-2.714,0.846-3.995,0.846c-2.492,0-4.51-1.101-5.059-2.748c-0.293-0.808-0.33-1.176-0.33-2.897V32.822
			h-1.869v-3.187h1.869c0-1.832,0-3.077,0.186-4.47l4.981-1.247c-0.186,1.721-0.293,3.739-0.293,5.645H117.733z"></path></svg></a>
        <div class="searchLarge">
            <a data-item="trigger" class="searchTrigger hide-text">Search</a>
            <div class="dropDown">
                
<div class="container search-overlay-container">
    <form class="headerSearch active" method="get" action="/search/">
        <div class="box">
            <input type="search" title="query" autocomplete="off" placeholder="What are you looking for?" tabindex="1" name="q" value="" class="search-expand smart-search-input"><button type="submit" class="search-button" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Search", "pageType": "article"}'>
                    <svg class=" mag-red"><use xlink:href="#mag-red"></use></svg><span class="search-go">Go</span>
            </button>
        </div>
    </form>

    <div class="smart-search-results">
        <span class="closeDropdown screen-large" data-item="close">
                <svg class=" close-gray"><use xlink:href="#close-gray"></use></svg></span>
        <div class="smart-search-results-list"></div>
        <div class="smart-search-trending-content"></div>
                </div>
</div>            </div>
        </div>
        
<nav class="primaryNav" data-component="headerNav"><ul class="navList"><li class="alpha"><a href="/video/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Videos
            </a></li><li class="beta"><a href="/topic/smart-cities/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Smart Cities
            </a></li><li class="gamma"><a href="/topic/windows-10/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Windows 10
            </a></li><li class="delta"><a href="/topic/cloud/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Cloud
            </a></li><li class="epsilon"><a href="/topic/innovation/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Innovation
            </a></li><li class=""><a href="/topic/security/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Security
            </a></li><li class=""><a href="http://www.techproresearch.com/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Tech Pro
            </a></li><li class="hasDrop"><a class="arrow moreText">more</a><ul class="menu-topics"><li class="alphaDrop"><a href="https://academy.zdnet.com/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                ZDNet Academy
            </a></li><li class=""><a href="/topic/digital-transformation/" digital transformation data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Digital Transformation
            </a></li><li class=""><a href="/topic/microsoft/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Microsoft
            </a></li><li class=""><a href="/topic/mobility/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Mobility
            </a></li><li class=""><a href="/topic/internet-of-things/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                IoT
            </a></li><li class=""><a href="/topic/hardware/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Hardware
            </a></li><li class=""><a href="https://www.cnet.com/best-vpn-services-directory/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Best VPN Services
            </a></li><li class="seeAll"><a href="/topic/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                See All Topics 
            </a></li><li class="subDiv"><a href="http://www.techrepublic.com/resource-library/whitepapers/" target="'_blank'" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                White Papers
            </a></li><li class="subDiv"><a href="//downloads.zdnet.com/" data-download-link="'true'" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Downloads
            </a></li><li class="subDiv"><a href="/reviews/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}' data-vanity-rewritten="true">
                Reviews
            </a></li><li class="subDiv"><a href="/pictures/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Galleries
            </a></li><li class="subDiv"><a href="/video/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Videos
            </a></li></ul></li><li><a href="/newsletters/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Newsletter", "pageType": "article"}' class="linkAlt" data-vanity-rewritten="true">Newsletters</a></li><li><a href="/blog/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-AllWriters", "pageType": "article"}' class="linkAlt">All Writers</a></li><li class="hasDrop"><a class="linkAlt"><span class="zduser"><svg class=" user_alt"><use xlink:href="#user_alt"></use></svg></span></a><span class="loggedOut"><ul class="menu-user" data-component="userTracking"><li><a href="https://secure.zdnet.com/user/login/?appId=1101" rel="nofollow" data-user-show='{"action":"login","params":{"appId":1101,"position":"Header"}}'>Log In to ZDNET</a></li><li><a href="https://secure.zdnet.com/user/registration/?appId=1101" rel="nofollow" data-user-show='{"action":"register","params":{"appId":1101,"position":"Header"}}'>Join ZDNet</a></li><li><a href="/about/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "header-about", "pageType": "article"}' data-vanity-rewritten="true">About ZDNet</a></li></ul></span><span class="loggedIn"><ul class="menu-user"><li><a href="https://secure.zdnet.com/members/preferences/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "header-personicon-manage", "pageType": "article"}' rel="nofollow">Preferences</a></li><li><a href="https://secure.zdnet.com/members/community/" rel="nofollow">Community</a></li><li><a href="https://secure.zdnet.com/members/newsletters/" rel="nofollow">Newsletters</a></li><li><a href="http://www.zdnet.com/user/logout/" data-omniture-track="trackLogout" data-omniture-track-data='{"moduleInfo": "header-personicon", "pageType": "article"}' rel="nofollow" data-user-action="logout">Log Out</a></li></ul></span></li>    </ul><ul class="navListMobile"><li class="backgroundLogo">
        <a id="zdLogoSmall" href="/" title="ZDNet">
            <svg class="svg-logo-header" viewbox="0 0 120 84" enable-background="new 0 0 120 84"><lineargradient id="zdlogo" gradientunits="userSpaceOnUse" x1="38.9038" y1="-1.7476" x2="38.9038" y2="81.0522" gradienttransform="matrix(0.9997 0.025 -0.025 0.9997 4.1309 1.418)"><stop offset="0" style="stop-color:#07111A;stop-opacity:0"></stop><stop offset="0.7998" style="stop-color:#07111A"></stop><stop offset="1" style="stop-color:#000000;stop-opacity:0"></stop></lineargradient><path opacity="0.4" fill="url(#zdlogo)" d="M81.783,59.255c1.078-0.467,1.573-1.732,1.106-2.81L59.259,2.28
	c-0.467-1.077-1.733-1.573-2.811-1.102L2.281,24.8c-1.076,0.47-1.574,1.734-1.104,2.813l23.627,54.168
	c0.472,1.075,1.736,1.571,2.813,1.103L81.783,59.255z"></path><path fill="#DE1400" d="M75.949,56.728c0.919-0.399,1.343-1.479,0.943-2.398L56.731,8.114c-0.399-0.919-1.479-1.342-2.4-0.941
			L8.116,27.329c-0.918,0.401-1.343,1.48-0.942,2.4l20.16,46.216c0.402,0.919,1.481,1.343,2.4,0.941L75.949,56.728z"></path><path fill="#FFFFFF" d="M53.456,23.18H42.001v19.714h-13.74L41.573,23.18H21.364l-3.731,5.568h12.238l-13.38,19.714H43.77
				l4.803-7.087V28.748h3.677c4.225,0,7.208,2.544,7.208,7.071c0,4.932-3.354,7.075-7.276,7.075h-2.904v5.568h4.178
				c7.006,0,12.842-5.534,12.842-12.643S60.498,23.18,53.456,23.18z"></path><path fill="#D4DEE4" d="M68.52,22.892h5.684l4.872,10.188c1.287,2.712,2.274,5.389,2.786,7.219c-0.185-1.978-0.366-5.241-0.403-7
			L81.35,22.892h4.874v25.473H80.87l-4.359-9.751c-1.391-3.188-2.97-6.778-3.447-8.355c0.186,2.09,0.225,5.096,0.258,7.221
			l0.147,10.886H68.52V22.892z"></path><path fill="#D4DEE4" d="M102.745,43.38l1.906,2.933c-2.163,1.757-4.436,2.604-7.074,2.604c-5.388,0-8.869-3.812-8.869-9.714
			c0-3.371,0.695-5.608,2.344-7.442c1.541-1.722,3.41-2.53,5.902-2.53c2.161,0,4.216,0.734,5.423,1.983
			c1.722,1.758,2.493,4.287,2.493,8.211c0,0.4,0,0.546,0,1.133H94.02v0.148c0,2.893,1.432,4.544,3.961,4.544
			C99.667,45.25,101.242,44.627,102.745,43.38z M94.096,36.966h5.682v-0.219c0-1.392-0.147-2.126-0.588-2.824
			c-0.479-0.732-1.174-1.1-2.163-1.1c-1.867,0-2.931,1.466-2.931,4.07V36.966z"></path><path fill="#D4DEE4" d="M117.733,29.564l-1.244,3.258h-3.153v9.57c0,2.382,0.44,3.007,2.127,3.007c0.439,0,0.878-0.114,1.76-0.37
			l0.623,2.931c-1.429,0.589-2.714,0.846-3.995,0.846c-2.492,0-4.51-1.101-5.059-2.748c-0.293-0.808-0.33-1.176-0.33-2.897V32.822
			h-1.869v-3.187h1.869c0-1.832,0-3.077,0.186-4.47l4.981-1.247c-0.186,1.721-0.293,3.739-0.293,5.645H117.733z"></path></svg></a>
    </li>

        <li class="searchMobileWrapper">
        <a data-item="trigger" class="search-trigger">
            <svg viewbox="0 0 16 16"><g><path class="st1" d="M15.9,14.3l-3.5-3.5c0.7-1.1,1.1-2.4,1.1-3.8c0-3.8-3-6.9-6.7-6.9C3,0,0,3.1,0,6.9s3,6.9,6.7,6.9
        c1.6,0,3-0.5,4.1-1.5l3.5,3.5c0.1,0.1,0.2,0.1,0.3,0.1c0,0,0,0,0,0c0.1,0,0.3-0.1,0.3-0.2l0.8-0.9C16,14.8,16,14.5,15.9,14.3z
         M6.7,11.6c-2.6,0-4.6-2.1-4.6-4.7s2.1-4.7,4.6-4.7c2.6,0,4.6,2.1,4.6,4.7S9.3,11.6,6.7,11.6z"></path></g></svg></a>
        <ul class="dropDown forSearch"><li>
                <div class="searchSmall">
                    
<div class="container search-overlay-container">
    <form class="headerSearch active" method="get" action="/search/">
        <div class="box">
            <input type="search" title="query" autocomplete="off" placeholder="What are you looking for?" tabindex="1" name="q" value="" class="search-expand smart-search-input"><button type="submit" class="search-button" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Search", "pageType": "article"}'>
                    <svg class=" mag-red"><use xlink:href="#mag-red"></use></svg><span class="search-go">Go</span>
            </button>
        </div>
    </form>

    <div class="smart-search-results">
        <span class="closeDropdown screen-large" data-item="close">
                <svg class=" close-gray"><use xlink:href="#close-gray"></use></svg></span>
        <div class="smart-search-results-list"></div>
        <div class="smart-search-trending-content"></div>
                </div>
</div>                </div>
            </li>
        </ul><span class="closeDropdown screen-small" data-item="close">
                <svg class=" close-gray"><use xlink:href="#close-gray"></use></svg></span>
    </li>

        <li data-component="dropdown">
        <a data-item="trigger">Menu</a>

        <ul class="dropDown mobileLinks"><li class="alpha">
            <a href="/video/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Videos
            </a>
        </li>
    
                                                        
                
        
                                    <li class="beta">
            <a href="/topic/smart-cities/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Smart Cities
            </a>
        </li>
    
                                                        
                
        
                                    <li class="gamma">
            <a href="/topic/windows-10/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Windows 10
            </a>
        </li>
    
                                                        
                
        
                                    <li class="delta">
            <a href="/topic/cloud/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Cloud
            </a>
        </li>
    
                                                        
                
        
                                    <li class="epsilon">
            <a href="/topic/innovation/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Innovation
            </a>
        </li>
    
                                    
                
        
                                    <li class="">
            <a href="/topic/security/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Security
            </a>
        </li>
    
                                    
                
        
                                    <li class="">
            <a href="http://www.techproresearch.com/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Tech Pro
            </a>
        </li>
    
                                                        
                                    
        
                            
                                    <li class="alphaDrop">
            <a href="https://academy.zdnet.com/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                ZDNet Academy
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="/topic/digital-transformation/" digital transformation data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Digital Transformation
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="/topic/microsoft/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Microsoft
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="/topic/mobility/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Mobility
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="/topic/internet-of-things/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                IoT
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="/topic/hardware/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Hardware
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="https://www.cnet.com/best-vpn-services-directory/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Best VPN Services
            </a>
        </li>
    
    
                    <li class="seeAll">
            <a href="/topic/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                See All Topics 
            </a>
        </li>
    
                    <li class="subDiv">
            <a href="http://www.techrepublic.com/resource-library/whitepapers/" target="'_blank'" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                White Papers
            </a>
        </li>
    
                    <li class="subDiv">
            <a href="//downloads.zdnet.com/" data-download-link="'true'" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Downloads
            </a>
        </li>
    
                                <li class="subDiv">
            <a href="/reviews/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}' data-vanity-rewritten="true">
                Reviews
            </a>
        </li>
    
                    <li class="subDiv">
            <a href="/pictures/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Galleries
            </a>
        </li>
    
                    <li class="subDiv">
            <a href="/video/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Videos
            </a>
        </li>
    




        </ul></li>

        <li data-component="dropdown">
        <a class="zd-user" data-item="trigger">
            <span class="zduser">
                    <svg class=" user_alt"><use xlink:href="#user_alt"></use></svg></span>
        </a>

        <ul class="dropDown"><li>
                
<span class="loggedOut">
    <ul class="menu-user" data-component="userTracking"><li><a href="https://secure.zdnet.com/user/login/?appId=1101" rel="nofollow" data-user-show='{"action":"login","params":{"appId":1101,"position":"Header"}}'>Log In to ZDNET</a>
        </li>
        <li><a href="https://secure.zdnet.com/user/registration/?appId=1101" rel="nofollow" data-user-show='{"action":"register","params":{"appId":1101,"position":"Header"}}'>Join ZDNet</a></li>
        <li><a href="/about/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "header-about", "pageType": "article"}' data-vanity-rewritten="true">About ZDNet</a></li>
    </ul></span>

<span class="loggedIn">
    <ul class="menu-user"><li><a href="https://secure.zdnet.com/members/preferences/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "header-personicon-manage", "pageType": "article"}' rel="nofollow">Preferences</a></li>
        <li><a href="https://secure.zdnet.com/members/community/" rel="nofollow">Community</a></li>
        <li><a href="https://secure.zdnet.com/members/newsletters/" rel="nofollow">Newsletters</a></li>
        <li><a href="http://www.zdnet.com/user/logout/" data-omniture-track="trackLogout" data-omniture-track-data='{"moduleInfo": "header-personicon", "pageType": "article"}' rel="nofollow" data-user-action="logout">Log Out</a></li>
    </ul></span>
            </li>
        </ul></li>

        <li data-component="dropdown">
        
        <a data-item="trigger">us</a>

        <div class="dropDown">
            
<ul data-component="editionToggler" class="menu-editions"><li>
        <a class="editionSwitch" data-edition="as" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Asia
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="au" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Australia
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="eu" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Europe
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="in" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            India
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="uk" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            United Kingdom
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="us" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            United States
        </a>
    </li>

    <li class="subDiv"><span class="label">ZDNet around the globe:</span></li>
                    <li class="subDiv">
        <a href="http://www.zdnet.be/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Belgium
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.com.cn/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet China
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.fr/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet France
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.de/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Germany
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.co.kr/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Korea
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://japan.zdnet.com/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Japan
        </a>
    </li>

</ul></div>
    </li>
</ul></nav></div>

        </div>
</header><div class="intromercial">
        <div id="intromercial-5a6f291459b15" class="ad-intromercial" data-ad="intromercial">
    <script>
        window.console && console.log && console.log("ADS: queuing intromercial-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("intromercial-5a6f291459b15");
    </script></div>

    </div>
    

            <div class="hpto">
	
</div>
    
    
        <div data-item-id="2bef804e-d745-4057-b328-22fa9216f811">
    <div class="topContent container">
        <div class="breakingNewsContainer"></div>
                        <div class="row">
                <div class="row">
        <div class="col-12">
                                                    
                                                        
                                            

    <div data-component="loadAsync" data-load-async-options='{"url":"\/components\/breaking-news\/xhr\/","replace":true,"relocate":".breakingNewsContainer","data":{"slug":"breaking-news-banner"}}'></div>                                                                                
                                                        
                                            		

<header class="storyHeader article"><h1 itemprop="headline">With the fullest measure of courage, DevOps holds true to its objective</h1>

				<p class="summary" itemprop="description alternativeHeadline">Quest for the One True DevOps, Part III: Where one of the world's most recognized broadcasters makes a technological breakthrough that could save it from obsolescence, and the facilitators of that breakthrough discuss whether it did so the right way.</p>
	
    
	        




    
<div class="byline">
                        <div class="thumb">
                <a rel="author" itemprop="author" href="/meet-the-team/" data-vanity-rewritten="true">
                                                                    <span class="img "><img src="https://zdnet2.cbsistatic.com/hub/i/r/2017/10/02/753511ee-9a1a-4fe4-9dac-ae231d1ba71b/thumbnail/40x40/124bbac74a0857377ab9a020547ebafe/2016-smf3-icon-01.jpg" class="" alt="Scott Fulton III" height="40" width="40"></span>
            
                </a>
            </div>
                <p class="meta">
                                   By <a rel="author" itemprop="author" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "byline-author", "pageType": "article"}' href="/meet-the-team/" data-vanity-rewritten="true">Scott Fulton III</a>
            
                    
                    for <a href="/blog/scale/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "byline-blog", "pageType": "article"}'>Scale</a>
        
                                        |            <time datetime="2018-01-29 14:00:22">January 29, 2018 -- 14:00 GMT (06:00 PST)</time>
        
                                                        
                    | Topic: <a href="/topic/digital-transformation/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "byline-topic", "pageType": "article"}'>Digital Transformation</a>
            </p>

</div>
    </header></div>
            </div>
    </div>

    </div>
    <div id="mantle_skin" data-article-num="1">
        <span id="adSkinLeft"></span>
        <span id="adSkinRight"></span>
            <div id="skin-5a6f291459b15" class="ad-skin" data-ad="skin">
    <script>
        window.console && console.log && console.log("ADS: queuing skin-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("skin-5a6f291459b15");
    </script></div>


                
    <section class="leader leader-top" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_top_leaderboard_desktop","spot":"content-top-leaderboard"}'><div id="leader-plus-top-5a6f291459b15" class="ad-leader-plus-top" data-ad="leader-plus-top">
    <script>
        window.console && console.log && console.log("ADS: queuing leader-plus-top-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("leader-plus-top-5a6f291459b15");
    </script></div>

            </section><div class="contentWrapper ">
                <div class="container ">
            
    <div class="row">
                <div class="row">
        <div class="col-12">
                                            <div class="row">
                                        <div class="row">
        <div class="col-12">
                                            <div class="row">
                                    <div class="col-8">
                                                    
                                                        
                                            
    
        


<article><script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "Article",
        "headline": "With the fullest measure of courage, DevOps holds true to its objective",
        "datePublished": "2018-01-29 14:00:22",
        "image": {
            "@type": "ImageObject",
            "url": "https://zdnet1.cbsistatic.com/hub/i/2018/01/05/b851f335-f062-4720-9873-d24bc10ffd2c/311f7363d2cf50acba9a943d1d23e9cf/180105-m03-scale-w3-fig-01.jpg",
            "height": 578,
            "width": 770
        },
        "author": {
            "@type": "Person",
            "name": "Scott Fulton III"
        },
        "publisher": {
            "@type": "Organization",
            "name": "ZDNet",
            "logo": {
                "@type": "ImageObject",
                "url": "http://www.zdnet.comhttps://zdnet3.cbsistatic.com/fly/bundles/zdnetcss/images/core/logo.png",
                "height": 60,
                "width": 600
            }
        },
        "dateModified": "2018-01-29 14:00:22",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "http://www.zdnet.com/article/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective/"
        }
    }
</script><div itemscope itemtype="http://schema.org/NewsArticle">
    <meta itemprop="thumbnailUrl" content="https://zdnet1.cbsistatic.com/hub/i/2018/01/05/b851f335-f062-4720-9873-d24bc10ffd2c/311f7363d2cf50acba9a943d1d23e9cf/180105-m03-scale-w3-fig-01.jpg"><meta itemprop="url mainEntityOfPage" content="http://www.zdnet.com/article/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective/"><meta itemprop="headline" content="With the fullest measure of courage, DevOps holds true to its objective"><meta itemprop="description" content="Quest for the One True DevOps, Part III: Where one of the world's most recognized broadcasters makes a technological breakthrough that could save it from obsolescence, and the facilitators of that breakthrough discuss whether it did so the right way."><meta itemprop="author" itemtype="person" content="Scott Fulton III"><meta itemprop="datePublished" content="2018-01-29 14:00:22"><meta itemprop="dateModified" content="2018-01-29 14:00:22"><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <meta itemprop="url" content="https://zdnet.com/"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="http://www.zdnet.comhttps://zdnet3.cbsistatic.com/fly/bundles/zdnetcss/images/core/logo.png"><meta itemprop="width" content="600"><meta itemprop="height" content="60"></div>
        <meta itemprop="name" content="ZDNet"></div>
</div>
    


        

    

    
<div class="shareBar" data-component="shareBar" data-share-bar-options='{"showCounts":true,"title":"With the fullest measure of courage, DevOps holds true to its objective","description":"Quest for the One True DevOps, Part III: Where one of the world\u0027s most recognized broadcasters makes a technological breakthrough that could save it from obsolescence, and the facilitators of that breakthrough discuss whether it did so the right way.","shortUrl":"http:\/\/zd.net\/2m0WvKN","author":{"socialProfiles":{"facebookProfile":"https:\/\/www.facebook.com\/scott.fultoniii.5","facebookPage":null,"twitter":"SMFulton3","googlePlus":"https:\/\/plus.google.com\/u\/0\/+ScottFultonIII"}},"location":"top","url":"http:\/\/www.zdnet.com\/article\/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective\/"}'>
    
    <ul><li class="comments">
                <a href="#comments-2bef804e-d745-4057-b328-22fa9216f811" data-location="topsharebar-comment">
                        <svg class=" comment-bubble"><use xlink:href="#comment-bubble"></use></svg><span class="disqus-comment-count social-count loaded" data-component="disqusCount" data-disqus-count-options='{"disqusIdentifier":"2bef804e-d745-4057-b328-22fa9216f811"}'>0</span>
</a>
            </li>
                <li class="facebook">
            <a class="social-share" data-popup="facebook" data-location="topsharebar-fb-like" data-counts="facebook">    <svg class=" facebook"><use xlink:href="#facebook"></use></svg><span class="social-count"></span></a>
        </li>
        <li class="linkedin">
            <a class="social-share" data-popup="linkedin" data-location="topsharebar-linkedin-share" data-counts="linkedin">    <svg class=" linkedin"><use xlink:href="#linkedin"></use></svg><span class="social-count"></span></a>
        </li>
        <li class="twitter">
            <a class="social-share" data-popup="twitter" data-location="topsharebar-twitter-tweet" data-counts="twitter">    <svg class=" twitter"><use xlink:href="#twitter"></use></svg></a>
        </li>
                <li class="email">
            <a data-component="emailContact" data-email-contact-options='{"trackClickText":"email-friend-submit","isDesktopGallery":false,"modalAsync":{"url":"\/user\/email-friend\/xhr\/","requestData":{"contentTitle":"With the fullest measure of courage, DevOps holds true to its objective","contentUrl":"http:\/\/www.zdnet.com\/article\/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective\/"}}}'>
                    <svg class=" envelope"><use xlink:href="#envelope"></use></svg></a>
        </li>
                    </ul></div>

    <div class="storyBody" data-component="lazyloadImages" data-lazyload-images-options='{"threshold":500}'>
                                    
        <div class="shortcode video large">
    
<svg class="svg-symbol playerControls"><symbol id="play" viewbox="0 0 26.6 32"><path d="M0,2.6c0-2.4,1.6-3.3,3.7-2L25,13.7c2,1.3,2,3.2,0,4.5L3.7,31.4c-2,1.3-3.7,0.3-3.7-2C0,29.4,0,2.6,0,2.6z"></path></symbol><symbol id="pause" viewbox="0 0 26.6 32"><g><polygon points="16,32 26.5,32 26.5,8.8 26.5,0 16,0"></polygon><rect x="0.1" y="0" width="10.6" height="32"></rect></g></symbol><symbol id="playlist" viewbox="0 0 32 22.9"><g><circle class="st11" cx="2.3" cy="20.6" r="2.3"></circle><circle class="st11" cx="2.3" cy="11.4" r="2.3"></circle><circle class="st11" cx="2.3" cy="2.3" r="2.3"></circle><path class="st11" d="M32,1.1C32,0.5,31.5,0,30.9,0H10.3C9.7,0,9.1,0.5,9.1,1.1v2.3c0,0.6,0.5,1.1,1.1,1.1h20.6c0.6,0,1.1-0.5,1.1-1.1V1.1z"></path><path class="st11" d="M32,10.3c0-0.6-0.5-1.1-1.1-1.1H10.3c-0.6,0-1.1,0.5-1.1,1.1v2.3c0,0.6,0.5,1.1,1.1,1.1h20.6c0.6,0,1.1-0.5,1.1-1.1V10.3z"></path><path class="st11" d="M32,19.4c0-0.6-0.5-1.1-1.1-1.1H10.3c-0.6,0-1.1,0.5-1.1,1.1v2.3c0,0.6,0.5,1.1,1.1,1.1h20.6c0.6,0,1.1-0.5,1.1-1.1V19.4z"></path></g></symbol><symbol id="speaker-on" viewbox="0 0 32 28.1"><g><g><path d="M12.6,5L6.3,8.7H0.6C0.3,8.7,0,9,0,9.3V19c0,0.4,0.3,0.7,0.6,0.7h5.9l6.1,3.4c1.3,0.8,1.5,0.2,1.5-1.5V6.5C14.2,4.8,13.9,4.2,12.6,5z"></path></g><path d="M18,23.1v-2.8c2.6,0,4.7-2.8,4.7-6.2S20.6,7.8,18,7.8V5c4.2,0,7.5,4,7.5,9S22.1,23.1,18,23.1z"></path><path d="M21.3,28.1v-2.8c4.4,0,7.9-5,7.9-11.2S25.6,2.8,21.3,2.8V0C27.2,0,32,6.3,32,14C32,21.8,27.2,28.1,21.3,28.1z"></path></g></symbol><symbol id="speaker-off" viewbox="0 0 32 18.8"><g><g><path d="M12.6,0.4L6.3,4H0.6C0.3,4,0,4.3,0,4.7v9.7c0,0.4,0.3,0.7,0.6,0.7h5.9l6.1,3.4c1.3,0.8,1.5,0.2,1.5-1.5V1.8C14.2,0.2,13.9-0.5,12.6,0.4z"></path></g><polygon points="32,4.5 30.2,2.7 25.3,7.6 20.4,2.7 18.6,4.5 23.5,9.4 18.6,14.3 20.4,16.1 25.3,11.2 30.2,16.1 32,14.3 27.1,9.4 "></polygon></g></symbol><symbol id="captions" viewbox="0 0 32 16.2"><g><path d="M8.6,16.2c-1.2,0-2.4-0.2-3.4-0.6c-1.1-0.4-2-0.9-2.7-1.6c-0.8-0.7-1.4-1.6-1.8-2.6C0.2,10.4,0,9.3,0,8.1c0-1.2,0.2-2.3,0.7-3.3s1-1.8,1.8-2.6C3.2,1.5,4.1,1,5.2,0.6S7.4,0,8.6,0c1,0,1.9,0.1,2.7,0.4c0.8,0.3,1.4,0.6,2,1.1c0.6,0.4,1.1,0.9,1.4,1.5c0.4,0.5,0.7,1.1,0.9,1.6l-4.1,1.9c-0.1-0.3-0.2-0.6-0.4-0.9C11,5.3,10.8,5,10.5,4.8c-0.3-0.2-0.6-0.4-0.9-0.5c-0.3-0.1-0.7-0.2-1-0.2C8,4.2,7.5,4.3,7,4.5C6.6,4.7,6.2,5,5.8,5.3C5.5,5.7,5.2,6.1,5.1,6.5C4.9,7,4.8,7.5,4.8,8.1c0,0.5,0.1,1.1,0.3,1.5c0.2,0.5,0.4,0.9,0.8,1.2c0.3,0.4,0.7,0.6,1.2,0.8C7.5,11.9,8,12,8.6,12c0.3,0,0.7-0.1,1-0.2c0.3-0.1,0.6-0.3,0.9-0.5c0.3-0.2,0.5-0.4,0.7-0.7c0.2-0.3,0.3-0.6,0.4-0.9l4.1,1.9c-0.2,0.5-0.5,1-0.9,1.6c-0.4,0.5-0.9,1-1.4,1.5c-0.6,0.4-1.2,0.8-2,1.1C10.5,16,9.6,16.2,8.6,16.2z"></path><path d="M24.9,16.2c-1.2,0-2.4-0.2-3.4-0.6c-1.1-0.4-2-0.9-2.7-1.6c-0.8-0.7-1.4-1.6-1.8-2.6c-0.4-1-0.7-2.1-0.7-3.3c0-1.2,0.2-2.3,0.7-3.3c0.4-1,1-1.8,1.8-2.6c0.8-0.7,1.7-1.3,2.7-1.7C22.6,0.2,23.7,0,24.9,0c1,0,1.9,0.1,2.7,0.4c0.8,0.3,1.4,0.6,2,1.1c0.6,0.4,1.1,0.9,1.4,1.5C31.5,3.5,31.8,4,32,4.5l-4.1,1.9c-0.1-0.3-0.2-0.6-0.4-0.9c-0.2-0.3-0.4-0.5-0.7-0.7c-0.3-0.2-0.6-0.4-0.9-0.5c-0.3-0.1-0.7-0.2-1-0.2c-0.6,0-1.1,0.1-1.5,0.3c-0.5,0.2-0.9,0.5-1.2,0.8c-0.3,0.4-0.6,0.8-0.8,1.2c-0.2,0.5-0.3,1-0.3,1.5c0,0.5,0.1,1.1,0.3,1.5c0.2,0.5,0.4,0.9,0.8,1.2c0.3,0.4,0.7,0.6,1.2,0.8c0.5,0.2,1,0.3,1.5,0.3c0.3,0,0.7-0.1,1-0.2c0.3-0.1,0.6-0.3,0.9-0.5c0.3-0.2,0.5-0.4,0.7-0.7c0.2-0.3,0.3-0.6,0.4-0.9l4.1,1.9c-0.2,0.5-0.5,1-0.9,1.6c-0.4,0.5-0.9,1-1.4,1.5c-0.6,0.4-1.2,0.8-2,1.1C26.8,16,25.9,16.2,24.9,16.2z"></path></g></symbol><symbol id="share" viewbox="0 0 32 20"><path d="M20,6c0,0-7.9-0.1-13.2,3.3C1.6,12.7,0,20,0,20s5.1-5.4,9.8-7.2C14.9,10.9,20,12,20,12v6l12-8L20,0V6z"></path></symbol><symbol id="fullscreen" viewbox="0 0 32 32"><g><g><polygon class="st11" points="11.4,0 0,0 0,11.4 3.4,8 9.1,13.7 13.7,9.1 8,3.4           "></polygon></g><g><polygon class="st11" points="20.6,32 32,32 32,20.6 28.6,24 22.9,18.3 18.3,22.9 24,28.6          "></polygon></g><g><polygon class="st11" points="32,11.4 32,0 20.6,0 24,3.4 18.3,9.1 22.9,13.7 28.6,8          "></polygon></g><g><polygon class="st11" points="0,20.6 0,32 11.4,32 8,28.6 13.7,22.9 9.1,18.3 3.4,24          "></polygon></g></g></symbol><symbol id="video" viewbox="0 0 32 22"><g><path d="M29,2.2c-0.7,0.2-4.6,3-7.9,5.3V2.1C21.1,1,20.1,0,19,0H2.1C1,0,0,1,0,2.1v17.7C0,21,1,22,2.1,22H19c1.2,0,2.1-1,2.1-2.1v-5.9c3.3,2.4,7.4,5.4,8.2,5.6c1.4,0.4,2.7-0.1,2.7-0.1V2.2C32,2.2,30.1,1.8,29,2.2z"></path></g></symbol></svg><div class="zdnetVideoPlayer">
    <div class="videoContainer loading">
        <div class="videoPlayer" data-component="zdnetVideoUvpjs" data-zdnet-video-uvpjs-options='{"videos":[{"id":"10cbafb0-fb23-4693-8bfe-b9b700937e43","title":"DevOps is the hot topic in 2018: Five reasons why","description":"","slug":"devops-are-the-hot-topic-five-reasons-why","chapters":{"data":[],"paging":{"total":0,"limit":15,"offset":0}},"duration":48,"mpxId":"1130460227562","mpxRefId":"jV8KtlxQar_V_RGKbfQZgSvBG9Z8E_JE","primaryTopic":{"id":"109dbc12-ec91-11e3-95d2-02911863765e","slug":"it-priorities"},"secondaryTopics":"big-data,data-centers,data-management,security,artificial-intelligence,internet-of-things,developer","author":{"id":"497bb8de-10d8-11e4-9732-00505685119a","firstName":"ZDNet","lastName":"Editors"},"primaryCollection":{"id":"","title":""},"previewImg":"http:\/\/zdnet4.cbsistatic.com\/hub\/i\/2018\/01\/05\/0550d466-6000-417a-9eef-9292307642ae\/5a3bf8ba60b233cf5e57343e-1280x7201jan052018222710poster.jpg","m3u8":"\/video\/manifest\/devops-are-the-hot-topic-five-reasons-why.m3u8","mp4":"http:\/\/android-streaming.techrepublic.com\/media\/2018\/01\/05\/1130460227562\/2018-01-05-wochit-devops-are-the-hot-topic-five-reasons-why_1476194_740.mp4","selector":"\/video\/selector\/devops-are-the-hot-topic-five-reasons-why\/"}],"relatedItems":null,"autoplay":false,"autoplayMuted":false,"loopVideo":false,"timelineContainer":null,"vidInfoContainer":".video-details-wrapper","monitorProgress":null,"refreshAds":null,"timeRange":"","popOnScroll":false,"config":{"policies":{"default":95897180},"tracking":{"can_partner_id":"canPartnerID","comscore_id":"3000074","nielsen_cid":"us-700144","nielsen_vcid":"c01","nielsen_vcid_reviews":"c05","nielsen_vcid_home":"c07","nielsen_vcid_news":"c08","nielsen_vcid_how_to":"c09","nielsen_vcid_videos":"c20","comscore_host":"http:\/\/b.scorecardresearch.com\/p?","comscore_partnerId":"zdnet","comscore_publishersSecret":"2cb08ca4d095dd734a374dff8422c2e5","comscore_c2":"3005086","comscore_c4":"3000074","dw_host":"\/\/dw.cbsi.com\/levt\/video\/e.gif?","dw_siteId":"2","comscore_legacy_c2":"3000074","comscore_legacy_c4":"3000074"},"uvpConfig":{"default":{"charset":"UTF-8","currencyCode":"USD","visitorNamespace":"cbsinteractive","tackLiveStreams":"y","trackingServer":"om.cbsi.com","heartbeatVisitorMarketingCloudOrgId":"10D31225525FF5790A490D4D@AdobeOrg","heartbeatVisitorNamespace":"10D31225525FF5790A490D4D@AdobeOrg","heartbeatTrackingServer":"http:\/\/cbsinteractive.hb.omtrdc.net","heartbeatAdobePublisherId":"10D31225525FF5790A490D4D@AdobeOrg"}}},"baseUrl":"http:\/\/www.zdnet.com","runtime":"Flash","policy":null,"partnerId":null,"uvpPartner":"zdnet","controlsCss":"https:\/\/zdnet2.cbsistatic.com\/fly\/css\/video\/htmlPlayerControls\/controls-bdb11d3a1a-rev.css"}'>
                        <div class="videoPromo" style="display: none">
                <div class="videoSlide">
                    <div>
                        <div class="playOverlay" data-item="playOverlay"></div>
                                                                                                    <span class="img "><img src="https://zdnet3.cbsistatic.com/hub/i/r/2018/01/05/0550d466-6000-417a-9eef-9292307642ae/thumbnail/570x322/05a25e7be7ea135e38a18b5fd1534228/5a3bf8ba60b233cf5e57343e-1280x7201jan052018222710poster.jpg" class="" alt="" height="322" width="570"></span>
            
                                            </div>
                </div>
            </div>

            <div data-item="loadingCircle" class="loading-circle"></div>

                        <script data-item="abCheck" src="https://zdnet2.cbsistatic.com/fly/bundles/zdnetjs/js/utils/advertisement.js" type="text/javascript"></script></div>

        <div class="videoControls" data-component="videoControlsUvpjs"></div>
    </div>
</div></div><p style="text-align: center;"> 	<em>Video: DevOps is the hot topic in 2018: Five reasons why</em></p><blockquote> 	 		"There is widespread acceptance that business and IT strategies should be linked or interdependent.  Indeed, the operative word,  	<em>linkage</em> is used by many researchers to characterize an approach to IT planning that responds to, as well as shapes, business strategies.  While this has achieved the status of conventional wisdom among practitioners, and is often an unquestioned axiom among researchers, the <em>nature</em> of linkage has not been adequately clarified in the literature.  That is, the concept of linkage has been historically invoked as a <em>metaphor</em> to argue for the integration of business and IT strategies without adequate articulation or clarification of its characteristics." 	      <p> 		 		- John C. Henderson and N. Venkatraman MIT Sloan School of Management  		<em>Strategic Alignment: A Framework for Strategic Information Technology Management</em> [1989] 	</p></blockquote><p> 	 	In many of Europe's major countries, public broadcasters are financed through state funds.  The business model of sustaining broadcasting through taxation, amid surging competition from streaming services such as Netflix and Hulu -- and, in times of desperation,  	<a href="http://www.dw.com/en/more-and-more-germans-boycotting-state-media-fees/a-19165376">enforcing those media taxes with fines and jail sentences</a> -- is no longer viable.  As <a href="https://www.accenture.com/t20150523T054033__w__/cr-en/_acnmedia/Accenture/Conversion-Assets/DotCom/Documents/Global/PDF/Technology_1/Accenture-Future-of-Broadcasting-III-Strategy-Delivers.pdf">a 2015 report from business consultant Accenture</a> [PDF] concluded, "In the new, consumer-driven world, access to content, rather than distribution, will become the critical differentiator."</p><p> 	 	It has been a new, consumer-driven world ever since the first consumer was born, although audience metrics may be imprecise as to when that was.</p><figure class="image  image-full-width shortcode-image"><span class="img aspect-set " style="padding-bottom: 56%"><img src="https://zdnet3.cbsistatic.com/hub/i/r/2018/01/05/b851f335-f062-4720-9873-d24bc10ffd2c/resize/770xauto/85fa666222715cb2833d1387f0ff6d2a/180105-m03-scale-w3-fig-01.jpg" class="" alt="180105-m03-scale-w3-fig-01.jpg" height="auto" width="770"></span></figure><p> 	 	We're at the third phase of our metaphorical Quest for the One True DevOps.  On our map of the Middle Ground of IT, we find ourselves at one of the tallest peaks in the DevOps Mountains.  From here, completely coincidentally, we can see two towers.  The one we're standing next to is the Monitoring Tower.  It's all-seeing, absorbing light from all points in the realm, but at no time is it ever totally cognizant of what it sees.</p><p> 	 	The other tower lies in the distance, in a valley to the south.  At its apex is the oldest oracle of logic, the Eye of Antiquity.  It can look anyplace for something specific, but is never certain of what direction it should look to find it.</p>        <div id="inpage-video-top-5a6f291459b15" class="ad-inpage-video-top" data-ad="inpage-video-top">
    <script>
        window.console && console.log && console.log("ADS: queuing inpage-video-top-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("inpage-video-top-5a6f291459b15");
    </script></div>

<p> 	 	It just so happens that this first tower is being used by a broadcaster.  The whole world seems to be shifting beneath its foundations, and it's struggling for a way to adjust.</p><p><strong>Read also: </strong><a href="http://www.zdnet.com/article/agile-plus-devops-is-slowly-but-steadily-reaching-enterprise-scale/">Agile plus DevOps is slowly but steadily reaching enterprise scale</a></p><h2>World service</h2>


    <section class="sharethrough-top" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_sharethrough_top_in_article_desktop","spot":"dfp-in-article"}'><div id="sharethrough-top-5a6f291459b15" class="ad-sharethrough-top" data-ad="sharethrough-top">
    <script>
        window.console && console.log && console.log("ADS: queuing sharethrough-top-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("sharethrough-top-5a6f291459b15");
    </script></div>

    </section><p> 	 	For most of its existence, the British Broadcasting Corporation has established its services on a business model of collecting public fees.  In 2013, the job of forging a completely new service model -- first for major events such as sports, and later for the entire program portfolio -- fell to Zoe Bolton.</p><p> 	 	"I was responsible for developing the service operations," Bolton told a Splunk company conference in London in 2016 ( 	<a href="https://diginomica.com/2016/05/11/bbc-store-monitoring-and-improving-customer-journeys-with-splunk-cloud/">according to a transcript by Diginomica</a>).  "The people, the processes and deciding what toolsets we were going to use -- it was the complete unknown. . . We were like a start-up model really, even though we were working for a huge organization.  We couldn't really rob from the existing operations team, because we hadn't really done anything like this worldwide around e-commerce before, and it's a lot more complicated."</p><p> 	 	The broader concept of DevOps implies a collaboration between, if not the outright merger of, two often disparate business units.  But for Bolton and the BBC, there was no Dev team to begin with, and the Ops team was busy with its own operations.  It was the convergence of no one with nothing.</p><p> 	 	"Whenever they have a new program, they normally would add a page to their Web site, or a mini-site, or a tile, and they want to know whether that's doing well, and what they need to do to tweak it to make it go better," explained Andi Mann, Chief Technology Advocate with  	<a href="https://www.splunk.com/">Splunk</a>.  "By using a DevOps-inspired mode of constant feedback, they use Splunk to monitor the activity on that new tile, as well as things like application activity, who's watching those shows, response times, and infrastructure activity.  And they feed that all back to the marketing team, and they work cooperatively with marketing to make sure the tile placement is right, that errors aren't holding people back from clicking through.  They could be trying new ways of engaging with viewers."</p><p> 	 	Prior to Bolton's arrival, the BBC's services were being maintained by six completely separate systems.  Every month, a combined report was prepared on all six systems' collective performance, using Microsoft Excel as the reporting mechanism, in a process that consumed one week of effort each time.</p><p><strong>Read also:</strong> <a href="http://www.zdnet.com/article/executives-overestimate-devops-maturity/">Executives overestimate DevOps maturity</a></p><p> 	 	Bolton's efforts, coupled with the adoption of the Splunk platform, managed to accomplish what has often been stated to be principal goals of DevOps: the automation of critical business functions, and the bridging of gaps between divisions.  But as a department head for program operations, not IT operations, she did it without either Dev or Ops.  And the departments she managed to bridge together were program services and marketing.  (Unfortunately,  	<a href="https://servicemarksolutions.com/">the name "ServiceMark" has already been claimed</a>.)</p><figure class="image  image-full-width shortcode-image"><span class="img aspect-set " style="padding-bottom: 56%"><img src="" class="lazy" alt="180105-m03-scale-w3-fig-02.jpg" height="auto" width="770" data-original="    https://zdnet1.cbsistatic.com/hub/i/r/2018/01/05/95d72914-3eeb-4829-b6c7-0f64c9f4d5b9/resize/770xauto/88e7d47b502eaa767f840e6d8b45dd4c/180105-m03-scale-w3-fig-02.jpg"></span><noscript><span class="img aspect-set " style="padding-bottom: 56%"><img src="https://zdnet1.cbsistatic.com/hub/i/r/2018/01/05/95d72914-3eeb-4829-b6c7-0f64c9f4d5b9/resize/770xauto/88e7d47b502eaa767f840e6d8b45dd4c/180105-m03-scale-w3-fig-02.jpg" class="" alt="180105-m03-scale-w3-fig-02.jpg" height="auto" width="770"></span></noscript></figure><p> 	 	"I think it was [ 	<em>Peter</em>] Drucker who said, you can't manage what you can't measure," noted Mann.  "More importantly, you don't know if you're doing the right things unless you have that measurement set up in the first place.  What are you even trying to improve?"</p><blockquote class="pullquote alignright">
		<p>"Right this second, every industry all over the world is trying to understand how to incorporate this higher velocity of technology advancement and R&amp;D, into their existing business processes. Over time, each of those industries is going to find the stable shapes... I'd be shocked if there were half-a-dozen."</p>
					<cite>— -Adam Jacob, Chief Technology Officer, Chef</cite>
			</blockquote><p> 	 	It seems reasonable enough to declare that any software, in and of itself, cannot present the entire solution for an organization reforming its business model.  The story of the BBC's "digital transformation," however, appears to demonstrate how software, or a cloud-based service that presents software, completely facilitates new business efforts -- at least those efforts grounded on audience or customer measurement -- without the intervention of the departments typically charged with overseeing such a task.</p><p> 	 	Put another way, the BBC appears to have provided us with a working demonstration of a successful implementation of DevOps that did  	<em>not</em> require the kind of "top-down" "buy-in" that many of its advocates would mandate.</p><h2>Truth or consequences</h2><p> 	 	There actually has been a class of software that has applied itself to the modeling and, where feasible, automation of fundamental business processes.  Business process management (BPM, although some vendors use the "P" to stand for "performance") is  	<a href="http://www.tomsitpro.com/articles/bpm-business_intelligence-business_analytics-decision_management-bpm_dm,2-550.html">nothing new to this century</a>.</p><p> 	 	In DevOps, the operative model is the pipeline; in BPM, it's the  	<em>workflow</em>.  Since the 1990s, business analysts have used a flowchart-based approach to visualize the steps that take place in the performance of a business transaction.  Keep in mind, this is not a computer function being modeled, but rather the sequence of tasks that people perform (often through the use of tools, computers among them) to achieve discrete, desired results.  It was usually the results with which these processes were tagged.</p><p><strong>Read also:</strong> <a href="http://www.zdnet.com/article/devops-accelerates-requiring-new-leadership-styles/">DevOps accelerates, requiring new leadership styles</a></p><p> 	 	These processes, and the functions that accompany them, lie at the very center of organizations; for many, especially in the financial sector, they are the very definition of the business.</p><p> 	 	Originally, DevOps pipelines were not the same as BPM workflows.  That changed when the tooling for delivery pipelines became an industry in itself.</p><p> 	 	"DevOps starts and finishes with the customer," wrote Bob Tarne, a coach in Agile processes for manufacturing companies, for IBM DeveloperWorks.  "Customer demand starts the development cycle.  Planning is the initial step to determine how customer demand will be met.  Business needs to be able to react quickly to customer feedback.  Lean and agile techniques facilitate the ability to react quickly."</p><p> 	 	Almost identical language has been used to describe supply chain management software.  Taken out of context, this quote from Tarne looks as though someone had done a global search-and-replace of "supply chain" for "DevOps."</p><figure class="image  image-full-width shortcode-image"><span class="img aspect-set " style="padding-bottom: 56%"><img src="" class="lazy" alt="180105-m03-scale-w3-fig-03.jpg" height="auto" width="770" data-original="    https://zdnet2.cbsistatic.com/hub/i/r/2018/01/05/58da52ec-0fdb-4fa6-ab8b-cc5f54cf4ce5/resize/770xauto/a1ca183f2b13da95e54174dd0f880371/180105-m03-scale-w3-fig-03.jpg"></span><noscript><span class="img aspect-set " style="padding-bottom: 56%"><img src="https://zdnet2.cbsistatic.com/hub/i/r/2018/01/05/58da52ec-0fdb-4fa6-ab8b-cc5f54cf4ce5/resize/770xauto/a1ca183f2b13da95e54174dd0f880371/180105-m03-scale-w3-fig-03.jpg" class="" alt="180105-m03-scale-w3-fig-03.jpg" height="auto" width="770"></span></noscript></figure><p> 	 	It's here where we realize our journey toward the terminal of the pipeline has led us on a detour into the public market.  There, we discover that to distribute our new ideal throughout the realm, marketing has to wrap it in a message that sells.</p><p> 	 	"We found that there are collections of practices that are strongly correlated with high-performing IT departments," said Puppet chief technical strategist Nigel Kersten, discussing the latest research for the  	<a href="https://puppet.com/resources/whitepaper/state-of-devops-report">2017 State of DevOps Report</a>, produced in cooperation with DORA.  "If you want to actually work out how high-performing you are as an IT department, it turns out that deployment <em>pain</em> -- very subjectively, for the people doing deployments, how painful are they? -- is a really good proxy for all sorts of much more sophisticated, and much more difficult-to-measure, items.</p><p><strong>Read also: </strong><a href="http://www.zdnet.com/article/devops-will-be-a-big-deal-in-the-year-ahead/">5 reasons DevOps will be a big deal in the year ahead</a></p><p> 	 	"So if you're just starting out, ask your development teams, or whoever actually deploys your software, how painful are they?  And then record that trendline.  If it's going up, you're improving.  If it's going down, you're getting worse.  If it's not moving at all, all the things you're doing are not actually making any difference.  Other than that, the two big measurements you want to focus on, are speed and quality, because they're meant to be the promise of this new world of working."</p><p> 	 	With all this discussion of pain and pleasure as signals of bad and good behavior, respectively (presumably), one might get the impression that we've stopped discussing technology and joined a psychology lecture.</p><p> 	 	Quoting from the 2017 State of DevOps Report:  "Transformational leadership enables the necessary practices that correlate with high performance, and it also supports effective communication and collaboration between team members in pursuit of organizational goals.  Such leadership provides the foundation for a culture in which continuous experimentation and learning is part of everybody's daily work.  The behavior of transformational leaders thus enhances and enables the values, processes and practices that our research has identified."</p><p> 	 	All of a sudden, we're in the behavioral modeling business.  DevOps, which began as an earnest plea by a couple of guys from Flickr to have the Mr. Spocks and the Mr. Scotts of the world come together more often to discuss things, has transcended the scrum room and hurled itself directly into the realm of B. F. Skinner and operant conditioning.  The behavior of workers in an organization can be changed to better align with the goals of the business, if we manage to find that magic element of inspiration -- that "transformational leadership" quality that cannot come from software.</p><p> 	 	If you think I've jumped into a culture chasm myself, take a look at the late University of Georgia political science professor Dr. Robert T. Golembiewski's milestone work,  	<em>Handbook of Organizational Behavior</em>.  "Transformational leadership is appropriate for managing conflict," Dr. Golembiewski wrote.  "This type of leader, sometimes referred to as a charismatic leader, uses his or her personal power to inspire employees to new ways of thinking and problem solving."</p><p> 	 	Then, just three paragraphs later, "Conflict management requires experimentation and risk taking.  B. F. Skinner's operant conditioning, which refers to voluntary learning of behavior through positive reinforcement, is particularly appropriate here."  Without a great deal of effort, and perhaps without much awareness, at least some of us appear to have substituted the classic "Skinner Box" with a CI/CD platform.</p><p><strong>Read also: </strong><a href="http://www.zdnet.com/article/what-is-devops-an-executive-guide-to-agile-development-and-it-operations/">What is DevOps? An executive guide to agile development and IT operations</a></p><h2>The ring goes way south</h2><p> 	 	Is this interpretation of DevOps going too far?  Are we commandeering a metaphor that has shown results in improving the mindset and performance of IT workers, to resuscitate the old, and perhaps tired, notion of performance management?</p><p> 	 	"The thing that we learned," revealed Chef CTO Adam Jacob, "was that top-down business process automation doesn't deliver the results you thought it would, particularly because of ossification."</p><p> 	 	Rules of behavior do tend to reinforce themselves, especially by way of feedback loops -- and yes, that's something B. F. Skinner did discover.  It's that feedback that makes the workflows and business logic at the center of organizations rigid and resistant to change, Jacob is arguing here.  The feedback needs to be redirected, he suggests, so that the loop extends outside of individual departments, so that the signals being received are reflective of the changing state of affairs, and not some artificial state of satisfaction.  Thus each feedback loop in the chain of the organization, he suggests, must be tightly coupled.</p><blockquote class="pullquote alignleft">
		<p>"More often than not, there's just a set, defined strategy we'll take that customer through, to get them through to the end result, which is releasing with extreme velocity and quality."</p>
					<cite>— -Robert Stroud, former principal analyst, Forrester</cite>
			</blockquote><p> 	 	"Historically, we've always wanted to decouple it, to break it down and say this piece doesn't rely on the shape of the other," Jacob continued.  "But that's not true.  In complex systems, everything works because the shape of  	<em>x</em> fits in the shape of <em>y</em>."</p><p> 	 	Splunk's Andi Mann also spoke in terms of behavioral programming.</p><p> 	 	 "DevOps defines an end state," Mann told us, "where you're delivering software better and faster because your teams are working together collaboratively and communicating better.  And this is an  	<em>output</em>.</p><p> 	 	"A lot of people describe DevOps in terms of culture change," Mann continued.  "Not about tooling or even about process, but about culture.  But again, culture is an output as well, not an input.  We need to start looking at the artifacts that  	<em>create</em> culture, the artifacts that change your ability to collaborate, that define those boundaries and silos and how you break them."</p><div data-shortcode></div>
    

        
                <div class="relatedContent alignRight">
                        
                            <div class="thumb">
                    <a href="http://www.zdnet.com/article/devops-how-to-get-started-and-how-to-make-it-work/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "pinbox", "pageType": "article"}'>
                                                                        <span class="img "><img src="https://zdnet4.cbsistatic.com/hub/i/r/2015/05/14/87dd4708-e78e-40b3-bf38-893bda238fb9/resize/220x165/16b5b9f01563b3aaefb98b75144d6242/roadblock.jpg" class="" alt="DevOps: How to get started and how to make it work" height="165" width="220"></span>
            
                    </a>
                </div>
            
                            <p class="title">
                    <a href="http://www.zdnet.com/article/devops-how-to-get-started-and-how-to-make-it-work/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "pinbox", "pageType": "article"}'>
                        DevOps: How to get started and how to make it work
                    </a>
                </p>
            
                            <p class="dek">DevOps could transform the way your organisation delivers software projects but there are some hurdles you'll have to jump along the way.</p>
            
            <p class="read-more">
                <a href="http://www.zdnet.com/article/devops-how-to-get-started-and-how-to-make-it-work/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "pinbox", "pageType": "article"}'>Read More</a>
            </p>
        </div><p> 	 	Mann's interpretation of the chain of automation would place data, measurements, and signals at the start of the sequence, and culture changes at the end -- in the category Skinner would call "consequences."  But it is one single, unbroken chain.  There is a competing set of theories -- for example, Gartner's vision of bimodal IT -- which would suggest that different classes of business processes have their own exclusive cycles, which run at their own speeds.  Some have reinterpreted the bimodal notion to refer to "old stuff" and "new stuff," but as its creators have pointed out, it's really an acknowledgment that not all business processes share the same chain.</p><p> 	 	If that's the case, then maybe DevOps does belong in a category by itself after all.</p><p> 	 	"I believe that good computing practices and good DevOps practices are applicable to all change, all deployment, and all technology," remarked former Forrester analyst Robert Stroud, now chief product officer for continuous delivery software provider Xebia Labs.  "But the reality of it is that the business doesn't always require every application to run at the same speed."</p><p> 	 	Stroud suggests the presence of what he calls "multi-speed IT" -- not a bimodal or two-faced scheme, but a series of somewhat self-contained processes.  "The reality of it is," he told us, "some systems will ideate faster or slower than others.  But you still want to put that change through the same rigor, the same testing, the same check-in processes, the same ideation processes, the same validation of the code that it's effective, that it works, that it serves a purpose and is fit for use.  Then you want to deploy it in an automated manner.  So as far as DevOps is concerned, we want to make the DevOps processes, and the DevOps way of working, consistent across the whole environment.  Let the business choose how often it ideates -- it's their choice.  Ultimately, IT exists to run the business.  We're not here to tell the business what to do."</p><p><strong>Read also: </strong><a href="http://www.zdnet.com/article/harnessing-ai-to-make-devops-more-effective/">Harnessing AI to make DevOps more effective</a></p><p> 	 	Stroud's vision places IT in the role of automating business processes using the same methodology, but not producing components of the same chain.  The pipeline, as he projects it, fashions a set of repeatable actions and functions for each class of business activity.  But their connection with one another may be more asynchronous, in the manner of Web services -- waiting to be called, and then sending signals when they're done.</p><p> 	 	It's that vision which begins to look more like where we started: the simpler, more logical, less psychologically obsessed realm of software development.  It doesn't demand cultural change as a means for delivering an ideal, and all the goodies and downloads that come with it.  Nor does it profess the ideal of analyzing every signal in search of the meaning behind the data that will deliver, in the end, cultural change.  For that matter, there isn't much cultural change to it at all.</p><p><strong>Read also:</strong> <a href="http://www.zdnet.com/article/is-devops-sustainable-after-the-consultants-leave/">Is DevOps sustainable after the consultants leave?</a></p><h2>Regrouping</h2><figure class="image  image-full-width shortcode-image"><span class="img aspect-set " style="padding-bottom: 56%"><img src="" class="lazy" alt="180105-m03-scale-w3-fig-04.jpg" height="auto" width="770" data-original="    https://zdnet4.cbsistatic.com/hub/i/r/2018/01/05/a311921a-f57b-4fd5-8c28-95476f5275d9/resize/770xauto/c9755d04a8c9c998db389b3321c758ee/180105-m03-scale-w3-fig-04.jpg"></span><noscript><span class="img aspect-set " style="padding-bottom: 56%"><img src="https://zdnet4.cbsistatic.com/hub/i/r/2018/01/05/a311921a-f57b-4fd5-8c28-95476f5275d9/resize/770xauto/c9755d04a8c9c998db389b3321c758ee/180105-m03-scale-w3-fig-04.jpg" class="" alt="180105-m03-scale-w3-fig-04.jpg" height="auto" width="770"></span></noscript></figure><p> 	 	The end of our journey is in sight, and already we start to feel the need for warm blankets and perhaps elven bread.  We're about to embark on a guided tour of the most unchanging element in all the realm: the corporation.  There, we'll see what a former prominent DevOps analyst learned when he put the principles he used to teach to the ultimate test, as he joins the enterprise itself.  Will what he have gained have been worth the sacrifice?  And what can we gain from the lessons he's learned?</p><p> 	 	We'll see if we can escape the volcano without losing a finger.  Until then, hold strong.</p><h3>Quest for the One True DevOps </h3><ul><li><a href="http://www.zdnet.com/article/the-dream-of-fellowship-for-software-developers-and-it-operators/">Part one: The dream of fellowship for software developers and IT operators</a></li>	      <li><a href="http://www.zdnet.com/article/the-dawn-of-automation-and-the-promise-of-a-formula-for-business-success/" target="_blank">Part two: The dawn of automation and the promise of a formula for business success</a></li></ul><p> 	<a href="http://www.zdnet.com/article/the-dawn-of-automation-and-the-promise-of-a-formula-for-business-success/" target="_blank"></a></p><h3>Journey Further -- From the CBS Interactive Network</h3><ul><li>"<a href="http://www.zdnet.com/article/executives-overestimate-devops-maturity/">Executives overestimate DevOps maturity</a>" by Robert Stroud, Forrester Research</li><li>"<a href="https://www.techrepublic.com/blog/tech-decision-maker/the-failed-promise-of-business-process-management-bpm/">The failed promise of Business Process Management (BPM)</a>" by Patrick Gray, Tech Decision Maker</li><li>"<a href="http://www.zdnet.com/article/devops-success-factors-culture-apis-and-security/">DevOps success factors: Culture, APIs, and security</a>" by Tas Bindi, Riding the DevOps Revolution</li></ul><h3>Elsewhere</h3><ul><li>"<a href="https://www.cmswire.com/information-management/rethinking-bimodal-it-part-2-coping-with-change/">Rethinking Bimodal IT Part 2: Coping with Change</a>" by Scott M. Fulton, III, CMSWire</li><li>"<a href="https://www.hpe.com/us/en/insights/articles/what-is-chef-a-primer-for-devops-newbies-1704.html">What is Chef? A primer for DevOps newbies</a>" by Steven J. Vaughan-Nichols, HPE enterprise.nxt</li><li>"<a href="https://blog.smartbear.com/cloud-computing/change-control-overcoming-the-compulsion-to-repeat-the-past/">Change Control: Overcoming the Compulsion to Repeat the Past</a>" by Scott M. Fulton, III, SmartBear</li></ul><h3> Related stories </h3><ul><li><a href="http://www.zdnet.com/article/the-old-software-fortress-weathers-the-storm-of-supreme-chaos/">Searching for the perimeter in cloud security: From microservices to chaos</a></li>	      <li><a href="http://www.zdnet.com/article/micro-fortresses-everywhere-the-cloud-security-model-and-the-software-defined-perimeter/">Micro-fortresses everywhere: The cloud security model and the software-defined perimeter</a></li>	      <li><a href="http://www.zdnet.com/article/microservices-and-the-invasion-of-the-identity-entities/">Microservices and the invasion of the identity entities</a></li>	      <li><a href="http://www.zdnet.com/article/machine-learning-and-the-spectre-of-the-wrong-solution/">Machine learning and the spectre of the wrong solution</a></li></ul><p> 	<em>The map of Middle Ground for this series of Scale was drawn by Katerina Fulton.</em></p>
    </div>

    
<section class="related-topics"><h3>Related Topics:</h3>
        
                    <a href="/topic/data-centers/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}'>
                Data Centers
            </a>
                    <a href="/topic/cxo/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}'>
                CXO
            </a>
                    <a href="/topic/innovation/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}'>
                Innovation
            </a>
                    <a href="/topic/digital-transformation-a-cxos-guide/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}'>
                Digital Transformation: A CXOs Guide
            </a>
                    <a href="/topic/big-data/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}'>
                Big Data Analytics
            </a>
            </section><div class="shareBar" data-component="shareBar" data-share-bar-options='{"showCounts":true,"title":"With the fullest measure of courage, DevOps holds true to its objective","description":"Quest for the One True DevOps, Part III: Where one of the world\u0027s most recognized broadcasters makes a technological breakthrough that could save it from obsolescence, and the facilitators of that breakthrough discuss whether it did so the right way.","shortUrl":"http:\/\/zd.net\/2m0WvKN","author":{"socialProfiles":{"facebookProfile":"https:\/\/www.facebook.com\/scott.fultoniii.5","facebookPage":null,"twitter":"SMFulton3","googlePlus":"https:\/\/plus.google.com\/u\/0\/+ScottFultonIII"}},"location":"bottom","url":"http:\/\/www.zdnet.com\/article\/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective\/"}'>
    
    <ul><li class="comments">
                <a href="#comments-2bef804e-d745-4057-b328-22fa9216f811" data-location="bottomsharebar-comment">
                        <svg class=" comment-bubble"><use xlink:href="#comment-bubble"></use></svg><span class="disqus-comment-count social-count loaded" data-component="disqusCount" data-disqus-count-options='{"disqusIdentifier":"2bef804e-d745-4057-b328-22fa9216f811"}'>0</span>
</a>
            </li>
                <li class="facebook">
            <a class="social-share" data-popup="facebook" data-location="bottomsharebar-fb-like" data-counts="facebook">    <svg class=" facebook"><use xlink:href="#facebook"></use></svg><span class="social-count"></span></a>
        </li>
        <li class="linkedin">
            <a class="social-share" data-popup="linkedin" data-location="bottomsharebar-linkedin-share" data-counts="linkedin">    <svg class=" linkedin"><use xlink:href="#linkedin"></use></svg><span class="social-count"></span></a>
        </li>
        <li class="twitter">
            <a class="social-share" data-popup="twitter" data-location="bottomsharebar-twitter-tweet" data-counts="twitter">    <svg class=" twitter"><use xlink:href="#twitter"></use></svg></a>
        </li>
                <li class="email">
            <a data-component="emailContact" data-email-contact-options='{"trackClickText":"email-friend-submit","isDesktopGallery":false,"modalAsync":{"url":"\/user\/email-friend\/xhr\/","requestData":{"contentTitle":"With the fullest measure of courage, DevOps holds true to its objective","contentUrl":"http:\/\/www.zdnet.com\/article\/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective\/"}}}'>
                    <svg class=" envelope"><use xlink:href="#envelope"></use></svg></a>
        </li>
                    </ul></div>
</article><div id="taboola-below-article-thumbnails-with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective" data-component="taboola" data-taboola-options='{"mode":"alternating-thumbnails-a","container":"taboola-below-article-thumbnails-with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective","placement":"ZDNETarticleDesktop\/Tablet-Below Article Thumbnails","isXhr":false}' om-event="ZDNETarticleDesktop/Tablet-Below Article Thumbnails"></div>
                                                                                
                                                        
                                                                                                    
                    

<!-- General comments -->
<div id="comments-2bef804e-d745-4057-b328-22fa9216f811" class="postComments">
    <div class="disqus-details">
                <div class="disqus-login-button loggedOut" data-component="userTracking">
            <a class="btn btn-primary" href="https://secure.zdnet.com/user/registration/?appId=1101&amp;redirectUrl=http%3A//www.zdnet.com/article/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective/%23comments-2bef804e-d745-4057-b328-22fa9216f811&amp;showUserName=1" data-user-show='{"action":"register","params":{"appId":1101,"position":"comments","redirectUrl":"http:\/\/www.zdnet.com\/article\/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective\/#comments-2bef804e-d745-4057-b328-22fa9216f811","showUserName":1}}'>LOG IN TO COMMENT</a>
        </div>
                <div class="disqus-user-dropdown loggedIn">
            <span class="disqus-username" id="disqusUsername-2bef804e-d745-4057-b328-22fa9216f811" data-user-var="userName"></span>
                        <ul class="menu-disqus-user"><li><a href="https://secure.zdnet.com/members/preferences/">My Profile</a></li>
                <li><a href="/user/logout/">Log Out</a></li>
            </ul></div>
                <span class="disqus-faq-guidlines">
            | <a href="http://cbsi.force.com/CBSi/zdnetcommunityfaq">Community Guidelines</a>
        </span>
    </div>
    <div id="disqusContainer-2bef804e-d745-4057-b328-22fa9216f811">
        <a name="zdnet_core.anchor.comments"></a>

        <h3>
            <span>Join Discussion</span>
        </h3>

        <div data-social="disqus" data-id="2bef804e-d745-4057-b328-22fa9216f811" data-title="With the fullest measure of courage, DevOps holds true to its objective" data-url="http://www.zdnet.com/article/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective/" data-load-on-init="true"></div>
    </div>
</div>

<div class="add-comment loggedOut" data-component="userTracking">
    <a class="btn btn-primary" href="https://secure.zdnet.com/user/registration/?appId=1101&amp;redirectUrl=http%3A//www.zdnet.com/article/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective/%23comments-2bef804e-d745-4057-b328-22fa9216f811&amp;showUserName=1" data-user-show='{"action":"register","params":{"appId":1101,"position":"comments","redirectUrl":"http:\/\/www.zdnet.com\/article\/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective\/#comments-2bef804e-d745-4057-b328-22fa9216f811","showUserName":1}}'>Add Your Comment</a>
</div>

<div class="add-comment loggedIn">
    <a class="btn btn-primary" href="#comments-2bef804e-d745-4057-b328-22fa9216f811">Add Your Comment</a>
</div>                                                                                            
                                                        
                                            

        <div id="110647" class="yahoo-sponsored-bottom" data-component="yahooTags" data-yahoo-tags-options='{"netseer_tag_id":"21103","netseer_ad_width":"770","netseer_ad_height":"240","netseer_task":"ad","netseer_imp_type":"1","netseer_imp_src":"2","netseer_placement_id":110647}'></div>
                                                                    </div>
            <div class="col-4">
                                                    
                                                        
                                            

                    	<div class="ad-wrap" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_top_mpu_desktop","spot":"content-top-mpu"}'>
	    <section class="mpu"><div id="mpu-plus-top-5a6f291459b15" class="ad-mpu-plus-top" data-ad="mpu-plus-top">
    <script>
        window.console && console.log && console.log("ADS: queuing mpu-plus-top-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("mpu-plus-top-5a6f291459b15");
    </script></div>

	    </section></div>
                                                                                    
                                                        
                                            

                        <section class="vendor-text-link"><div id="vendor-text-link-5a6f291459b15" class="ad-vendor-text-link" data-ad="vendor-text-link">
    <script>
        window.console && console.log && console.log("ADS: queuing vendor-text-link-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("vendor-text-link-5a6f291459b15");
    </script></div>

    </section><section data-module="Related Stories" class="module relatedStories"><h2 class="heading">
		<span class="int">Related Stories</span>
	</h2>
	<div class="box">
		<ul><li>
					<div>
					    <a class="thumb" title="Bankwest's Halo payments ring born out of 'agile' approach to banking" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="/article/bankwests-halo-payments-ring-born-out-of-agile-approach-to-banking/">
					                                                        <span class="img "><img src="https://zdnet2.cbsistatic.com/hub/i/r/2018/01/29/7285967c-8527-411f-ba5b-9abdd1609b83/thumbnail/170x128/d08f12371e25a03b78935648abbdbb50/bankwest-halo-payment-ring.jpg" class="" alt="Bankwest's Halo payments ring born out of 'agile' approach to banking" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Innovation</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="/article/bankwests-halo-payments-ring-born-out-of-agile-approach-to-banking/">Bankwest's Halo payments ring born out of 'agile' approach to banking</a></p>
					</div>
				</li>
																			<li>
					<div>
					    <a class="thumb" title="​Here come all the AI deployments; Now how do we manage AI?" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="/article/here-come-all-the-ai-deployments-now-how-do-we-manage-ai/">
					                                                        <span class="img "><img src="https://zdnet2.cbsistatic.com/hub/i/r/2018/01/24/524f1f6e-34ea-4972-bf3f-362a19f416ca/thumbnail/170x128/30e698349eb3b725c923e9127923c407/figure-5.jpg" class="" alt="​Here come all the AI deployments; Now how do we manage AI?" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Artificial Intelligence</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="/article/here-come-all-the-ai-deployments-now-how-do-we-manage-ai/">​Here come all the AI deployments; Now how do we manage AI?</a></p>
					</div>
				</li>
																			<li>
					<div>
					    <a class="thumb" title="Lessons learned from Google's application of artificial intelligence to user experience" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="/article/googles-approach-to-ai-and-ux/">
					                                                        <span class="img "><img src="https://zdnet3.cbsistatic.com/hub/i/r/2018/01/27/b5e73209-9997-4bf7-8814-6db3d80fd48a/thumbnail/170x128/2ea3acdade4f07e4284075f1838516a2/lights-corridor-cropped-national-gallery-of-art-washington-dc-photo-by-joe-mckendrick.jpg" class="" alt="Lessons learned from Google's application of artificial intelligence to user experience" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Artificial Intelligence</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="/article/googles-approach-to-ai-and-ux/">Lessons learned from Google's application of artificial intelligence to user experience</a></p>
					</div>
				</li>
																			<li>
					<div>
					    <a class="thumb" title="What enterprises will focus on for digital transformation in 2018" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="/article/what-enterprises-will-focus-on-for-digital-transformation-in-2018/">
					                                                        <span class="img "><img src="https://zdnet2.cbsistatic.com/hub/i/r/2018/01/25/588f07d2-e357-46fb-aeda-87e4713e4c60/thumbnail/170x128/514ab1f072671330f62df8f6a2aa481b/thedigitalenterprise2018customerworkersupplierpartnerexperience.png" class="" alt="What enterprises will focus on for digital transformation in 2018" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Digital Transformation</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="/article/what-enterprises-will-focus-on-for-digital-transformation-in-2018/">What enterprises will focus on for digital transformation in 2018</a></p>
					</div>
				</li>
											</ul></div>
</section><div id="newsletter-terms-of-service" data-component="modal" class="modal hide">
        <div class="modalHeader">
            <a class="close" data-close="modal">×</a>
            <h4 class="heading"><span class="modalTitle">Thank You</span></h4>
        </div>
        <div class="modalBody">

            <div class="terms-of-service">
                <h2>Please review our terms of service to complete your newsletter subscription.</h2>

                <form method="post" action="#">
                     <div style="font: inherit; font-size:7pt;">
                         By registering you become a member of the CBS Interactive family of sites and you have read and agree to the <a href="http://www.cbsinteractive.com/legal/cbsi/terms-of-use" target="_blank">Terms of Use</a>, <a href="https://cbsi.secure.force.com/CBSi/articles/FAQ/Privacy-Policy?categories=CBS_Interactive%3AmPrivacy&amp;template=template_mobilePrivacy&amp;referer=mobileprivacy.com&amp;data=&amp;cfs=default" target="_blank">Privacy Policy</a> and <a href="https://cbsi.secure.force.com/CBSi/articles/FAQ/mThird-Party-Social-Networking-Services?template=template_mobilepp&amp;referer=mobilepp.com&amp;data=&amp;cfs=default" target="_blank">Video Services Policy</a>. You agree to receive updates, alerts and promotions from CBS and that CBS may share information about you with our marketing partners so that they may contact you by email or otherwise about their products or services.
                         You will also receive a complimentary subscription to the ZDNet's Tech Update Today and ZDNet Announcement newsletters. You may unsubscribe from these newsletters at any time.
                         <br><br></div>

                    <button type="submit" class="btn btn-block btn-primary" id="newsletter-terms-of-service-submit">ACCEPT &amp; CLOSE</button>
                </form>
            </div>

        </div>
    </div>
<div id="newsletter-widget-2327" data-component="newsletterWidget" data-newsletter-widget-options='{"errorMessage":"Something has gone awry. Please contact &lt;a href=\u0022https:\/\/cbsi.secure.force.com\/CBSi\/submitcase?template=template_zdnet&amp;referer=zdnet.com&amp;cfs=SFS_3\u0022&gt;&lt;b&gt;customer service&lt;\/b&gt;&lt;\/a&gt; to confirm your request.","position":"newsletter-sub-widget"}'>
    <section class="keepUp"><h2 class="heading"><span class="int">Newsletters</span></h2>
        <div class="box" data-component="userTracking">
            <div class="newsletterWidgetSuccessMessage hide">You have been successfully signed up. To sign up for more newsletters or to manage your account, visit the <a href="https://secure.zdnet.com/members/newsletters/">Newsletter Subscription Center</a>.</div>
            <div class="newsletterWidgetErrorMessage hide">
                <div class="alert alert-error"></div>
            </div>


            <div class="newsletters">
                <div id="widget-3133" data-component="loadNewsletterAsync" data-load-newsletter-async-options='{"loggedUrl":"\/newsletter\/xhr\/widget\/","loginUrl":"\/newsletter\/xhr\/widget-login\/","data":{"topic":"digital-transformation"}}'>
                </div>
            </div>
                        <span class="loggedOut">
                <a href="/newsletters/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "newsletter-seeall", "pageType": "article"}' class="btn-circle" data-vanity-rewritten="true">
                  <div class="btn-circle-text">
                    <span>See</span>
                    All
                  </div>
                </a>
            </span>

            <span class="loggedIn">
                <a href="https://secure.zdnet.com/members/newsletters/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "newsletter-seeall", "pageType": "article"}' class="btn-circle">
                  <div class="btn-circle-text">
                    <span>See</span>
                    All
                  </div>
                </a>
            </span>
        </div>
    </section></div>
                                                                                
                                                        
                                            

                    
    <section class="dynamic-showcase-top"><div id="dynamic-showcase-top-5a6f291459b15" class="ad-dynamic-showcase-top" data-ad="dynamic-showcase-top">
    <script>
        window.console && console.log && console.log("ADS: queuing dynamic-showcase-top-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("dynamic-showcase-top-5a6f291459b15");
    </script></div>

    </section><section class="mpu" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_middle_mpu_desktop","spot":"content-middle-mpu"}'><div id="mpu-middle-5a6f291459b15" class="ad-mpu-middle" data-ad="mpu-middle">
    <script>
        window.console && console.log && console.log("ADS: queuing mpu-middle-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("mpu-middle-5a6f291459b15");
    </script></div>

    </section><div id="uid-214490400" data-component="medusaAsync" data-medusa-async-options='{"url":"\/m3d0s1\/xhr\/right-rail\/","data":{"promo":2150,"count":3},"template":"right-rail"}'>
    </div>

						                                                                                
                                                        
                                            

                    
    <section class="mpu scrolling-mpu" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_bottom_mpu_desktop","spot":"content-bottom-mpu"}'><div id="mpu-bottom-5a6f291459b15" class="ad-mpu-bottom" data-ad="mpu-bottom">
    <script>
        window.console && console.log && console.log("ADS: queuing mpu-bottom-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("mpu-bottom-5a6f291459b15");
    </script></div>

            </section></div>
                                </div>
                        </div>
            </div>
                <div class="row">
        <div class="col-12">
                                                    
                                                        
                                            

                        <section class="leader leader-bottom" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_bottom_leaderboard_desktop","spot":"content-bottom-leaderboard"}'><div id="leader-plus-bottom-5a6f291459b15" class="ad-leader-plus-bottom" data-ad="leader-plus-bottom">
    <script>
        window.console && console.log && console.log("ADS: queuing leader-plus-bottom-5a6f291459b15 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("leader-plus-bottom-5a6f291459b15");
    </script></div>

    </section><div data-component="magnet" data-magnet-options='{"data":[{"id":"2bef804e-d745-4057-b328-22fa9216f811","title":"With the fullest measure of courage, DevOps holds true to its objective","description":"Quest for the One True DevOps, Part III: Where one of the world\u0027s most recognized broadcasters makes a technological breakthrough that could save it from obsolescence, and the facilitators of that breakthrough discuss whether it did so the right way.","slug":"with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective","ajaxUrl":"\/article\/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective\/xhr\/","url":"\/article\/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective\/","typeName":"content_article"},{"id":"19956199-ff57-4cc7-bd73-b698e3f2b683","title":"Google starts selling its $249 Clips camera, but you need to join a wait list to get one","description":"Google\u0027s hands-free AI camera goes on sale but then quickly sells out.","slug":"google-starts-selling-its-249-clips-camera-but-you-need-to-join-a-wait-list-to-get-one","ajaxUrl":"\/article\/google-starts-selling-its-249-clips-camera-but-you-need-to-join-a-wait-list-to-get-one\/xhr\/","url":"\/article\/google-starts-selling-its-249-clips-camera-but-you-need-to-join-a-wait-list-to-get-one\/","typeName":"content_article"},{"id":"9fd19b8e-1dc2-47b9-a25c-34bf555d705c","title":"Singapore Airlines inks partnerships to drive digital ambition","description":"Singapore\u0027s national carrier has signed partnership agreements with the country\u0027s research and trade agencies to explore opportunities in areas such as data analytics and IoT, to improve efficiencies.","slug":"singapore-airlines-inks-partnerships-to-drive-digital-ambition","ajaxUrl":"\/article\/singapore-airlines-inks-partnerships-to-drive-digital-ambition\/xhr\/","url":"\/article\/singapore-airlines-inks-partnerships-to-drive-digital-ambition\/","typeName":"content_article"},{"id":"2ed3c799-e7a8-4931-8264-e43863d54ac6","title":"Nokia\u0027s new ReefShark chipset aims to deliver big 5G performance boost","description":"Nokia develops a new chipset that can halve the size of 5G antennas and boost capacity.","slug":"nokias-new-reefshark-chipset-aims-to-deliver-big-5g-performance-boost","ajaxUrl":"\/article\/nokias-new-reefshark-chipset-aims-to-deliver-big-5g-performance-boost\/xhr\/","url":"\/article\/nokias-new-reefshark-chipset-aims-to-deliver-big-5g-performance-boost\/","typeName":"content_article"},{"id":"82172a2c-5c3e-4916-98f6-7a8eee4cf7d0","title":"WhatsApp Business becomes available in Brazil","description":"Instant messaging tool continues to build on its popularity in the country to grow its footprint within the enterprise space.","slug":"whatsapp-business-becomes-available-in-brazil","ajaxUrl":"\/article\/whatsapp-business-becomes-available-in-brazil\/xhr\/","url":"\/article\/whatsapp-business-becomes-available-in-brazil\/","typeName":"content_article"},{"id":"1ec5e5a7-3c5d-48e3-bbbf-b2f181edd2ac","title":"Windows emergency patch: Microsoft\u0027s new update kills off Intel\u0027s Spectre fix","description":"Out-of-band update disables Intel\u0027s mitigation for Spectre Variant 2 attack, which Microsoft says can cause data loss on top of unexpected reboots.","slug":"windows-emergency-patch-microsofts-new-update-kills-off-intels-spectre-fix","ajaxUrl":"\/article\/windows-emergency-patch-microsofts-new-update-kills-off-intels-spectre-fix\/xhr\/","url":"\/article\/windows-emergency-patch-microsofts-new-update-kills-off-intels-spectre-fix\/","typeName":"content_article"}],"currentItem":[{"id":"2bef804e-d745-4057-b328-22fa9216f811","title":"With the fullest measure of courage, DevOps holds true to its objective","description":"Quest for the One True DevOps, Part III: Where one of the world\u0027s most recognized broadcasters makes a technological breakthrough that could save it from obsolescence, and the facilitators of that breakthrough discuss whether it did so the right way.","slug":"with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective","ajaxUrl":"\/article\/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective\/xhr\/","url":"\/article\/with-the-fullest-measure-of-courage-devops-holds-true-to-its-objective\/","typeName":"content_article"}],"hasToc":false}' data-waypoint="2bef804e-d745-4057-b328-22fa9216f811"></div>
	                                                                    </div>
            </div>
                                </div>
                        </div>
            </div>
    </div>


                
            	        </div>
            </div>

        </div>

    </div>

            
<footer role="contentinfo" class="footer-main"><div class="container">
        <div class="row">
            <div class="col-6 siteHighlights">
                
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "Organization",
  "url": "http://www.zdnet.com/",
  "contactPoint": [
    { "@type": "ContactPoint",
      "telephone": "+1-415-344-2000",
      "contactType": "customer service"
    }
  ]
}
</script><a id="zd-logo" href="/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-Logo", "pageType": "article"}'>ZDNet</a>
                <div class="connect">
                    <div class="connect-label">Connect with us</div>
                    <div class="social-links-wrapper" itemscope itemtype="http://schema.org/Organization">
                        <link itemprop="url" href="http://www.zdnet.com"><a class="circle" target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/pages/ZDNet/5953112932" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-ConnectWithZDNet", "pageType": "article"}' itemprop="sameAs">
                            <svg viewbox="0 0 15.2 32"><g><path d="M15.2,11.1H9.6V7c0-1.2,1.3-1.5,1.9-1.5c0.6,0,3.6,0,3.6,0V0L11,0C5.4,0,4.1,4.1,4.1,6.7v4.4H0v5.6h4.1
        c0,7.3,0,15.2,0,15.2h5.5c0,0,0-8.1,0-15.2h4.7L15.2,11.1z"></path></g></svg></a>
                        <a class="circle" target="_blank" rel="noopener noreferrer" href="http://twitter.com/zdnet" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-ConnectWithZDNet", "pageType": "article"}' itemprop="sameAs">
                            <svg viewbox="0 0 32.5 28.4"><g><path d="M32.5,3.4c-0.5,0.3-2.2,1-3.7,1.1c1-0.6,2.4-2.4,2.8-3.9c-0.9,0.6-3.1,1.6-4.2,1.6c0,0,0,0,0,0
        C26.1,0.9,24.4,0,22.5,0c-3.7,0-6.7,3.2-6.7,7.2c0,0.6,0.1,1.1,0.2,1.6h0C11,8.7,5.1,6,1.8,1.3c-2,3.8-0.3,8,2,9.5
        c-0.8,0.1-2.2-0.1-2.9-0.8c0,2.5,1.1,5.8,5.2,7c-0.8,0.5-2.2,0.3-2.8,0.2c0.2,2.1,3,4.9,6,4.9c-1.1,1.3-4.7,3.8-9.3,3
        c3.1,2,6.7,3.2,10.5,3.2c10.8,0,19.2-9.4,18.7-21.1c0,0,0,0,0,0c0,0,0-0.1,0-0.1c0,0,0-0.1,0-0.1C30.2,6.4,31.5,5.1,32.5,3.4z"></path></g></svg></a>
                        <a class="circle" target="_blank" rel="noopener noreferrer" href="https://www.linkedin.com/company/zdnet-com" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-ConnectWithZDNet", "pageType": "article"}' itemprop="sameAs">
                            <svg viewbox="0 0 31.9 32"><g><path d="M24,8c-5.1,0.1-7.7,3.8-8,4V8h-6v24h6V18c0-0.5,1.3-4.6,6-4c2.5,0.2,3.9,3.5,4,4v14l6,0V15.4
        C31.7,13,30.5,8.1,24,8z M0,32h6V8H0V32z M3,0C1.3,0,0,1.3,0,3s1.3,3,3,3c1.7,0,3-1.3,3-3S4.7,0,3,0z"></path></g></svg></a>
                    </div>
                </div>
                <p class="copyright">© 2018 CBS Interactive. All rights reserved. <a href="http://legalterms.cbsinteractive.com/privacy" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-CopyrightLinks", "pageType": "article"}' rel="nofollow" target="_blank">Privacy Policy</a> | <a href="http://legalterms.cbsinteractive.com/cookies" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-CopyrightLinks", "pageType": "article"}' rel="nofollow" target="_blank">Cookies</a> | <a href="http://legalterms.cbsinteractive.com/adchoice" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-CopyrightLinks", "pageType": "article"}' rel="nofollow" target="_blank">Ad Choice</a> |  <a href="/advertise/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-CopyrightLinks", "pageType": "article"}' rel="nofollow" target="_blank" data-vanity-rewritten="true">Advertise</a> | <a href="http://legalterms.cbsinteractive.com/terms-of-use" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-CopyrightLinks", "pageType": "article"}' rel="nofollow" target="_blank">Terms of Use</a> | <a href="http://legalterms.cbsinteractive.com/eula" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-CopyrightLinks", "pageType": "article"}' rel="nofollow" target="_blank">Mobile User Agreement</a></p>

                                    <div class="networkSites">
                        <form data-component="footerSites">
                            <label for="cbsiSites">Visit other CBS Interactive sites:</label>
                            <select id="cbsiSites"><option selected value="">Select Site</option><option value="http://www.cbs.com/cbs_cares/">CBS Cares</option><option value="http://www.cbsfilms.com">CBS Films</option><option value="http://www.cbsradio.com">CBS Radio</option><option value="http://www.cbs.com">CBS.com</option><option value="http://www.cbsinteractive.com">CBSInteractive</option><option value="http://www.cbsnews.com">CBSNews.com</option><option value="http://www.cbssports.com">CBSSports.com</option><option value="http://www.chowhound.com">Chowhound</option><option value="http://www.cnet.com">CNET</option><option value="http://www.cbsiam.com/">College Networks</option><option value="http://www.gamespot.com">GameSpot</option><option value="http://www.last.fm">Last.fm</option><option value="http://www.maxpreps.com">MaxPreps</option><option value="http://www.metacritic.com">Metacritic.com</option><option value="http://www.cbsnews.com/moneywatch/">Moneywatch</option><option value="http://www.mysimon.com">mySimon</option><option value="http://www.radio.com">Radio.com</option><option value="http://www.search.com">Search.com</option><option value="http://www.shopper.com">Shopper.com</option><option value="http://www.sho.com">Showtime</option><option value="http://www.techrepublic.com">TechRepublic</option><option value="http://theinsider.etonline.com/">The Insider</option><option value="http://www.tv.com">TV.com</option><option value="http://www.urbanbaby.com">UrbanBaby.com</option><option value="http://www.zdnet.com">ZDNet</option></select></form>
                    </div>
                            </div>

                        <div class="col-2 alpha">
                <ul><li><a href="/topic/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}'>Topics</a></li>
                    <li><a href="/blog/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}'>All Authors</a></li>
                    <li><a href="/pictures/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}'>Galleries</a></li>
                    <li><a href="/video/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}'>Videos</a></li>
                    <li><a href="http://narratives.zdnet.com/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}'>Sponsored Narratives</a></li>
                </ul></div>

                        <div class="col-2 beta">
                <ul><li><a href="/about/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}' data-vanity-rewritten="true">About ZDNet</a></li>
                    <li><a href="/meet-the-team/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}' data-vanity-rewritten="true">Meet The Team</a></li>
                    <li><a href="/sitemap/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}' data-vanity-rewritten="true">Site Map</a></li>
                    <li><a href="/rssfeeds/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}' data-vanity-rewritten="true">RSS Feeds</a></li>
                    <li><a href="/reprints/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}' data-vanity-rewritten="true">Reprint Policy</a></li>
                </ul></div>

                        <div class="col-2 gamma">
                <ul data-component="userTracking"><li class="loggedIn">
                            <a href="https://secure.zdnet.com/members/preferences/" rel="nofollow">Manage</a> | <a href="http://www.zdnet.com/user/logout/" rel="nofollow" data-member="submitLogOut" data-user-action="logout" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "trackLogout", "pageType": "article"}'>Log Out</a>

                            <span class="zduser">
                                    <svg class=" user_alt"><use xlink:href="#user_alt"></use></svg></span>
                        </li>
                    
                    <li class="loggedOut">
                        <a href="https://secure.zdnet.com/user/login/?appId=1101" rel="nofollow" data-user-show='{"action":"login","params":{"appId":1101,"position":"Footer"}}'>Log In to ZDNET</a>
                        |
                        <a href="https://secure.zdnet.com/user/registration/?appId=1101" rel="nofollow" data-user-show='{"action":"register","params":{"appId":1101,"position":"Footer"}}'>Join ZDNet</a>
                    </li>

                    <li><a href="https://secure.zdnet.com/members/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-Services", "pageType": "article"}' rel="nofollow">Membership</a></li>
                    <li><a href="/newsletters/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-Services", "pageType": "article"}' data-vanity-rewritten="true">Newsletters</a></li>
                    <li><a href="https://cbsi.secure.force.com/CBSi/knowledgehome?referer=zdnet.com" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-Services", "pageType": "article"}'>Site Assistance</a></li>
                    <li><a href="https://academy.zdnet.com/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-Services", "pageType": "article"}'>ZDNet Academy</a></li>
                </ul></div>
        </div>
    </div>
</footer><script>
	// Source: https://gist.github.com/jcxplorer/823878/
	// Licence: Public Domain
	function UUIDv4 (){var b="",a,c;for(a=0;32>a;a++){c=16*Math.random()|0;if(8==a||12==a||16==a||20==a)b+="-";b+=(12==a?4:16==a?c&3|8:c).toString(16)}return b};

	var __tealium_data_guid = UUIDv4(),
		utag_data = {"isEnabled":true,"articleAuthorId":["a4b54dcc-a23c-4e2f-a732-e1328981927e"],"articleAuthorName":["scott fulton iii"],"articleId":"2bef804e-d745-4057-b328-22fa9216f811","articlePubDate":"2018-01-29 14:00:22","articleTitle":"with the fullest measure of courage, devops holds true to its objective","articleType":"content_article","blogId":"f39833e3-64bd-45ed-8437-18cf9f7cf5e5","blogName":"scale","deviceType":"desktop","isDev":"0","pageType":"article","siteHier":["digital transformation","data centers"],"siteSection":"editorial","siteType":"responsive web","topicId":["4bbd52b3-12fc-4183-9f2a-1274944fbf8d","10279ab0-ec91-11e3-95d2-02911863765e"],"topicName":["digital transformation","data centers"],"buyingCycle":"investigate","siteId":2,"bkSiteId":3330,"limit":4,"rsid":"cnetzdnetglobalsite","siteName":"zdnet","tealium":{"profile":"zdnet","env":"prod"}};
    	utag_data.pageViewGuid = __tealium_data_guid;
</script><script data-main="https://zdnet3.cbsistatic.com/fly/1080-fly/js/main.default.js" src="https://zdnet2.cbsistatic.com/fly/1080-fly/js/libs/require-2.1.2.js"></script><script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js" async></script><script async src="https://ps.ns-cdn.com/dsatserving2/scripts/netseerads.js" type="text/javascript"></script><script>
    (function(){
        try {
        window.mPulseApp = mPulse.init("YZ2TK-PC7PJ-K64DL-L53CR-P2G4E", "22a34a7a-a08f-48ae-a20b-48d26cf7fbb0");
        } catch(e) {}
    })();
</script></body></html>

    