Google Play Services deprecates Android Jelly Bean support

Android versions 4.1, 4.2, and 4.3 make up less than 1% of the current active device count.

android-studio-stats-july-21.png

Image: Google

Google has said that devices still running Jelly Bean will no longer be supported after version 21.30.99, which is due to be released at the end of August.

In a blog post, Google said the move was due to the version of Android which was first released in 2012 making up less than 1% of active devices and developers having to spend more time to support it.

Jelly Bean spanned versions 4.1, 4.2, and 4.3, or in API level terms from 16 to 18. The search giant is recommending developers bump up the minimum API level for apps up to API level 19, or KitKat.

"A very small percentage of all Android devices are using API levels less than 19. We believe that many of these old devices may not be actively being used," Google said.

"If your app still has a significant number of users on older devices, you can use multiple APK support in Google Play to deliver an APK that uses Google Play services 21.30.99."

According to the stats presented to developers when making new projects in Android Studio -- the only way to find Google's Android version breakdown -- Android 10 accounted for 8% of devices, followed by Pie with around 30%, while Oreo versions took up another 20%.

Google was yesterday hit with an anti-trust suit from 36 US states over its control of Android app distribution.

"If you don't find the app you're looking for in Google Play, you can choose to download the app from a rival app store or directly from a developer's website. We don't impose the same restrictions as other mobile operating systems do," Google senior director of public policy Wilson White said.

Apple, meanwhile, is currently fighting against the prospect of sideloading apps, claiming last month it would make everything worse for every one of its users

Related Coverage