'

Odd Firefox system requirements recommendation

I'm left puzzling over an odd system requirements recommendation posted for Firefox ...

Maybe I'm just focusing on nothing, but Mozilla's system requirements recommendations for Firefox 3.0 beta struck me as odd:

Odd Firefox system requirements recommendation

Anyone any ideas why XP would be recommended over Vista?  The same pattern is repeated for Firefox 2 and Thunderbird 2 too:

Odd Firefox system requirements recommendation

I guess it's easier to understand why this applies to Firefox 2, but for the same recommendation to be in place for Firefox 3 seems odd to me.  I've got the beta running just fine on Vista.

I wonder whether the recommendation isn't more political than technical.

Anyone able to shed any light on the matter?