<!DOCTYPE html>
<html lang="en" xmlns:fb="http://ogp.me/ns/fb#"><head><meta http-equiv="x-dns-prefetch-control" content="on"><link rel="dns-prefetch" href="//s0.2mdn.net" pr="0.7"><link rel="dns-prefetch" href="//api.viglink.com" pr="0.7"><link rel="dns-prefetch" href="//c2.taboola.com" pr="0.9"><link rel="dns-prefetch" href="//cdn.viglink.com" pr="0.7"><link rel="dns-prefetch" href="//tru.am" pr="0.7"><link rel="dns-prefetch" href="//urs.zdnet.com" pr="0.9"><link rel="dns-prefetch" href="//cdn.taboola.com" pr="1"><link rel="dns-prefetch" href="//platform.linkedin.com" pr="0.8"><link rel="dns-prefetch" href="//www.lightboxcdn.com" pr="0.7"><link rel="preconnect" href="//zdnet1.cbsistatic.com" pr="1"><link rel="preconnect" href="//zdnet2.cbsistatic.com" pr="1"><link rel="preconnect" href="//zdnet3.cbsistatic.com" pr="1"><link rel="preconnect" href="//zdnet4.cbsistatic.com" pr="1"><link rel="preconnect" href="//www.googletagservices.com" pr="1"><link rel="preconnect" href="//native.sharethrough.com" pr="1"><link rel="preconnect" href="//www.googleadservices.com" pr="1"><link rel="preconnect" href="//z.moatads.com" pr="1"><link rel="preconnect" href="//partner.googleadservices.com" pr="0.9"><link rel="preconnect" href="//pagead2.googlesyndication.com" pr="0.9"><link rel="preconnect" href="//tpc.googlesyndication.com" pr="0.9"><link rel="preconnect" href="//securepubads.g.doubleclick.net" pr="0.9"><link rel="preconnect" href="//rev.cbsi.com" pr="0.9"><link rel="preconnect" href="//static.adsafeprotected.com" pr="0.9"><link rel="preconnect" href="//cbsi.demdex.net" pr="0.9"><link rel="preconnect" href="//fast.cbsi.demdex.net" pr="0.9"><link rel="preconnect" href="//ps.ns-cdn.com" pr="0.9"><link rel="preconnect" href="//pixel.adsafeprotected.com" pr="0.8"><link rel="preconnect" href="//c.go-mpulse.net" pr="1"><link rel="preconnect" href="//tags.tiqcdn.com" pr="1"><link rel="preconnect" href="//secure-us.imrworldwide.com" pr="0.9"><link rel="preconnect" href="//b.scorecardresearch.com" pr="0.9"><link rel="preconnect" href="//b2b.cbsimg.net" pr="0.9"><link rel="preconnect" href="//sb.scorecardresearch.com" pr="0.9"><link rel="preconnect" href="//secure.quantserve.com" pr="0.9"><link rel="preconnect" href="//trc.taboola.com" pr="0.8"><meta content="text/html; charset=utf-8" http-equiv="Content-Type"><meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible"><meta content="en" http-equiv="Content-Language"><title>Android P to stop apps from monitoring network activity | ZDNet</title><meta name="description" content="It's about time Google patches this nasty security flaw where any Android app can monitor network access of another app."><link rel="canonical" href="https://www.zdnet.com/article/android-p-to-restrict-apps-from-monitoring-network-access/"><meta property="og:site_name" content="ZDNet"><meta property="og:type" content="article"><meta property="og:url" content="https://www.zdnet.com/article/android-p-to-restrict-apps-from-monitoring-network-access/"><meta property="og:title" content="Android P to stop apps from monitoring network activity | ZDNet"><meta property="og:description" content="It's about time Google patches this nasty security flaw where any Android app can monitor network access of another app."><meta property="og:image" content="https://zdnet3.cbsistatic.com/hub/i/r/2018/03/07/95edb2dc-c3bb-4385-b850-1d9bda1883f2/thumbnail/770x578/b0df62dc8c3c4d5dc06774b9c049558d/google-pixel-2-0490-025.jpg"><meta name="author" content="Jake Smith"><meta property="article:author" content="https://twitter.com/jakeosmith"><meta name="twitter:site" content="@ZDNet"><meta name="twitter:creator" content="@ZDNet"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:url" content="https://www.zdnet.com/article/android-p-to-restrict-apps-from-monitoring-network-access/"><meta name="twitter:title" content="Android P to stop apps from monitoring network activity | ZDNet"><meta name="twitter:description" content="It's about time Google patches this nasty security flaw where any Android app can monitor network access of another app."><meta name="twitter:image" content="https://zdnet3.cbsistatic.com/hub/i/r/2018/03/07/95edb2dc-c3bb-4385-b850-1d9bda1883f2/thumbnail/770x578/b0df62dc8c3c4d5dc06774b9c049558d/google-pixel-2-0490-025.jpg"><meta name="viewport" content="width=device-width, user-scalable=no, maximum-scale=1, minimum-scale=1"><meta name="theme-color" content="#080e14"><link rel="icon" sizes="192x192" href="https://zdnet2.cbsistatic.com/fly/bundles/zdnetcss/images/logos/logo-192x192.png"><link rel="amphtml" href="https://www.zdnet.com/google-amp/article/android-p-to-restrict-apps-from-monitoring-network-access/"><link rel="stylesheet" href="https://zdnet3.cbsistatic.com/fly/1243-fly/css/core/main-0ca210d08f-rev.css"><!--[if (lt IE 9)&(!IEMobile)]>
        <link rel="stylesheet" href="https://zdnet1.cbsistatic.com/fly/1243-fly/css/core/ie8-2f65ec576f-rev.css" media="screen">
        <![endif]--><script type="text/javascript">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</script><!-- Start of Soasta mPulse Script --><script>
(function(){
    if (window.BOOMR && window.BOOMR.version) { return; }
    var dom, doc, where, iframe = document.createElement("iframe"), win = window;

    function boomerangSaveLoadTime(e) {
        win.BOOMR_onload=(e && e.timeStamp) || new Date().getTime();
    }

    if (win.addEventListener) {
        win.addEventListener("load", boomerangSaveLoadTime, false);
    } else if (win.attachEvent) {
        win.attachEvent("onload", boomerangSaveLoadTime);
    }

    iframe.src = "javascript:void(0)";
    iframe.title = "";
    iframe.role = "presentation";
    (iframe.frameElement || iframe).style.cssText = "width:0;height:0;border:0;display:none;";
    where = document.getElementsByTagName("script")[0];
    where.parentNode.insertBefore(iframe, where);

    try {
        doc = iframe.contentWindow.document;
    } catch(e) {
        dom = document.domain;
        iframe.src = "javascript:var d=document.open();d.domain='"+dom+"';void(0);";
        doc = iframe.contentWindow.document;
    }

    doc.open()._l = function() {
        var js = this.createElement("script");
        if (dom) { this.domain = dom; }
        js.id = "boomr-if-as";
        js.src = "//c.go-mpulse.net/boomerang/" +
        "YZ2TK-PC7PJ-K64DL-L53CR-P2G4E";
        BOOMR_lstart = new Date().getTime();
        this.body.appendChild(js);
    };
    doc.write('<body onload="document._l();">');
    doc.close();
})();
</script><!-- End of Soasta mPulse Script --><script type="text/javascript" async src="//js-sec.indexww.com/ht/ls-zdnet.js"></script><script src="https://zdnet1.cbsistatic.com/fly/bundles/zdnetjs/js/libs/mpulse-1.0.2.js"></script><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--><link rel="alternate" type="application/rss+xml" title="Latest topics for ZDNet in Mobility" href="https://www.zdnet.com/topic/mobility/rss.xml"></head><body class="	
">

    <div id="cookie-policy" class="alert optBeta" data-component="cookiePolicy">
	<p>
		<a class="close" data-close="cookie-policy">
			<svg viewbox="0 0 28 28"><polygon points="28,1.9 26.1,0 14,12.1 1.9,0 0,1.9 12.1,14 0,26.1 1.9,28 14,15.9 26.1,28 28,26.1 15.9,14 	"></polygon></svg></a>
		This web site uses cookies to improve your experience. By viewing our content, you are accepting the use of cookies. To find out more and change your cookie settings, please
		<a href="http://legalterms.cbsinteractive.com/cookies" target="_blank">view our cookie policy</a>.
	</p>
</div>
            <svg class="svg-symbol"><symbol id="comment-bubble" viewbox="0 0 32 27.4"><path d="M16,0c8.8,0,16,5.3,16,11.9c0,2.9-2.2,6.3-4.6,8.3l2.3,7.2l-6.9-4.7c-2.1,0.7-4.3,1.1-6.8,1.1
        c-8.8,0-16-5.3-16-11.9C0,5.3,7.2,0,16,0z"></path></symbol><symbol id="email" viewbox="0 0 32 21"><g><polygon points="32,19.5 32,1.3 23.1,10.4"></polygon></g><g><path d="M16.9,13.8L30.4,0h-29l13.5,13.9C15.4,14.4,16.3,14.4,16.9,13.8z"></path></g><g><polygon points="0,1.5 0,19.4 8.7,10.5"></polygon></g><g><path d="M18.3,15.3c-0.7,0.7-1.6,1-2.4,1c-0.9,0-1.7-0.3-2.4-1L10.2,12l-8.8,9h29.2l-8.9-9.2L18.3,15.3z"></path></g><g><polygon points="32,21 32,21 32,21"></polygon></g></symbol><symbol id="facebook" viewbox="0 0 15.2 32"><path d="M15.2,11.1H9.6V7c0-1.2,1.3-1.5,1.9-1.5c0.6,0,3.6,0,3.6,0V0L11,0C5.4,0,4.1,4.1,4.1,6.7v4.4H0v5.6h4.1
        c0,7.3,0,15.2,0,15.2h5.5c0,0,0-8.1,0-15.2h4.7L15.2,11.1z"></path></symbol><symbol id="googleplus" viewbox="0 0 32 32"><path d="M18.8,1c1.1-0.6,1.6-1,1.6-1H9.9C7.8,0,2,2.4,2,7.9c0,5.5,6,6.7,8.2,6.6C9,16,10,17.4,10.7,18.1
        c0.7,0.7,0.5,0.9-0.3,0.9C9.7,19,0,19.1,0,26s12.8,7.4,17.1,3.7s3.3-8.9,0-11.2c-3.3-2.3-4.5-3.4-2.4-5.3
        c2.1-1.8,3.7-3.3,3.7-6.8s-2.8-5.2-2.8-5.2S17.7,1.6,18.8,1z M17.1,25.7c0,3-2.5,4.4-6.8,4.4c-4.3,0-6.6-2.1-6.6-5.4
        c0-3.2,3.1-4.8,9-4.8C14.3,21.2,17.1,22.7,17.1,25.7z M10.9,13.2c-5.2,0-7.5-12.1-1.4-12.1C14.2,0.9,17.8,13.2,10.9,13.2z
         M28.1,4V0.1h-2V4h-4v2h4V10h2V6.1H32V4H28.1z"></path></symbol><symbol id="linkedin" viewbox="0 0 31.9 32"><path d="M24,8c-5.1,0.1-7.7,3.8-8,4V8h-6v24h6V18c0-0.5,1.3-4.6,6-4c2.5,0.2,3.9,3.5,4,4v14l6,0V15.4
        C31.7,13,30.5,8.1,24,8z M0,32h6V8H0V32z M3,0C1.3,0,0,1.3,0,3s1.3,3,3,3c1.7,0,3-1.3,3-3S4.7,0,3,0z"></path></symbol><symbol id="more" viewbox="0 0 32 7.3"><circle cx="3.7" cy="3.7" r="3.7"></circle><circle cx="16" cy="3.7" r="3.7"></circle><circle cx="28.3" cy="3.7" r="3.7"></circle></symbol><symbol id="pinterest" viewbox="0 0 24.9 32"><path d="M13.2,0C4.4,0,0,6.3,0,11.5c0,3.2,1.2,6,3.8,7c0.4,0.2,0.8,0,0.9-0.5c0.1-0.3,0.3-1.1,0.4-1.5
        c0.1-0.5,0.1-0.6-0.3-1c-0.7-0.9-1.2-2-1.2-3.6c0-4.6,3.5-8.8,9.1-8.8c5,0,7.7,3,7.7,7c0,5.3-2.4,9.8-5.9,9.8
        c-1.9,0-3.4-1.6-2.9-3.5c0.6-2.3,1.6-4.8,1.6-6.5c0-1.5-0.8-2.8-2.5-2.8c-2,0-3.6,2-3.6,4.8c0,1.7,0.6,2.9,0.6,2.9s-2,8.5-2.4,10
        c-0.7,3-0.1,6.6-0.1,7c0,0.2,0.3,0.3,0.4,0.1c0.2-0.2,2.5-3.1,3.3-6c0.2-0.8,1.3-5.1,1.3-5.1c0.6,1.2,2.5,2.3,4.5,2.3
        c5.9,0,10-5.4,10-12.6C24.9,5.1,20.3,0,13.2,0z"></path></symbol><symbol id="reddit" viewbox="0 0 32 26.7"><path d="M22.9,14.5C23,14.7,23,15,23,15.2c0,0.4-0.2,0.9-0.4,1.2c-0.3,0.3-0.6,0.6-1,0.7h0c0,0,0,0,0,0c0,0,0,0,0,0
        c-0.2,0.1-0.4,0.1-0.6,0.1c-0.5,0-0.9-0.2-1.3-0.5c-0.4-0.3-0.6-0.7-0.7-1.2c0,0,0,0,0,0c0,0,0,0,0,0h0c0-0.1,0-0.2,0-0.4
        c0-0.4,0.1-0.8,0.4-1.2c0.2-0.3,0.6-0.6,1-0.7c0,0,0,0,0,0c0,0,0,0,0,0c0.2-0.1,0.5-0.1,0.7-0.1c0.4,0,0.8,0.1,1.2,0.4
        C22.5,13.8,22.7,14.1,22.9,14.5C22.9,14.5,22.9,14.5,22.9,14.5C22.9,14.5,22.9,14.5,22.9,14.5L22.9,14.5z M21.6,19.7
        c-0.2-0.1-0.4-0.2-0.6-0.2c-0.2,0-0.3,0-0.5,0.1c-1.4,0.8-3.1,1.3-4.7,1.3c-1.2,0-2.5-0.3-3.6-0.8l0,0l0,0
        c-0.2-0.1-0.4-0.2-0.6-0.4c-0.1-0.1-0.2-0.1-0.3-0.2c-0.1-0.1-0.3-0.1-0.4-0.1c-0.1,0-0.2,0-0.4,0.1c0,0,0,0,0,0
        c-0.2,0.1-0.3,0.2-0.4,0.4c-0.1,0.2-0.2,0.4-0.2,0.6c0,0.2,0,0.3,0.1,0.5c0.1,0.1,0.2,0.3,0.4,0.4c1.6,1.1,3.5,1.6,5.4,1.6
        c1.7,0,3.4-0.4,4.9-1.1l0,0l0,0c0.2-0.1,0.5-0.2,0.7-0.4c0.1-0.1,0.2-0.2,0.4-0.3c0.1-0.1,0.2-0.3,0.2-0.4c0-0.1,0-0.2,0-0.2
        c0-0.1,0-0.3-0.1-0.4C21.9,19.9,21.8,19.8,21.6,19.7L21.6,19.7z M10.4,17.1C10.4,17.1,10.4,17.1,10.4,17.1
        c0.2,0.1,0.4,0.1,0.6,0.1c0.5,0,1-0.2,1.4-0.6c0.4-0.3,0.6-0.8,0.6-1.4c0,0,0,0,0,0c0,0,0-0.1,0-0.1c0-0.6-0.3-1-0.6-1.4
        c-0.4-0.3-0.9-0.6-1.4-0.6c-0.1,0-0.3,0-0.4,0c0,0,0,0,0,0h0c-0.7,0.1-1.3,0.7-1.5,1.4c0,0,0,0,0,0C9,14.8,9,15,9,15.2
        c0,0.4,0.1,0.9,0.4,1.2C9.6,16.7,10,17,10.4,17.1C10.4,17.1,10.4,17.1,10.4,17.1L10.4,17.1z M32,12.1L32,12.1c0,0.1,0,0.1,0,0.2
        c0,0.8-0.2,1.5-0.7,2.2c-0.4,0.6-0.9,1.1-1.5,1.4c0,0.3,0.1,0.6,0.1,0.9c0,1.7-0.6,3.3-1.6,4.6v0h0c-1.9,2.5-4.7,3.9-7.6,4.7l0,0
        c-1.5,0.4-3.1,0.6-4.7,0.6c-2.4,0-4.7-0.4-6.9-1.3v0h0c-2.3-0.9-4.5-2.4-5.8-4.6c-0.7-1.2-1.1-2.5-1.1-3.9c0-0.3,0-0.6,0.1-0.9
        c-0.6-0.3-1.1-0.8-1.5-1.4C0.3,13.9,0,13.2,0,12.4v0c0-1.1,0.5-2.1,1.2-2.8c0.7-0.7,1.7-1.2,2.8-1.2h0c0.1,0,0.2,0,0.3,0
        c0.5,0,1.1,0.1,1.6,0.3l0,0h0C6.3,8.8,6.8,9,7.1,9.3c0.1-0.1,0.3-0.1,0.4-0.2c2.3-1.4,5-1.9,7.6-2c0-1.3,0.2-2.7,0.8-3.8
        c0.5-1,1.4-1.8,2.5-2l0,0h0c0.4-0.1,0.8-0.1,1.2-0.1c1.1,0,2.2,0.3,3.2,0.7c0.5-0.7,1.1-1.2,1.9-1.5l0,0l0,0
        C25.3,0.1,25.8,0,26.2,0c0.5,0,1,0.1,1.5,0.3v0c0,0,0,0,0,0c0,0,0,0,0,0C28.4,0.6,29,1,29.4,1.6C29.8,2.2,30,3,30,3.7
        c0,0.1,0,0.3,0,0.4l0,0c0,0,0,0,0,0c-0.1,1-0.6,1.8-1.2,2.4c-0.7,0.6-1.6,1-2.5,1c-0.1,0-0.3,0-0.4,0c-0.9-0.1-1.8-0.5-2.4-1.2
        c-0.6-0.7-1-1.5-1-2.5c0,0,0-0.1,0-0.1C21.6,3.3,20.7,3,19.8,3c-0.1,0-0.3,0-0.4,0h0c-0.7,0.1-1.3,0.5-1.6,1.1v0
        c-0.5,0.9-0.6,1.9-0.6,3c2.6,0.2,5.2,0.8,7.4,2.1h0l0,0c0,0,0.1,0.1,0.2,0.1C25,9.2,25.2,9,25.4,8.9c0.7-0.5,1.5-0.7,2.3-0.7
        c0.4,0,0.7,0,1.1,0.1h0l0,0c0,0,0,0,0,0c0.8,0.2,1.6,0.7,2.2,1.3C31.5,10.4,31.9,11.2,32,12.1L32,12.1L32,12.1z M24.4,3.6
        c0,0,0,0.1,0,0.1v0c0,0.4,0.2,0.9,0.6,1.2c0.3,0.3,0.8,0.5,1.2,0.5h0c0,0,0.1,0,0.1,0c0.4,0,0.9-0.2,1.2-0.5
        C27.8,4.6,28,4.2,28,3.8v0c0,0,0-0.1,0-0.1c0-0.5-0.2-0.9-0.6-1.2c-0.3-0.3-0.8-0.5-1.2-0.5c-0.1,0-0.3,0-0.4,0.1h0l0,0
        c-0.4,0.1-0.7,0.3-1,0.6C24.6,2.9,24.4,3.2,24.4,3.6L24.4,3.6z M5.4,10.5c-0.3-0.2-0.7-0.3-1.1-0.3c-0.1,0-0.1,0-0.2,0h0l0,0
        c-0.5,0-1,0.2-1.4,0.6c-0.4,0.4-0.6,0.8-0.7,1.4v0l0,0c0,0,0,0.1,0,0.1c0,0.3,0.1,0.6,0.3,0.9c0.1,0.2,0.3,0.4,0.5,0.6
        C3.4,12.6,4.3,11.5,5.4,10.5L5.4,10.5z M27.8,16.9c0-1.2-0.4-2.3-1.1-3.2c-1.3-1.9-3.4-3.1-5.6-3.8l0,0c-0.4-0.1-0.8-0.2-1.3-0.3
        c-1.3-0.3-2.6-0.4-3.9-0.4c-1.7,0-3.5,0.3-5.2,0.8c-2.2,0.7-4.3,1.9-5.6,3.8v0c-0.7,0.9-1.1,2.1-1.1,3.3c0,0.4,0.1,0.9,0.2,1.3
        l0,0c0.2,0.9,0.7,1.8,1.3,2.5c0.6,0.7,1.4,1.3,2.2,1.8c0.2,0.1,0.4,0.2,0.5,0.3c2.3,1.3,5,1.9,7.6,1.9c0.4,0,0.9,0,1.3,0
        c2.7-0.2,5.3-1,7.5-2.6v0c0.7-0.5,1.3-1.1,1.8-1.8c0.5-0.7,0.9-1.5,1-2.3v0C27.8,17.5,27.8,17.2,27.8,16.9L27.8,16.9z M29.9,12.3
        c0-0.3-0.1-0.6-0.2-0.8l0,0l0,0c-0.2-0.4-0.5-0.7-0.8-0.9c-0.4-0.2-0.8-0.3-1.2-0.3c-0.4,0-0.7,0.1-1.1,0.3c1.1,0.9,2,2,2.6,3.3
        c0.2-0.2,0.4-0.4,0.5-0.6C29.8,13,29.9,12.6,29.9,12.3L29.9,12.3z M29.9,12.3"></path></symbol><symbol id="stumble" viewbox="0 0 32 24"><path d="M17.8,8.6l2.1,1.5l3.3-1.5l0-1.6C23,3.3,19.9,0,16,0c-3.8,0-7,3.2-7.1,6.9v9.9c0,0.9-0.8,1.6-1.7,1.6
        c-0.9,0-1.9-0.4-1.9-1.3V12H0c0,0,0,5.1,0,5.1C0,20.9,3.2,24,7.1,24c3.9,0,7.1-3.1,7.1-6.9V6.9c0-0.9,0.8-1.7,1.8-1.7
        c0.9,0,1.8,0.8,1.8,1.7V8.6z M26.7,12v5.1c0,0.9-1,1.5-1.9,1.5c-0.9,0-1.7-0.7-1.7-1.6l0-5l-3.3,1.6L17.8,12v5.1
        c0,3.8,3.2,6.9,7.1,6.9c3.9,0,7.1-3.1,7.1-6.9c0,0,0-5.1,0-5.1H26.7z"></path></symbol><symbol id="tumblr" viewbox="0 0 20.9 32"><path d="M7,0C6.8,1.8,6.7,2.4,6.1,3.6C5.5,4.7,4.7,6.2,3.7,7.1C2.8,7.9,1.4,8.7,0,9.2v5.5h4.1v8.9
        c0,1.6,0.2,2.8,0.5,3.6c0.3,0.8,0.9,1.6,1.8,2.4c0.9,0.7,2.8,1.7,2.8,1.7s1.6,0.6,3.2,0.6c1.4,0,2.7-0.1,4-0.4c1.2-0.3,3-1,4.6-1.7
        v-5.5c-1.8,1.1-4,1.9-5.8,1.9c-1,0-1.9-0.2-2.7-0.7c-0.6-0.3-1-0.8-1.2-1.4c-0.2-0.6-0.7-1.9-0.7-3.9v-5.7H19V8.6h-8.5V0H7z"></path></symbol><symbol id="twitter" viewbox="0 0 32.5 28.4"><path d="M32.5,3.4c-0.5,0.3-2.2,1-3.7,1.1c1-0.6,2.4-2.4,2.8-3.9c-0.9,0.6-3.1,1.6-4.2,1.6c0,0,0,0,0,0
        C26.1,0.9,24.4,0,22.5,0c-3.7,0-6.7,3.2-6.7,7.2c0,0.6,0.1,1.1,0.2,1.6h0C11,8.7,5.1,6,1.8,1.3c-2,3.8-0.3,8,2,9.5
        c-0.8,0.1-2.2-0.1-2.9-0.8c0,2.5,1.1,5.8,5.2,7c-0.8,0.5-2.2,0.3-2.8,0.2c0.2,2.1,3,4.9,6,4.9c-1.1,1.3-4.7,3.8-9.3,3
        c3.1,2,6.7,3.2,10.5,3.2c10.8,0,19.2-9.4,18.7-21.1c0,0,0,0,0,0c0,0,0-0.1,0-0.1c0,0,0-0.1,0-0.1C30.2,6.4,31.5,5.1,32.5,3.4z"></path></symbol><symbol id="yahoo" viewbox="-133 141 30.3 20"><path d="M-107.7,146.7c0,0,1.2-0.7,2.1-0.7s2.1,0,2.1,0l0.8-1.9h-12.9l0.1,1.4l0.8,0.4l3.3,0.1c0,0,0.2,0.7-0.3,1.1
        c-0.6,0.4-5.4,4.7-5.4,4.7l-6.2-7.5c0,0,0.1-0.2,1-0.2c0.9,0,3.5,0,3.5,0V141H-133v3.1c0,0,1.8,0,2.7,0c0.9,0,1.9,1,2.8,1.8
        c0.9,0.9,7.1,7.4,7.1,7.4v5.4c0,0-0.5,0.8-2.2,0.8c-1.8,0-2.5,0.1-2.5,0.1v1.4h14.1v-1c0,0-0.4-0.6-0.8-0.6h-3.4
        c-0.4,0-0.5-0.5-0.5-1.1c0-0.6,0-4.7,0-4.7L-107.7,146.7z"></path></symbol><symbol id="whatsapp" viewbox="0 0 32 32"><path d="M16.2,0C7.6,0,0.6,7,0.6,15.6c0,4.3,2.3,8.1,2.3,8.1L0.2,32l8.5-2.7c0,0,3.2,1.9,7.5,1.9
        c8.6,0,15.6-7,15.6-15.6C31.8,7,24.8,0,16.2,0z M16.2,28.7c-4,0-7.2-2.2-7.2-2.2l-4.9,1.6l1.6-4.8c0,0-2.6-3.5-2.6-7.8
        C3.1,8.4,9,2.5,16.2,2.5c7.2,0,13.1,5.9,13.1,13.1C29.3,22.8,23.5,28.7,16.2,28.7z"></path><path d="M10.3,8.8c0,0,0.4-0.3,0.6-0.3c0.2,0,1.2,0,1.2,0s0.3,0.1,0.5,0.4c0.2,0.3,1.2,2.8,1.3,3
        c0.1,0.2,0.3,0.7,0,1.1c-0.3,0.4-1,1.2-1,1.2s-0.3,0.2,0,0.6c0.2,0.4,1,1.6,2.1,2.6c1.1,1,2.4,1.7,3,1.9c0.7,0.2,0.8-0.1,1-0.4
        c0.2-0.3,1-1.3,1-1.3s0.3-0.4,0.8-0.2c0.5,0.2,3.1,1.5,3.1,1.5s0.3,0.1,0.3,0.4c0,0.3,0.2,1.4-0.7,2.4c-0.9,1-2.9,1.5-3.8,1.2
        c-0.9-0.3-4-1.1-6-2.9s-3.6-3.8-4.3-5.3c-0.7-1.5-0.6-2.3-0.6-2.7S9,9.6,10.3,8.8z"></path></symbol></svg><svg class="svg-symbol"><symbol id="stars-full" viewbox="0 0 14 14"><polygon points="7,0 8.8,5.1 14,5.3 9.9,8.7 11.3,14 7,11 2.7,14 4.1,8.7 0,5.3 5.2,5.1"></polygon></symbol><symbol id="stars-half" viewbox="0 0 14 14"><polygon points="7.1,0 7.1,11 2.7,14 4.1,8.7 0,5.3 5.2,5.1"></polygon></symbol><symbol id="play" viewbox="0 0 24 24"><path d="M21 12l-18 12v-24z"></path></symbol><symbol id="circle" viewbox="0 0 24 24"><circle cx="12" cy="12" r="12"></circle></symbol><symbol id="playOverlay" viewbox="-99 101 100 100"><g><circle cx="-50" cy="151" r="33"></circle></g><path class="playOverlayBorder" d="M-50,118c18.2,0,33,14.8,33,33s-14.8,33-33,33s-33-14.8-33-33S-68.2,118-50,118 M-50,116c-19.3,0-35,15.7-35,35  s15.7,35,35,35s35-15.7,35-35S-30.7,116-50,116L-50,116z"></path><g><path class="playOverlayArrow" d="M-60.3,138.6c0-2.2,1.5-3.1,3.4-1.9l19.8,12.2c1.9,1.2,1.9,3,0,4.2l-19.8,12.2c-1.9,1.2-3.4,0.3-3.4-1.9C-60.3,163.4-60.3,138.6-60.3,138.6z"></path></g></symbol><symbol id="play_alt" viewbox="0 0 24 24"><g><path d="M12 2c5.514 0 10 4.486 10 10s-4.486 10-10 10-10-4.486-10-10 4.486-10 10-10zm0-2c-6.627 0-12 5.373-12 12s5.373 12 12 12 12-5.373 12-12-5.373-12-12-12zm-2 7v10l7-5-7-5z"></path></g></symbol><symbol id="video" viewbox="0 0 32 22"><g><path d="M29,2.2c-0.7,0.2-4.6,3-7.9,5.3V2.1C21.1,1,20.1,0,19,0H2.1C1,0,0,1,0,2.1v17.7C0,21,1,22,2.1,22H19c1.2,0,2.1-1,2.1-2.1
        v-5.9c3.3,2.4,7.4,5.4,8.2,5.6c1.4,0.4,2.7-0.1,2.7-0.1V2.2C32,2.2,30.1,1.8,29,2.2z"></path></g></symbol><symbol id="video-alt" viewbox="0 0 24 24"><path d="M19.615 3.184c-3.604-.246-11.631-.245-15.23 0-3.897.266-4.356 2.62-4.385 8.816.029 6.185.484 8.549 4.385 8.816 3.6.245 11.626.246 15.23 0 3.897-.266 4.356-2.62 4.385-8.816-.029-6.185-.484-8.549-4.385-8.816zm-10.615 12.816v-8l8 3.993-8 4.007z"></path></symbol><symbol id="photo" viewbox="0 0 32 24"><path d="M30,4h-6c-0.5,0-2.9-4-4-4h-8c-1.1,0-3.6,4-4,4H2C0.9,4,0,4.9,0,6v16c0,1.1,0.9,2,2,2h28c1.1,0,2-0.9,2-2V6
            C32,4.9,31.1,4,30,4z M16,20.3c-3.9,0-7-3.1-7-7c0-3.9,3.1-7,7-7c3.9,0,7,3.1,7,7C23,17.2,19.9,20.3,16,20.3z M16,19
            c-3.1,0-5.6-2.5-5.6-5.6c0-3.1,2.5-5.6,5.6-5.6c3.1,0,5.6,2.5,5.6,5.6C21.6,16.5,19.1,19,16,19z"></path></symbol><symbol id="arrow-round" viewbox="0 0 16 28"><g><path d="M0.6,27.4c0.8,0.8,2,0.8,2.8,0l12-12c0.8-0.8,0.8-2,0-2.8l-12-12C3,0.2,2.5,0,2,0C1.5,0,1,0.2,0.6,0.6
        c-0.8,0.8-0.8,2,0,2.8L11.2,14L0.6,24.6C-0.2,25.4-0.2,26.6,0.6,27.4z"></path></g></symbol><symbol id="envelope" viewbox="0 0 24 24"><g><path d="M12 12.713l-11.985-9.713h23.97l-11.985 9.713zm0 2.574l-12-9.725v15.438h24v-15.438l-12 9.725z"></path></g></symbol><symbol id="envelope-open-solid"><svg viewbox="0 0 24 24"><path d="M.026 24l11.974-11.607 11.974 11.607h-23.948zm11.964-23.961l-11.99 8.725v12.476l7.352-7.127-5.653-4.113 10.291-7.488 10.309 7.488-5.655 4.108 7.356 7.132v-12.476l-12.01-8.725z"></path></svg></symbol><symbol id="envelope-open-outline"><svg viewbox="0 0 24 24"><path d="M11.99 0l-11.99 8.723v15.277h24v-15.277l-12.01-8.723zm.001 2.472l9.793 7.113-6.735 4.588-3.049-2.47-3.049 2.471-6.737-4.589 9.777-7.113zm-9.991 9.386l5.329 3.63-5.329 4.318v-7.948zm.474 10.142l9.526-7.723 9.526 7.723h-19.052zm19.526-2.194l-5.329-4.317 5.329-3.631v7.948z"></path></svg></symbol><symbol id="padlock"><svg viewbox="0 0 1792 1792"><path d="M640 768h512v-192q0-106-75-181t-181-75-181 75-75 181v192zm832 96v576q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-576q0-40 28-68t68-28h32v-192q0-184 132-316t316-132 316 132 132 316v192h32q40 0 68 28t28 68z"></path></svg></symbol><symbol id="settings"><svg viewbox="0 0 24 24"><path d="M24 13.616v-3.232c-1.651-.587-2.694-.752-3.219-2.019v-.001c-.527-1.271.1-2.134.847-3.707l-2.285-2.285c-1.561.742-2.433 1.375-3.707.847h-.001c-1.269-.526-1.435-1.576-2.019-3.219h-3.232c-.582 1.635-.749 2.692-2.019 3.219h-.001c-1.271.528-2.132-.098-3.707-.847l-2.285 2.285c.745 1.568 1.375 2.434.847 3.707-.527 1.271-1.584 1.438-3.219 2.02v3.232c1.632.58 2.692.749 3.219 2.019.53 1.282-.114 2.166-.847 3.707l2.285 2.286c1.562-.743 2.434-1.375 3.707-.847h.001c1.27.526 1.436 1.579 2.019 3.219h3.232c.582-1.636.75-2.69 2.027-3.222h.001c1.262-.524 2.12.101 3.698.851l2.285-2.286c-.744-1.563-1.375-2.433-.848-3.706.527-1.271 1.588-1.44 3.221-2.021zm-12 2.384c-2.209 0-4-1.791-4-4s1.791-4 4-4 4 1.791 4 4-1.791 4-4 4z"></path></svg></symbol><symbol id="bell" viewbox="0 0 24 24"><g><path d="M15.137 3.945c-.644-.374-1.042-1.07-1.041-1.82v-.003c.001-1.172-.938-2.122-2.096-2.122s-2.097.95-2.097 2.122v.003c.001.751-.396 1.446-1.041 1.82-4.667 2.712-1.985 11.715-6.862 13.306v1.749h20v-1.749c-4.877-1.591-2.195-10.594-6.863-13.306zm-3.137-2.945c.552 0 1 .449 1 1 0 .552-.448 1-1 1s-1-.448-1-1c0-.551.448-1 1-1zm3 20c0 1.598-1.392 3-2.971 3s-3.029-1.402-3.029-3h6z"></path></g></symbol><symbol id="user_alt" viewbox="0 0 24 24"><g><path d="M20.822 18.096c-3.439-.794-6.64-1.49-5.09-4.418 4.72-8.912 1.251-13.678-3.732-13.678-5.082 0-8.464 4.949-3.732 13.678 1.597 2.945-1.725 3.641-5.09 4.418-3.073.71-3.188 2.236-3.178 4.904l.004 1h23.99l.004-.969c.012-2.688-.092-4.222-3.176-4.935z"></path></g></symbol><symbol id="paperclip" viewbox="0 0 24 24"><g><path d="M21.586 10.461l-10.05 10.075c-1.95 1.949-5.122 1.949-7.071 0s-1.95-5.122 0-7.072l10.628-10.585c1.17-1.17 3.073-1.17 4.243 0 1.169 1.17 1.17 3.072 0 4.242l-8.507 8.464c-.39.39-1.024.39-1.414 0s-.39-1.024 0-1.414l7.093-7.05-1.415-1.414-7.093 7.049c-1.172 1.172-1.171 3.073 0 4.244s3.071 1.171 4.242 0l8.507-8.464c.977-.977 1.464-2.256 1.464-3.536 0-2.769-2.246-4.999-5-4.999-1.28 0-2.559.488-3.536 1.465l-10.627 10.583c-1.366 1.368-2.05 3.159-2.05 4.951 0 3.863 3.13 7 7 7 1.792 0 3.583-.684 4.95-2.05l10.05-10.075-1.414-1.414z"></path></g></symbol><symbol id="book" viewbox="0 0 24 24"><g><path d="M5.495 4c-1.375 0-1.375-2 0-2h16.505v-2h-17c-1.657 0-3 1.343-3 3v18c0 1.657 1.343 3 3 3h17v-20h-16.505z"></path></g></symbol><symbol id="caret" viewbox="0 0 16 28"><g><path d="M0.6,27.4c0.8,0.8,2,0.8,2.8,0l12-12c0.8-0.8,0.8-2,0-2.8l-12-12C3,0.2,2.5,0,2,0C1.5,0,1,0.2,0.6,0.6
        c-0.8,0.8-0.8,2,0,2.8L11.2,14L0.6,24.6C-0.2,25.4-0.2,26.6,0.6,27.4z"></path></g></symbol><symbol id="info" viewbox="0 0 24 24"><g><path d="M12 2c5.514 0 10 4.486 10 10s-4.486 10-10 10-10-4.486-10-10 4.486-10 10-10zm0-2c-6.627 0-12 5.373-12 12s5.373 12 12 12 12-5.373 12-12-5.373-12-12-12zm-.001 5.75c.69 0 1.251.56 1.251 1.25s-.561 1.25-1.251 1.25-1.249-.56-1.249-1.25.559-1.25 1.249-1.25zm2.001 12.25h-4v-1c.484-.179 1-.201 1-.735v-4.467c0-.534-.516-.618-1-.797v-1h3v6.265c0 .535.517.558 1 .735v.999z"></path></g></symbol><symbol id="mag-red" viewbox="0 0 26 26"><g><circle fill="none" stroke="#DE1400" stroke-miterlimit="10" cx="12.312" cy="12.312" r="10.804"></circle><line fill="none" stroke="#DE1400" stroke-miterlimit="10" x1="19.77" y1="19.77" x2="24.688" y2="24.688"></line></g></symbol><symbol id="close-gray" viewbox="0 0 26 26"><g><line fill="none" stroke="#768089" stroke-miterlimit="10" x1="1.426" y1="1.426" x2="24.688" y2="24.688"></line><line fill="none" stroke="#768089" stroke-miterlimit="10" x1="24.689" y1="1.426" x2="1.427" y2="24.688"></line></g></symbol><symbol id="info" viewbox="0 0 24 24"><path d="M12 2c5.514 0 10 4.486 10 10s-4.486 10-10 10-10-4.486-10-10 4.486-10 10-10zm0-2c-6.627 0-12 5.373-12 12s5.373 12 12 12 12-5.373 12-12-5.373-12-12-12zm-.001 5.75c.69 0 1.251.56 1.251 1.25s-.561 1.25-1.251 1.25-1.249-.56-1.249-1.25.559-1.25 1.249-1.25zm2.001 12.25h-4v-1c.484-.179 1-.201 1-.735v-4.467c0-.534-.516-.618-1-.797v-1h3v6.265c0 .535.517.558 1 .735v.999z"></path></symbol><symbol id="close" viewbox="0 0 28 28"><g><polygon points="28,1.9 26.1,0 14,12.1 1.9,0 0,1.9 12.1,14 0,26.1 1.9,28 14,15.9 26.1,28 28,26.1 15.9,14    "></polygon></g></symbol><symbol id="rss" viewbox="0 0 24 24"><path d="M6.503 20.752c0 1.794-1.456 3.248-3.251 3.248-1.796 0-3.252-1.454-3.252-3.248 0-1.794 1.456-3.248 3.252-3.248 1.795.001 3.251 1.454 3.251 3.248zm-6.503-12.572v4.811c6.05.062 10.96 4.966 11.022 11.009h4.817c-.062-8.71-7.118-15.758-15.839-15.82zm0-3.368c10.58.046 19.152 8.594 19.183 19.188h4.817c-.03-13.231-10.755-23.954-24-24v4.812z"></path></symbol><symbol id="download" viewbox="0 0 24 24"><path d="M16 11h5l-9 10-9-10h5v-11h8v11zm1 11h-10v2h10v-2z"></path></symbol><symbol id="users" viewbox="0 0 24 24"><path d="M10.118 16.064c2.293-.529 4.428-.993 3.394-2.945-3.146-5.942-.834-9.119 2.488-9.119 3.388 0 5.644 3.299 2.488 9.119-1.065 1.964 1.149 2.427 3.394 2.945 1.986.459 2.118 1.43 2.118 3.111l-.003.825h-15.994c0-2.196-.176-3.407 2.115-3.936zm-10.116 3.936h6.001c-.028-6.542 2.995-3.697 2.995-8.901 0-2.009-1.311-3.099-2.998-3.099-2.492 0-4.226 2.383-1.866 6.839.775 1.464-.825 1.812-2.545 2.209-1.49.344-1.589 1.072-1.589 2.333l.002.619z"></path></symbol><symbol id="tr-logotype-with-flag" viewbox="0 0 500 119.565"><g><g><g><path d="M4.836,52.219l-1.898,9.499c0,0,11.475,6.566,19.227,23.654c6.813,15.013,8.47,31.416,8.47,31.416
                            l2.846-7.833c0,0-1.564-15.878-8.544-31.411C16.151,57.995,4.836,52.219,4.836,52.219z"></path><path d="M4.836,52.219l-1.898,9.499c0,0,11.475,6.566,19.227,23.654c6.813,15.013,8.47,31.416,8.47,31.416
                            l2.846-7.833c0,0-1.564-15.878-8.544-31.411C16.151,57.995,4.836,52.219,4.836,52.219z"></path></g><g><g><path d="M4.836,51.719l-1.898,9.499c0,0,11.475,6.566,19.227,23.654c6.813,15.013,8.47,31.416,8.47,31.416l2.846-7.833
                                c0,0-1.564-15.878-8.544-31.411C16.151,57.495,4.836,51.719,4.836,51.719z"></path></g><defs><filter id="Adobe_OpacityMaskFilter" filterunits="userSpaceOnUse" x="2.938" y="51.719" width="30.543" height="64.569"><fecolormatrix type="matrix" values="-1 0 0 0 1  0 -1 0 0 1  0 0 -1 0 1  0 0 0 1 0" color-interpolation-filters="sRGB" result="source"></fecolormatrix></filter></defs><mask maskunits="userSpaceOnUse" x="2.938" y="51.719" width="30.543" height="64.569" id="SVGID_1_"><g filter="url(#Adobe_OpacityMaskFilter)"><image overflow="visible" width="36" height="69" xlink:href="data:image/jpeg;base64,/9j/4AAQSkZJRgABAgEASABIAAD/7AARRHVja3kAAQAEAAAAHgAA/+4AIUFkb2JlAGTAAAAAAQMA
                                    EAMCAwYAAAG4AAACFgAAA5P/2wCEABALCwsMCxAMDBAXDw0PFxsUEBAUGx8XFxcXFx8eFxoaGhoX
                                    Hh4jJSclIx4vLzMzLy9AQEBAQEBAQEBAQEBAQEABEQ8PERMRFRISFRQRFBEUGhQWFhQaJhoaHBoa
                                    JjAjHh4eHiMwKy4nJycuKzU1MDA1NUBAP0BAQEBAQEBAQEBAQP/CABEIAEUAJAMBIgACEQEDEQH/
                                    xACIAAEBAQEBAQAAAAAAAAAAAAAABwUGBAIBAQAAAAAAAAAAAAAAAAAAAAAQAAEDAwQDAQAAAAAA
                                    AAAAAAUCBAYQARUgMAMHABMWFxEAAgECAwYFBAMAAAAAAAAAAQIDEQQhQRIAIDEiExRRYXEyBRCh
                                    IxWRgkMSAQAAAAAAAAAAAAAAAAAAADD/2gAMAwEAAhEDEQAAAM3D6/sSGvf4ABSZt9FYktomRiAA
                                    6bp5lZCNgAUuadiZjUHGgaIZwP/aAAgBAgABBQDf/9oACAEDAAEFAN//2gAIAQEAAQUAhUVZnWZ4
                                    C9BPa9cnBjdoXEMjLI2IcBSVYJLeV9edR9RcXVC18a4ucsdEzAUkUfrAjWMNdmDr84vQhdpLEtHW
                                    L32i8en7avWbu/EZyrf9KqAyeV8//9oACAECAgY/AH//2gAIAQMCBj8Af//aAAgBAQEGPwC+lvld
                                    UVo47eeNgCHALSChqDgV4jPDY2t0NSNUwTgckqeI8CMxl/B3JPip5BBcvMZUMjAJJrCRhUJpzco5
                                    c8vJ7O8TUjYo498b5OhyI2lsLg6jHQpIAQsiMKqwr9/Oo3B8R8i+q4RK287EapFX/Nq8XAxrmOPD
                                    ET24rd2OqRBQkvHSrxgLmaAjDKme4skbFHQhlZTQqRiCCM9o7tgFuEJiuEWtBIvhXJlIP2y2uIIk
                                    0W8tJ7cYU0SYkKF4BX1KPTcW3lNLa/pC/lJX8TcCeJ0/2qeG0HyCAlrOTTJSlBHNQajXH3qoHrul
                                    gEeW9tWWjAhBcAFeBqQFlXA+Vd26siWLW0wkBJqoSZcFXHDmjYn127Ht/wAP7HT2+jl6HV1eyns6
                                    ePhp8tye1aQLHcwEiM055I2UrTOoQvt3mlun3Ha5V1dPs9XGmnVj6bkP6mnf6ZejWnHpPqpqwrpr
                                    Sv0//9k=" transform="matrix(1 0 0 1 0 49.377)"></image></g></mask><g opacity="0.23" mask="url(#SVGID_1_)"><path d="M4.836,51.719l-1.898,9.499c0,0,11.475,6.566,19.227,23.654c6.813,15.013,8.47,31.416,8.47,31.416
                                l2.846-7.833c0,0-1.564-15.878-8.544-31.411C16.151,57.495,4.836,51.719,4.836,51.719z"></path></g></g></g><g><g><path d="M8.16,34.418l-2.054,11c0,0,12.501,8.385,19.303,23.496c8.179,18.156,9.506,35.847,9.506,35.847
                            l3.238-9.101c0,0-0.903-14.925-7.833-31.89C21.297,41.7,8.16,34.418,8.16,34.418z"></path><path d="M23.269,42.807c0,0,5.469-16.144,18.835-15.909c13.138,0.238,18.492,11.546,30.941,10.453
                            c17.877-1.588,30.146-24.692,30.146-24.692l-1.821-8.466c0,0-11,20.179-28.558,20.894c-11.637,0.467-15.672-9.105-28.009-9.893
                            c-16.77-1.076-22.795,17.88-22.795,17.88L23.269,42.807z"></path><path d="M39.574,83.87c0,0,7.12-14.241,19.938-14.082C71.225,69.934,77.271,81.26,89.737,80.31
                            c14.556-1.107,23.501-21.52,23.501-21.52l-1.661-7.594c0,0-7.68,17.488-22.312,18.036c-11.638,0.441-15.279-9.228-27.617-10.128
                            c-14.088-1.029-21.603,13.533-21.603,13.533L39.574,83.87z"></path><path d="M8.16,34.418l-2.054,11c0,0,12.501,8.385,19.303,23.496c8.179,18.156,9.506,35.847,9.506,35.847
                            l3.238-9.101c0,0-0.903-14.925-7.833-31.89C21.297,41.7,8.16,34.418,8.16,34.418z"></path><path d="M23.269,42.807c0,0,5.469-16.144,18.835-15.909c13.138,0.238,18.492,11.546,30.941,10.453
                            c17.877-1.588,30.146-24.692,30.146-24.692l-1.821-8.466c0,0-11,20.179-28.558,20.894c-11.637,0.467-15.672-9.105-28.009-9.893
                            c-16.77-1.076-22.795,17.88-22.795,17.88L23.269,42.807z"></path><path d="M39.574,83.87c0,0,7.12-14.241,19.938-14.082C71.225,69.934,77.271,81.26,89.737,80.31
                            c14.556-1.107,23.501-21.52,23.501-21.52l-1.661-7.594c0,0-7.68,17.488-22.312,18.036c-11.638,0.441-15.279-9.228-27.617-10.128
                            c-14.088-1.029-21.603,13.533-21.603,13.533L39.574,83.87z"></path></g><g><g><g><path d="M8.16,33.918l-2.054,11c0,0,12.501,8.385,19.303,23.496c8.179,18.156,9.506,35.847,9.506,35.847l3.238-9.101
                                    c0,0-0.903-14.925-7.833-31.89C21.297,41.2,8.16,33.918,8.16,33.918z"></path><path d="M23.269,42.307c0,0,5.469-16.144,18.835-15.909c13.138,0.238,18.492,11.546,30.941,10.453
                                    c17.877-1.588,30.146-24.692,30.146-24.692l-1.821-8.466c0,0-11,20.179-28.558,20.894c-11.637,0.467-15.672-9.105-28.009-9.893
                                    c-16.77-1.076-22.795,17.88-22.795,17.88L23.269,42.307z"></path><path d="M39.574,83.37c0,0,7.12-14.241,19.938-14.082C71.225,69.434,77.271,80.76,89.737,79.81
                                    c14.556-1.107,23.501-21.52,23.501-21.52l-1.661-7.594c0,0-7.68,17.488-22.312,18.036
                                    c-11.638,0.441-15.279-9.228-27.617-10.128c-14.088-1.029-21.603,13.533-21.603,13.533L39.574,83.37z"></path></g></g><defs><filter id="Adobe_OpacityMaskFilter_1_" filterunits="userSpaceOnUse" x="6.106" y="3.692" width="107.132" height="100.569"><fecolormatrix type="matrix" values="-1 0 0 0 1  0 -1 0 0 1  0 0 -1 0 1  0 0 0 1 0" color-interpolation-filters="sRGB" result="source"></fecolormatrix></filter></defs><mask maskunits="userSpaceOnUse" x="6.106" y="3.692" width="107.132" height="100.569" id="SVGID_2_"><g filter="url(#Adobe_OpacityMaskFilter_1_)"><image overflow="visible" width="112" height="105" xlink:href="data:image/jpeg;base64,/9j/4AAQSkZJRgABAgEASABIAAD/7AARRHVja3kAAQAEAAAAHgAA/+4AIUFkb2JlAGTAAAAAAQMA
                                    EAMCAwYAAAIzAAADowAACUD/2wCEABALCwsMCxAMDBAXDw0PFxsUEBAUGx8XFxcXFx8eFxoaGhoX
                                    Hh4jJSclIx4vLzMzLy9AQEBAQEBAQEBAQEBAQEABEQ8PERMRFRISFRQRFBEUGhQWFhQaJhoaHBoa
                                    JjAjHh4eHiMwKy4nJycuKzU1MDA1NUBAP0BAQEBAQEBAQEBAQP/CABEIAGkAcAMBIgACEQEDEQH/
                                    xACeAAEAAwEBAQAAAAAAAAAAAAAABQYHAwIEAQEAAAAAAAAAAAAAAAAAAAAAEAACAwABBAICAwAA
                                    AAAAAAAEBQIDBgcAEDABIFBAFBUWFxEAAgECBAMEBgYGCwAAAAAAAQIDEQQAITESQSIFUWGBExAg
                                    MDJCFHGRobHRI0DwwWKCNVJy0jNTY5PjJKQVEgEAAAAAAAAAAAAAAAAAAABQ/9oADAMBAAIRAxEA
                                    AADPwDucFrFUd+AA+3jrpnEFbKmAfbscF1LQyD6jSaFbZwxSa1ERsV6yk5A0eqXC2FLz2TigD1aa
                                    oNAg62AAPWo5Z1Ndx3bszK6W4qLa/RiTQKIcj0LfMcjOwW6x5lthnOoUylF97ZUN9+XHdDPE76gS
                                    Yxrt8gA1PLLqQ0HZa0AAAAAJuEH1/IAAAAH/2gAIAQIAAQUA+x//2gAIAQMAAQUA+x//2gAIAQEA
                                    AQUA8ahWS3YbFNSmdfAIEw+8fjbRXVEcbaKmo0EwC/uECYfflM5BAv5EaiHN+6hWS3YJ0i5MN2ZK
                                    gGwznjUyj3ZltFWQs42ck+0qBako2mo/hQ/hxwsqGSanbDpJz3uqlNdyM+GuQ61S7h30+yBS1lFE
                                    GEdsIhBMzmoy5SApa/qU8eznOyfaE51zVciOwY/6p023r5lH4cf6FdNcaEKwF0SQtGf44TnXPG7G
                                    LeGvz/p4q8MITsnpcjUmzfQpRAZCFzS7WbpV7XP+svg7m1I2Xzw1Nubz9tbzjWPqBQpAZHUITsni
                                    8Xcuu5IfQjR247d/otOSV3olLg85U3OIJGDpP5LTUdLuRURc6ra7q2SdY2rnxnn5TV59Oo60OhDQ
                                    hlFEGEdqL7Rr7PVbtHgzx1uTfPjXpvZS/aprFPIiU2P9gQ9OuQ1IdTNmY1M+HG537CHUzNEa+TjA
                                    qcGnINMK9P5MaUOJpGzG5ox/H//aAAgBAgIGPwBH/9oACAEDAgY/AEf/2gAIAQEBBj8A9nDY2ykt
                                    Iw3uBURx15pG0yUfhh7a2XZayRpLAu4sQpGxtxbjvRvVFtZQvPM3wIK0FQKnsGepywJJGt7djWsU
                                    kjFhQ8fKR1+3Bkja3uGFKRRyMGNTw81EX7cG2vYXgmX4HFKipFR2jLUZeoLayheeZvgQVoKgVPYM
                                    9TlgxOVkvJjvuJQONKCNTrtXv41OEt7dFLWKmOW4BB8xmo2zLhGa+JPqQ2NspLSMN7gVEcdeaRtM
                                    lH4YW3sogpoBJMQPMkIzq7cdfDh6flb+ETRVDAEkFWHFWWhBwZejy/NR/wCBKVSUaDJ+VG4n4fHH
                                    yzdOnMlQu5ULR1b/ADVqlM9a5YY9QdLBBUAZTuTlTljbbT+Kvdgw2MW1nA82VjueQqKVYn7hl3YF
                                    vZuv/pXGSA5mKPOstNNclr9tPV+fB3TX7sWOfKkTNGq69oY+Pdj5O1Rbq/Iqyk0SGo5S9Myf3csu
                                    IyqzLeBAxJCLFFRQeA3ITl3nG69KX0J1RlWJhSvuPEop4g4RI5BBesOa0kNH3Z5ISAH0ry8NQPUk
                                    toGE/UwAFhzKx7hk0h0y/o1rpoM8SXV1IZZ5TukkbUn0zHqNpHKt1M5jkZQXMaqIwVb3lo2+nHHG
                                    WxlJ+XuKeOx6aMPt1HECKaGQG7rLbxKDUpNJJI4JyNNqHfnrl24aSRi7uSzMxqWJzJJPH0rJGxR0
                                    IZWU0KkZggjjhIrsJfwrqZKrNtAoB5o786spPfj+V/8AY/2cGKNxZQEnlt6q5WtVDSE7sv3dtez1
                                    bfobMY72ESFQ9Asu6R5KRmuoDZg+GJLS7jEsEoo6H7x2EcDh7OUMbYsz2khNVdCaV4DdSgb8Ke0W
                                    SNijoQyspoVIzBBHHC9PvyF6kg5W0E6qKkjsYDUeI40ZIx/zLbdLbEAVZqZxVNKB8uOtDw9kscal
                                    3chVVRUsTkAAOOLO4oXvo5dt5IlShEoJzroEKqo010qfRHdWshiniO6ORdQcRX8Q2FqrLFUMY5F9
                                    5TT6x3EYmkRNtvefnxEVI3N/eip476mg0BHoW+6hI9rZvnEigebKtPeBbJR2Ghr9RwsMfTrdlX4p
                                    Y1lc1zzeQMx+vDRt022CuCpKRIjUPYyAMD3g4M3Q5CXBZmtp2FCNVWJ9o+jmP8WJLW6jMU8R2yRt
                                    qD6FjjUu7kKqqKlicgABxwOq9VGy7Sot7cEHy6gqXcqSCSDkOH06J0S3cGSQiS8A+FFo0aHL4jza
                                    1yHA+k9NmalvfUCVOSzr7mpoN45dKk7cJfKB5ljICSSR+XMRGwA0J37MSXV7HvsrSnKa7ZJTmqnK
                                    hAGbCvZwODNcypBAlKu7BFHAZnLDrZQzXbqRsYgRRPWleZquKf1PxxHFciSykcDc0gDRBzQbd6En
                                    jqVA7aYWWF1kicBkdCGVgdCCMjgRdQtknVfdY1DrmDyutGWtM6HDMs10gYkhFdKKDwG6InLvOCen
                                    2qRO2TSmryUNKje5ZqZaDLHnz8871Fvbg0aRh9yjif24kurqQyzyndJI2pPpjuIW2TQuskbZHayH
                                    cpz7xhhEfLTqNqdhYAlPPjyqAdV3duL6+uTSKC5kYioBYiKKirWmbHIYN1dHai1EEAPJEnYO0nie
                                    P1D077CdkQmrwnmifSu5DlU0pUZ9+Al9WwnJAo9XiJJplIoy79wFO3H8ztP9eP8AtYePprfO3eaq
                                    QpEKsDSrMdu4dm2te0a4e9vX3yvoNFRRoiDgB+ufqtasy77OZkVB7wjk/NVm+lman0Y6j0qSQfKm
                                    8e8ES027phuRq0rXY4Htby0FPLmgErV97dE4VaeEjYndZBI00cTuo1jYII9jd9FDePtbO4upFhgT
                                    zd8jnaorFIoqT3nFx1CbJ7hy23Xao5UStBXaoA/SP//Z" transform="matrix(1 0 0 1 4 1.377)"></image></g></mask><g opacity="0.23" mask="url(#SVGID_2_)"><g><path d="M8.16,33.918l-2.054,11c0,0,12.501,8.385,19.303,23.496c8.179,18.156,9.506,35.847,9.506,35.847
                                    l3.238-9.101c0,0-0.903-14.925-7.833-31.89C21.297,41.2,8.16,33.918,8.16,33.918z"></path><path d="M23.269,42.307c0,0,5.469-16.144,18.835-15.909c13.138,0.238,18.492,11.546,30.941,10.453
                                    c17.877-1.588,30.146-24.692,30.146-24.692l-1.821-8.466c0,0-11,20.179-28.558,20.894c-11.637,0.467-15.672-9.105-28.009-9.893
                                    c-16.77-1.076-22.795,17.88-22.795,17.88L23.269,42.307z"></path><path d="M39.574,83.37c0,0,7.12-14.241,19.938-14.082C71.225,69.434,77.271,80.76,89.737,79.81
                                    c14.556-1.107,23.501-21.52,23.501-21.52l-1.661-7.594c0,0-7.68,17.488-22.312,18.036
                                    c-11.638,0.441-15.279-9.228-27.617-10.128c-14.088-1.029-21.603,13.533-21.603,13.533L39.574,83.37z"></path></g></g></g></g><g><g><path d="M161.441,30.68l-0.344,8.629c-0.468-0.057-7.58-0.287-12.065-0.287
                            c-0.704,9.268-1.223,23.257-1.287,30.55H135.21c0.928-9.332,1.579-18.775,1.694-30.55c-4.027,0-8.051,0.174-12.13,0.287
                            l0.289-8.629H161.441z"></path><path d="M164.37,51.094c0.3-2.56,2.088-5.238,5.303-5.238c2.847,0,4.282,1.783,4.282,5.238H164.37z
                             M184.479,56.506c0.3-1.49,0.419-2.974,0.419-4.46c0-8.273-5.355-12.849-15.11-12.849c-15.827,0-17.078,13.38-17.078,16.535
                            c0,11.724,8.273,14.579,17.729,14.579c3.455,0,6.961-0.424,10.356-1.132l1.426-8.331c-3.328,0.95-6.903,1.965-10.407,1.965
                            c-3.932,0-7.8-1.668-7.8-6.307H184.479z"></path><path d="M212.27,49.127c-2.442-0.834-4.998-1.425-7.556-1.425c-4.582,0-7.499,2.674-7.499,7.313
                            c0,4.463,2.38,6.782,6.837,6.782c2.507,0,5.062-0.594,7.379-1.426l-1.435,8.861c-2.912,0.716-5.885,1.077-8.856,1.077
                            c-9.704,0-15.227-5.237-15.227-15.056c0-3.149,0.774-16.058,15.763-16.058c3.87,0,7.02,0.35,10.054,1.126L212.27,49.127z"></path><path d="M227.375,29.911c-0.234,2.2-0.887,9.938-1.069,14.037l0.124,0.122c2.673-3.869,5.709-4.873,11.414-4.873
                            c5.836,0,10.892,2.196,10.892,9.455c0,1.61-0.834,13.505-0.834,20.945h-11.72c0.361-5.178,0.897-10.355,0.897-15.531
                            c0-2.914-0.897-5.592-4.348-5.592c-3.038,0-5.059,2.078-5.887,4.875c-1.007,3.156-1.254,9.882-1.494,16.247h-11.834
                            c0.834-7.44,2.021-25.285,2.021-39.686H227.375z"></path><path d="M161.441,30.68l-0.344,8.629c-0.468-0.057-7.58-0.287-12.065-0.287
                            c-0.704,9.268-1.223,23.257-1.287,30.55H135.21c0.928-9.332,1.579-18.775,1.694-30.55c-4.027,0-8.051,0.174-12.13,0.287
                            l0.289-8.629H161.441z"></path><path d="M164.37,51.094c0.3-2.56,2.088-5.238,5.303-5.238c2.847,0,4.282,1.783,4.282,5.238H164.37z
                             M184.479,56.506c0.3-1.49,0.419-2.974,0.419-4.46c0-8.273-5.355-12.849-15.11-12.849c-15.827,0-17.078,13.38-17.078,16.535
                            c0,11.724,8.273,14.579,17.729,14.579c3.455,0,6.961-0.424,10.356-1.132l1.426-8.331c-3.328,0.95-6.903,1.965-10.407,1.965
                            c-3.932,0-7.8-1.668-7.8-6.307H184.479z"></path><path d="M212.27,49.127c-2.442-0.834-4.998-1.425-7.556-1.425c-4.582,0-7.499,2.674-7.499,7.313
                            c0,4.463,2.38,6.782,6.837,6.782c2.507,0,5.062-0.594,7.379-1.426l-1.435,8.861c-2.912,0.716-5.885,1.077-8.856,1.077
                            c-9.704,0-15.227-5.237-15.227-15.056c0-3.149,0.774-16.058,15.763-16.058c3.87,0,7.02,0.35,10.054,1.126L212.27,49.127z"></path><path d="M227.375,29.911c-0.234,2.2-0.887,9.938-1.069,14.037l0.124,0.122c2.673-3.869,5.709-4.873,11.414-4.873
                            c5.836,0,10.892,2.196,10.892,9.455c0,1.61-0.834,13.505-0.834,20.945h-11.72c0.361-5.178,0.897-10.355,0.897-15.531
                            c0-2.914-0.897-5.592-4.348-5.592c-3.038,0-5.059,2.078-5.887,4.875c-1.007,3.156-1.254,9.882-1.494,16.247h-11.834
                            c0.834-7.44,2.021-25.285,2.021-39.686H227.375z"></path></g><g><g><g><path d="M161.441,30.18l-0.344,8.629c-0.468-0.057-7.58-0.287-12.065-0.287c-0.704,9.268-1.223,23.257-1.287,30.55H135.21
                                    c0.928-9.332,1.579-18.775,1.694-30.55c-4.027,0-8.051,0.174-12.13,0.287l0.289-8.629H161.441z"></path><path d="M164.37,50.594c0.3-2.56,2.088-5.238,5.303-5.238c2.847,0,4.282,1.783,4.282,5.238H164.37z M184.479,56.006
                                    c0.3-1.49,0.419-2.974,0.419-4.46c0-8.273-5.355-12.849-15.11-12.849c-15.827,0-17.078,13.38-17.078,16.535
                                    c0,11.724,8.273,14.579,17.729,14.579c3.455,0,6.961-0.424,10.356-1.132l1.426-8.332c-3.328,0.951-6.903,1.965-10.407,1.965
                                    c-3.932,0-7.8-1.668-7.8-6.307H184.479z"></path><path d="M212.27,48.627c-2.442-0.834-4.998-1.425-7.556-1.425c-4.582,0-7.499,2.674-7.499,7.313
                                    c0,4.463,2.38,6.782,6.837,6.782c2.507,0,5.062-0.594,7.379-1.426l-1.435,8.861c-2.912,0.716-5.885,1.077-8.856,1.077
                                    c-9.704,0-15.227-5.237-15.227-15.056c0-3.149,0.774-16.058,15.763-16.058c3.87,0,7.02,0.35,10.054,1.126L212.27,48.627z"></path><path d="M227.375,29.411c-0.234,2.2-0.887,9.938-1.069,14.037l0.124,0.122c2.673-3.869,5.709-4.873,11.414-4.873
                                    c5.836,0,10.892,2.196,10.892,9.455c0,1.61-0.834,13.505-0.834,20.945h-11.72c0.361-5.178,0.897-10.355,0.897-15.531
                                    c0-2.914-0.897-5.592-4.348-5.592c-3.038,0-5.059,2.078-5.887,4.875c-1.007,3.156-1.254,9.882-1.494,16.247h-11.834
                                    c0.834-7.44,2.021-25.285,2.021-39.686H227.375z"></path></g></g><defs><filter id="Adobe_OpacityMaskFilter_2_" filterunits="userSpaceOnUse" x="124.774" y="29.411" width="123.962" height="40.4"><fecolormatrix type="matrix" values="-1 0 0 0 1  0 -1 0 0 1  0 0 -1 0 1  0 0 0 1 0" color-interpolation-filters="sRGB" result="source"></fecolormatrix></filter></defs><mask maskunits="userSpaceOnUse" x="124.774" y="29.411" width="123.962" height="40.4" id="SVGID_3_"><g filter="url(#Adobe_OpacityMaskFilter_2_)"><image overflow="visible" width="129" height="45" xlink:href="data:image/jpeg;base64,/9j/4AAQSkZJRgABAgEASABIAAD/7AARRHVja3kAAQAEAAAAHgAA/+4AIUFkb2JlAGTAAAAAAQMA
                                    EAMCAwYAAAIbAAADUAAAB8z/2wCEABALCwsMCxAMDBAXDw0PFxsUEBAUGx8XFxcXFx8eFxoaGhoX
                                    Hh4jJSclIx4vLzMzLy9AQEBAQEBAQEBAQEBAQEABEQ8PERMRFRISFRQRFBEUGhQWFhQaJhoaHBoa
                                    JjAjHh4eHiMwKy4nJycuKzU1MDA1NUBAP0BAQEBAQEBAQEBAQP/CABEIAC0AgQMBIgACEQEDEQH/
                                    xAClAAADAQEAAwEAAAAAAAAAAAAFBgcABAECAwgBAQAAAAAAAAAAAAAAAAAAAAAQAAEDAgYCAgMB
                                    AAAAAAAAAAUDBAYAARACFRYHFxQ2QBEgEzUnEQABAgQCBgYHBgILAAAAAAACAQMRIRIEABMQMSIy
                                    FAVBUYEjNBVxQlIzo7PTIGGRooMWYpLwobHRcpPDJHSE9BIBAAAAAAAAAAAAAAAAAAAAQP/aAAwD
                                    AQACEQMRAAAA9zqcwhDMCufeQVnhJpqWmAfGHMmjG2DxhmlrRicaoLIq7YzAvsBYJpS04aQzCBPv
                                    7BPAx7uQj6d8poBQAhuIFo5Q5kh+2M3qBctMkNpxY/MioJ0rZ+fFOKxCkhoZyLRUvz+/oBYOlFwo
                                    bY//2gAIAQIAAQUA+X//2gAIAQMAAQUA+X//2gAIAQEAAQUAhsPCvwexIpWxIpWxIpV4HFL2/KCi
                                    B5cvsSKVKGjFkexAz+4YUBn+slak812+/jssIH1W/GAnKk44wE5kpDGCIBWPRgifVb8YCcqV+MQP
                                    1DhVw0zrJx5Z+T6xA1J4MuEa4QT2uuQmyjyUsmTUe1lBs0NvGiRQkPlDZFzHgwxISMLF2Idmjyix
                                    zLgyDU7J6Oy0SCVZPWz9rIbWuAwgntdE75b8k0dmIwC77OA1fkiOL2rlNBXMhXFeEid3eneOkV04
                                    3IP4OHGVrXP1MHKjOaiC7IyyJBxhZPYkUrkdqyHto1IGx0eqkmsnkBBE88atdwVwgnqkrdZGkcwj
                                    O4NQ/wBWo5quqx3cfmD+w/Fc9gePJ9zeUG1jzh/YfilOx/0h9/1m7V+qAdgaUf7A0qv/2gAIAQIC
                                    Bj8AX//aAAgBAwIGPwBf/9oACAEBAQY/AG7/AJizxDtwZqG24FAASt092aIsxVY/fjwPxnvqY8D8
                                    Z76mPA/Ge+piHAw+/Oe+p9t225g1nMhbk4IVEG0htiixBRXUS48D8Z76mLy15ciJaskIgKEp0kgD
                                    mDUSqsjin2GOWrYZ+RXB3OojWZObuWXtdeGOW8BkZ9fe51dNAE5u5Q+z16G7LguJzGRerzcuFRGF
                                    MMs/YwSW/K0atm1RHrk7haUiqREURnaKE4fiqRwiXN3cOvTqNuhsVnKAELi/mwqW13cNPSpNyhwU
                                    nOICLa/mwKXEHbdxVRq4bjSsPVKO6UJw/BVhgkt4NW7aojtw5GlI+qMN4oTh+KpHCJc3dw69Oo26
                                    GxWcoAQuL+bEri7j0bbf0sX/AC1Xc/ItF72miqsrdzdiUN7r0X19zR82Wn7l82WWaa1AnFIDIyqR
                                    Ip6sO1NWPEXf87f0cLf27/E2glBxCFANoSWkIzVCmsFVIejq0WP63yXNFjaNQR24YZaBSklRvOik
                                    e1cN2lo2jTDSQAE/tXrVelcMNcm5ed66aKTx5LrrYDqFO6glSrH1pQ1TwT3NbRbK6Bwgy1A20IUQ
                                    SQ0F3aTehrXVjmLbw1CNu46PRA2hVwFl1EKYt+XtLFGAgRT2zXaMpquslVcFeXp0tjIRSZmXQAJK
                                    K/0XBC/YOhbpGhwDEzWezFskBEin8S9uHeb2Crw7PL27d0TRRNHXXScRIalgITVF0Axdq45cGiHk
                                    sjUSAtSISqSiOseuP3YbvLRxHWHkqA06ehfQqLJUxzOM/wDaP/LLTY/rfJc0cpjCVqX403MNAWd4
                                    0+bhto6itCBDSREHruDPZx4e7/kb+tjIet7nJd2HMxtsgpLZKsUcKKQ1yXRy64QYstm82ZSkTiAQ
                                    J2oBaOaf9f8A1tF/c5iPCb5o24kIK2C0Nwh0UImBN0qgeecNhIqtIJBtUgurbAll145n/wAR/wCW
                                    Wl+PRaHD/Ma0XF21BXbdy3dBCmlQNNEke1MBeWZ1AUjBd9s+kDToVMI1zC2B8R3SWKGM0XZMYEMY
                                    TguPA/Ge+piwtrK0YtwfNw3CabECVWUEQRVGEU71deAeAkS7bERu2tSi5CaokV2SXd/vwTTwC40a
                                    KJgaIQki60VFkuBcb5dagYKhCQsNooqk0VFQcc/5jIEcu0tMtOjgworj/HVGHRpsf1vnOY5i6aKS
                                    EwTSIOuL/cis+pTnpP8Ab8eMyir937qoavf7O9Tj/wAWH/OY+YRHPjR7A0+62d2GrC/t/OzpZmXD
                                    L1FTm1931wr7J4DiPL82Kx4mvN1yq4Xu/RDtnhzK8szKVpys7MjCVGdsR/xS68NfuKvNoXJjRRTH
                                    apydiPX06o9GA8mzuMlDIjGmpN+EqIwjVs9eA4jy/NiseJrzdcquF7v0Q7Z4DheCrqnwm/CC73Gb
                                    EPRPF75XHxTnGR4fxUs33vZuywsYwh0cHH+rQz5LHy+J5PhvbKv321vRw951Hy+IZ3hvbGj3O1vQ
                                    0f/Z" transform="matrix(1 0 0 1 122 27.377)"></image></g></mask><g opacity="0.36" mask="url(#SVGID_3_)"><g><path d="M161.441,30.18l-0.344,8.629c-0.468-0.057-7.58-0.287-12.065-0.287
                                    c-0.704,9.268-1.223,23.257-1.287,30.55H135.21c0.928-9.332,1.579-18.775,1.694-30.55c-4.027,0-8.051,0.174-12.13,0.287
                                    l0.289-8.629H161.441z"></path><path d="M164.37,50.594c0.3-2.56,2.088-5.238,5.303-5.238c2.847,0,4.282,1.783,4.282,5.238H164.37z
                                     M184.479,56.006c0.3-1.49,0.419-2.974,0.419-4.46c0-8.273-5.355-12.849-15.11-12.849c-15.827,0-17.078,13.38-17.078,16.535
                                    c0,11.724,8.273,14.579,17.729,14.579c3.455,0,6.961-0.424,10.356-1.132l1.426-8.332c-3.328,0.951-6.903,1.965-10.407,1.965
                                    c-3.932,0-7.8-1.668-7.8-6.307H184.479z"></path><path d="M212.27,48.627c-2.442-0.834-4.998-1.425-7.556-1.425c-4.582,0-7.499,2.674-7.499,7.313
                                    c0,4.463,2.38,6.782,6.837,6.782c2.507,0,5.062-0.594,7.379-1.426l-1.435,8.861c-2.912,0.716-5.885,1.077-8.856,1.077
                                    c-9.704,0-15.227-5.237-15.227-15.056c0-3.149,0.774-16.058,15.763-16.058c3.87,0,7.02,0.35,10.054,1.126L212.27,48.627z"></path><path d="M227.375,29.411c-0.234,2.2-0.887,9.938-1.069,14.037l0.124,0.122
                                    c2.673-3.869,5.709-4.873,11.414-4.873c5.836,0,10.892,2.196,10.892,9.455c0,1.61-0.834,13.505-0.834,20.945h-11.72
                                    c0.361-5.178,0.897-10.355,0.897-15.531c0-2.914-0.897-5.592-4.348-5.592c-3.038,0-5.059,2.078-5.887,4.875
                                    c-1.007,3.156-1.254,9.882-1.494,16.247h-11.834c0.834-7.44,2.021-25.285,2.021-39.686H227.375z"></path></g></g></g></g><g><g><path d="M264.56,38.237c-0.651,10.415-0.947,20.884-1.064,31.36H251.18c1.369-12.313,1.841-23.799,1.901-39.686
                            h21c2.859,0,14.275,0.297,14.275,10.534c0,6.246-3.686,9.636-9.28,11.601c2.324,5.946,5.239,11.657,7.731,17.551h-13.205
                            c-2.142-7.561-4.937-14.872-7.675-22.257c0.957,0.187,1.966,0.3,2.914,0.3c3.454,0,7.554-1.307,7.554-5.412
                            c0-3.991-3.988-3.991-6.718-3.991H264.56z"></path><path d="M297.821,51.094c0.293-2.56,2.075-5.238,5.284-5.238c2.861,0,4.29,1.783,4.29,5.238H297.821z
                             M317.928,56.506c0.295-1.49,0.418-2.974,0.418-4.46c0-8.273-5.359-12.849-15.121-12.849c-15.821,0-17.067,13.38-17.067,16.535
                            c0,11.724,8.274,14.579,17.734,14.579c3.438,0,6.952-0.424,10.352-1.132l1.421-8.331c-3.337,0.95-6.9,1.965-10.41,1.965
                            c-3.927,0-7.797-1.668-7.797-6.307H317.928z"></path><path d="M331.374,47.938c1.427-0.361,2.85-0.655,4.34-0.655c4.402,0,6.607,2.738,6.607,7.023
                            c0,3.51-1.603,7.907-5.83,7.907c-4.046,0-5.709-3.924-5.709-7.378C330.782,52.516,331.017,50.199,331.374,47.938z
                             M329.827,83.163c0-5.478,0.302-11.011,0.474-16.545c3.034,2.44,6.666,3.692,10.532,3.692c8.565,0,12.785-7.911,12.785-15.586
                            c0-8.093-4.043-15.528-16.178-15.528c-6.658,0-11.958,0.652-17.305,1.541c0,14.161-0.846,28.321-2.095,42.425H329.827z"></path><path d="M376.76,65.789l-0.112-0.126c-2.44,3.57-6.132,4.647-10.407,4.647c-8.274,0-10.655-4.054-10.655-9.046
                            c0-1.903,1.069-15.467,1.069-21.358h11.658c-0.227,5.296-1.065,10.589-1.065,15.825c0,2.856,0.952,5.295,4.222,5.295
                            c3.038,0,4.709-2.375,5.291-5.055c0.778-3.333,0.899-10.173,1.074-16.065h11.547c-0.955,9.871-1.432,19.812-1.669,29.69H376.76
                            V65.789z"></path><path d="M403.125,47.938c1.428-0.361,2.854-0.655,4.338-0.655c4.405,0,6.601,2.738,6.601,7.023
                            c0,3.51-1.6,7.907-5.83,7.907c-4.042,0-5.709-3.924-5.709-7.378C402.524,52.516,402.761,50.199,403.125,47.938z M401.69,65.847
                            h0.12c2.317,3.039,5.357,4.464,9.289,4.464c9.574,0,14.265-8.034,14.265-16.778c0-9.342-5.463-14.335-14.626-14.335
                            c-1.196,0-2.385,0.056-3.515,0.173c-1.186,0.118-2.318,0.298-3.511,0.536c0.237-4.226,0.479-7.14,0.895-9.996h-11.837
                            c-0.178,13.271-1.075,26.473-2.024,39.686h10.89L401.69,65.847z"></path><path d="M440.253,29.911c-0.653,6.664-1.971,29.273-2.151,39.686h-11.836c1.126-13.213,1.785-26.415,2.144-39.686
                            H440.253z"></path><path d="M441.02,69.597c1.008-8.983,1.426-17.85,1.549-29.69h11.891c-0.998,9.871-1.068,19.812-1.068,29.69
                            H441.02z M442.863,36.22l0.118-7.023h11.548l-0.306,7.023H442.863z"></path><path d="M482.247,49.127c-2.44-0.834-4.997-1.425-7.548-1.425c-4.593,0-7.499,2.674-7.499,7.313
                            c0,4.463,2.376,6.782,6.838,6.782c2.499,0,5.052-0.594,7.379-1.426l-1.429,8.861c-2.919,0.716-5.893,1.077-8.865,1.077
                            c-9.698,0-15.235-5.237-15.235-15.056c0-3.149,0.774-16.058,15.774-16.058c3.859,0,7.02,0.35,10.054,1.126L482.247,49.127z"></path><path d="M264.56,38.237c-0.651,10.415-0.947,20.884-1.064,31.36H251.18c1.369-12.313,1.841-23.799,1.901-39.686
                            h21c2.859,0,14.275,0.297,14.275,10.534c0,6.246-3.686,9.636-9.28,11.601c2.324,5.946,5.239,11.657,7.731,17.551h-13.205
                            c-2.142-7.561-4.937-14.872-7.675-22.257c0.957,0.187,1.966,0.3,2.914,0.3c3.454,0,7.554-1.307,7.554-5.412
                            c0-3.991-3.988-3.991-6.718-3.991H264.56z"></path><path d="M297.821,51.094c0.293-2.56,2.075-5.238,5.284-5.238c2.861,0,4.29,1.783,4.29,5.238H297.821z
                             M317.928,56.506c0.295-1.49,0.418-2.974,0.418-4.46c0-8.273-5.359-12.849-15.121-12.849c-15.821,0-17.067,13.38-17.067,16.535
                            c0,11.724,8.274,14.579,17.734,14.579c3.438,0,6.952-0.424,10.352-1.132l1.421-8.331c-3.337,0.95-6.9,1.965-10.41,1.965
                            c-3.927,0-7.797-1.668-7.797-6.307H317.928z"></path><path d="M331.374,47.938c1.427-0.361,2.85-0.655,4.34-0.655c4.402,0,6.607,2.738,6.607,7.023
                            c0,3.51-1.603,7.907-5.83,7.907c-4.046,0-5.709-3.924-5.709-7.378C330.782,52.516,331.017,50.199,331.374,47.938z
                             M329.827,83.163c0-5.478,0.302-11.011,0.474-16.545c3.034,2.44,6.666,3.692,10.532,3.692c8.565,0,12.785-7.911,12.785-15.586
                            c0-8.093-4.043-15.528-16.178-15.528c-6.658,0-11.958,0.652-17.305,1.541c0,14.161-0.846,28.321-2.095,42.425H329.827z"></path><path d="M376.76,65.789l-0.112-0.126c-2.44,3.57-6.132,4.647-10.407,4.647c-8.274,0-10.655-4.054-10.655-9.046
                            c0-1.903,1.069-15.467,1.069-21.358h11.658c-0.227,5.296-1.065,10.589-1.065,15.825c0,2.856,0.952,5.295,4.222,5.295
                            c3.038,0,4.709-2.375,5.291-5.055c0.778-3.333,0.899-10.173,1.074-16.065h11.547c-0.955,9.871-1.432,19.812-1.669,29.69H376.76
                            V65.789z"></path><path d="M403.125,47.938c1.428-0.361,2.854-0.655,4.338-0.655c4.405,0,6.601,2.738,6.601,7.023
                            c0,3.51-1.6,7.907-5.83,7.907c-4.042,0-5.709-3.924-5.709-7.378C402.524,52.516,402.761,50.199,403.125,47.938z M401.69,65.847
                            h0.12c2.317,3.039,5.357,4.464,9.289,4.464c9.574,0,14.265-8.034,14.265-16.778c0-9.342-5.463-14.335-14.626-14.335
                            c-1.196,0-2.385,0.056-3.515,0.173c-1.186,0.118-2.318,0.298-3.511,0.536c0.237-4.226,0.479-7.14,0.895-9.996h-11.837
                            c-0.178,13.271-1.075,26.473-2.024,39.686h10.89L401.69,65.847z"></path><path d="M440.253,29.911c-0.653,6.664-1.971,29.273-2.151,39.686h-11.836c1.126-13.213,1.785-26.415,2.144-39.686
                            H440.253z"></path><path d="M441.02,69.597c1.008-8.983,1.426-17.85,1.549-29.69h11.891c-0.998,9.871-1.068,19.812-1.068,29.69
                            H441.02z M442.863,36.22l0.118-7.023h11.548l-0.306,7.023H442.863z"></path><path d="M482.247,49.127c-2.44-0.834-4.997-1.425-7.548-1.425c-4.593,0-7.499,2.674-7.499,7.313
                            c0,4.463,2.376,6.782,6.838,6.782c2.499,0,5.052-0.594,7.379-1.426l-1.429,8.861c-2.919,0.716-5.893,1.077-8.865,1.077
                            c-9.698,0-15.235-5.237-15.235-15.056c0-3.149,0.774-16.058,15.774-16.058c3.859,0,7.02,0.35,10.054,1.126L482.247,49.127z"></path></g><g><g><g><path d="M264.56,37.737c-0.651,10.415-0.947,20.884-1.064,31.36H251.18c1.369-12.313,1.841-23.799,1.901-39.686h21
                                    c2.859,0,14.275,0.297,14.275,10.534c0,6.246-3.686,9.636-9.28,11.601c2.324,5.946,5.239,11.657,7.731,17.551h-13.205
                                    c-2.142-7.561-4.937-14.872-7.675-22.257c0.957,0.187,1.966,0.3,2.914,0.3c3.454,0,7.554-1.307,7.554-5.412
                                    c0-3.991-3.988-3.991-6.718-3.991H264.56z"></path><path d="M297.821,50.594c0.293-2.56,2.075-5.238,5.284-5.238c2.861,0,4.29,1.783,4.29,5.238H297.821z M317.928,56.006
                                    c0.295-1.49,0.418-2.974,0.418-4.46c0-8.273-5.359-12.849-15.121-12.849c-15.821,0-17.067,13.38-17.067,16.535
                                    c0,11.724,8.274,14.579,17.734,14.579c3.438,0,6.952-0.424,10.352-1.132l1.421-8.332c-3.337,0.951-6.9,1.965-10.41,1.965
                                    c-3.927,0-7.797-1.668-7.797-6.307H317.928z"></path><path d="M331.374,47.438c1.427-0.361,2.85-0.655,4.34-0.655c4.402,0,6.607,2.738,6.607,7.023c0,3.51-1.603,7.907-5.83,7.907
                                    c-4.046,0-5.709-3.924-5.709-7.378C330.782,52.016,331.017,49.699,331.374,47.438z M329.827,82.663
                                    c0-5.478,0.302-11.011,0.474-16.545c3.034,2.44,6.666,3.692,10.532,3.692c8.565,0,12.785-7.911,12.785-15.586
                                    c0-8.093-4.043-15.528-16.178-15.528c-6.658,0-11.958,0.652-17.305,1.541c0,14.161-0.846,28.321-2.095,42.425H329.827z"></path><path d="M376.76,65.289l-0.112-0.126c-2.44,3.57-6.132,4.647-10.407,4.647c-8.274,0-10.655-4.054-10.655-9.046
                                    c0-1.903,1.069-15.467,1.069-21.358h11.658c-0.227,5.296-1.065,10.589-1.065,15.825c0,2.856,0.952,5.295,4.222,5.295
                                    c3.038,0,4.709-2.375,5.291-5.055c0.778-3.333,0.899-10.173,1.074-16.065h11.547c-0.955,9.871-1.432,19.812-1.669,29.69H376.76
                                    V65.289z"></path><path d="M403.125,47.438c1.428-0.361,2.854-0.655,4.338-0.655c4.405,0,6.601,2.738,6.601,7.023c0,3.51-1.6,7.907-5.83,7.907
                                    c-4.042,0-5.709-3.924-5.709-7.378C402.524,52.016,402.761,49.699,403.125,47.438z M401.69,65.347h0.12
                                    c2.317,3.039,5.357,4.464,9.289,4.464c9.574,0,14.265-8.034,14.265-16.778c0-9.342-5.463-14.335-14.626-14.335
                                    c-1.196,0-2.385,0.056-3.515,0.173c-1.186,0.118-2.318,0.298-3.511,0.536c0.237-4.226,0.479-7.14,0.895-9.996h-11.837
                                    c-0.178,13.271-1.075,26.473-2.024,39.686h10.89L401.69,65.347z"></path><path d="M440.253,29.411c-0.653,6.664-1.971,29.273-2.151,39.686h-11.836c1.126-13.213,1.785-26.415,2.144-39.686H440.253z"></path><path d="M441.02,69.097c1.008-8.983,1.426-17.85,1.549-29.69h11.891c-0.998,9.871-1.068,19.812-1.068,29.69H441.02z
                                     M442.863,35.72l0.118-7.023h11.548l-0.306,7.023H442.863z"></path><path d="M482.247,48.627c-2.44-0.834-4.997-1.425-7.548-1.425c-4.593,0-7.499,2.674-7.499,7.313
                                    c0,4.463,2.376,6.782,6.838,6.782c2.499,0,5.052-0.594,7.379-1.426l-1.429,8.861c-2.919,0.716-5.893,1.077-8.865,1.077
                                    c-9.698,0-15.235-5.237-15.235-15.056c0-3.149,0.774-16.058,15.774-16.058c3.859,0,7.02,0.35,10.054,1.126L482.247,48.627z"></path></g></g><defs><filter id="Adobe_OpacityMaskFilter_3_" filterunits="userSpaceOnUse" x="251.18" y="28.697" width="231.067" height="53.966"><fecolormatrix type="matrix" values="-1 0 0 0 1  0 -1 0 0 1  0 0 -1 0 1  0 0 0 1 0" color-interpolation-filters="sRGB" result="source"></fecolormatrix></filter></defs><mask maskunits="userSpaceOnUse" x="251.18" y="28.697" width="231.067" height="53.966" id="SVGID_4_"><g filter="url(#Adobe_OpacityMaskFilter_3_)"><image overflow="visible" width="236" height="59" xlink:href="data:image/jpeg;base64,/9j/4AAQSkZJRgABAgEASABIAAD/7AARRHVja3kAAQAEAAAAHgAA/+4AIUFkb2JlAGTAAAAAAQMA
                                    EAMCAwYAAAKMAAAE+wAADjj/2wCEABALCwsMCxAMDBAXDw0PFxsUEBAUGx8XFxcXFx8eFxoaGhoX
                                    Hh4jJSclIx4vLzMzLy9AQEBAQEBAQEBAQEBAQEABEQ8PERMRFRISFRQRFBEUGhQWFhQaJhoaHBoa
                                    JjAjHh4eHiMwKy4nJycuKzU1MDA1NUBAP0BAQEBAQEBAQEBAQP/CABEIADsA7AMBIgACEQEDEQH/
                                    xACsAAACAwEBAAAAAAAAAAAAAAAABgQFBwMCAQEAAAAAAAAAAAAAAAAAAAAAEAABAwQBAgUFAQAA
                                    AAAAAAAFAwQGAAECBzUVFxARExQ2IDBAUBY0EQACAQMCAwQECAgMBwAAAAABAgMREgQAITETBRBB
                                    YRRRIrPTgZEykiMzNHTwcVJy4yQVNSAwQKGxwUJiooOkBuFTc6OEJUYSAQAAAAAAAAAAAAAAAAAA
                                    AFD/2gAMAwEAAhEDEQAAAKZp4O4nle2mcLO94+Ug/wAcSCW1CUaB4EIsZhRDeoBKZfIxq2srBkw/
                                    qpeXUi9KKH5iiIWrQIQ+pporapMAkPK42EaXnOkipfQOYMFPcFBOzWwH9ebaglYZuGNG6qjWvjAu
                                    MeQGodUbQyikeoRYVVtHJvibmQyKqkGt2uZdiPr+AtoyNmR8TRINT5OugZlppV9kn2OdVm/M26El
                                    VxqiotQjXahG4mkcU5TNehJHE11WV641rlkLQM2VNKQAAAAAAA4ahirUJ9f24gAAAAAAAAAAAAAA
                                    H//aAAgBAgABBQD95//aAAgBAwABBQD95//aAAgBAQABBQCFxhjIL9sQNdsQNdsQNSaEvAmH3BjX
                                    B6S7YgamkYYx+/hDocNPDXWuY41bBoXGnIiWxKPjo/8ARq9rhiNrupUfONzw5y2RdtgkRMm07arv
                                    5PtYPkULDHnU22rymSnauldWKWTLACoZQFDyZ5pfWR+1qtrI/e2EPJgSlSeHZyF5fVd/I3GyoLPW
                                    qCqUekHAih+wMxcmYzdIKEjZU7mlqxS6aurFLJ9McdV1jwKqqaKbLWyb1mIEsw7F0/Ze8SSSQSkU
                                    8bhH4ckkWGSQJi7dUdmIsE8DHhptAqNbFmGuUFWwgyuq2EeEwUcZGaMTgOHfhzTA00IsG5JjC0FW
                                    0blDhJvHY/wM89wqHHMG41iTMDRKLXYsbXv6gTuDrHgZBwOtSnuRLlG67eAIrt5ZTiaRps4/u4pT
                                    CWx8i7rYTZRCTavTcXKVHGuCDeQcCJZdQKUZ+V1PcM8ZVqyyvq1H1U1h07+KAsM0wh7BtmvWz/W6
                                    x4a/bpIxiQcDBSNmEjovjgAlNr2vY1Cwxp0hrWPJKpMhY/YlHI8OOoCRDEOzMk0hIyBPMHUbva17
                                    MwolgtRJRwpsGjkYEnbCRDEOzkZlMKJjaSaUfnfxSp86uyHsnrUg1JBxhZJCFRdBX3THrYidFxA9
                                    7sQ29Z4Z5p522aftYvOSxhgHmR0RgltNSybjaTjJKIuXJ6a0dmBYJKb7Uv5G5IVO5hTpAG6S2mpZ
                                    MjsYy7U7nHq/uS/V+5x6huwzbRw42k4ySLmyRpwy2IbZMy86Llx9tmn7WOzAmeaBJIVBZpbTUsm7
                                    2gQz+1rHnqkHPflxrkKe/wCz8P8A/9oACAECAgY/AHP/2gAIAQMCBj8Ac//aAAgBAQEGPwDM85JL
                                    GMblWckqteZzK1vRvyNfaMv58fudfaMv58fudfaMv58fudNmQP5np67tKaK8VzWqrrX1uI3X4h/G
                                    4mHISqZM8cTMvECRwhIr+PX2jL+fH7nWH5OSWQZPNv5xVqcvl0pYi/l9suZmSzo6TtEqxMiiioj1
                                    N6N+VqbJlyctYoEaR2ujNFQFiaCGp2GsHJnw75pseKSR+bKKs6KzGiyAcTrKzcLF5WRFy7H5kjUu
                                    kRDs7sODfwc3MBN804iZe4CFA6keP0p7P3X/AKj9Dpc6BDGQxjlibeyRQCVu2uFGFDqXFnW6GdGj
                                    kXhVWFp3GufiokWNuBPMxVGZeIW0Mx/HSnjrfqm/f+r/AKbRkwcxMqVd+S6cmop/Za9xWvpoPHSd
                                    KlTk5jyrBZJta7kKKkV234ju1TLzIIoqbNEHlavotZYh/Pr96f6f9NpjD1JXlANivCUUnuBYSMR8
                                    R1ZnwMiE0SYetE/GlrjappWh38NPl4ckEcUchiIlZwSwVWNLEbuYarz8Q+F8nuuyvPxB4Xye610n
                                    LzJIJIpM/HiAiZyQxe7e9F7lPZFknPOOkMfLWHl8wVuZmcfSJQmoHDu1t1Tfu/V/02l89GDE5tjn
                                    jN0bGlaV2IP5wGneRbVnyZJIjt6yhUjr85CNdT+6T+zbWG+H1PGixWhjMEbqpZYyoKA/q7cF8dZE
                                    nVeoY+RgqU50USgMauoXhBHwanfpvIxgRIbZJ5DbGppWldyT+aDpTN1JUlIF6pCXUHvAYyKT8Q0x
                                    h6krygGxXhKKT3AsJGI+I6/ZNV8z5jytamzmX8rjStK+Gsj72/s4dPNKwSONS7uxoFVRUkn0Aagz
                                    IupkR5EaSqDjioDqGoaTncV0mFhrbGu7MflO54u59Jp/VqPpDl3yMtHJSKoMcQU1kd0IKA/JB414
                                    aSGFBHFGAqIooqqNgABo9PjxTlzRgGYl+UqFgGVR6j3eqa/htj9QiFqzpUpubWBtdakCtrAitN9d
                                    M6lBCGysTMxzK6g3nH5guFF42kht+Ar2Lh5cc8krxiUGFUZQGLLQ3SKa+rppsCQtZaJY2FrxlhUB
                                    h/WKjx1NgZVeVMACVNGUg3Kw8QRrMx5lsmhzpY5F2NrIkSsNvEazsiFrJocaaSNtjayIzKd/Edv+
                                    28WKrRvmCZ41FamFoqN6fVV27H6fkRzyzxBTIYkUqpcXAVd03oQdtebwXLIDY6spVkegYqw8Lu6o
                                    8dTYOSKxToVJoCVJ4Mta7qdxrFx5lsmheeORdjayTyqw28RrqUkptVseSMGhPrSrykG3pZhrpn3S
                                    D2a6g6fj239Ry4MUl60FxLruOHrIPg1Dg4wpFAgUGgBYjizUpux3OhN1DIWBWrYp3d6UBsRas1Ki
                                    tBt36YSvNiW0oZoybq+jkmTh468zzo/2bzvM8+/6Pm8rnXX1/wCd3fBrI+9v7OHXU/uk/s21L05h
                                    RsB6oR3xzFnHfxDXfBTUsAkeIyoyCWM2ulwtuQ9xHdrqEGS3MyIoZkmepa51miVjcdzU9kuNPm2T
                                    Qu0ci8qY0dDawqIyOI19u/7M3u9R4WFl83IlrYnLlWtqlzu6AcB2TyvS3JjiljpxtCCHfxujOsyR
                                    a+WWALJv6vMZ1MdV7zRXp8Pp7M2VSScrqGZK4PAETPDQfBGNdT+6T+zbWJhEMVyJkjcoKsEZhew2
                                    PyVqez/bn/nexXszGZSocRMhIoGHKRaj07gjXUiGAiCwh1p6xYmS0hq7AC6u3o9HY00TB4pMnMdH
                                    U1DK2VMQQfEazv8AJ9tHrp0cilHTFgVlYUKkRqCCD366OuUQIx1BGUk2/SLDO0W//UC7d/Dsxbru
                                    R5YWVrZfzHvt7q0tr8HbjyRijZDyySmpNWDtFX5qDXU/uk/s21jhyBHlg4zkgk/SUKUp6ZFUdmL1
                                    6gXD6kPJZzn+w5oUkqzClbBXbgp7zqo3B4HQy8jmQT0o7wFV5lOBe5G3Hp/4aWR3yZ1XjFJIoVtu
                                    /lojfEdYGD0yPlRwQuJkqx+laKaT5Tkk+oy9/h2LDmqwaM1jmjIWRPSASGFD3gjS4eElsa7sx3d2
                                    73c7VP4DWR1CUVECVVd/Xc+qi7A8WIGoRzDJPDJKuQWqW5jyNNUk8ahwa6odweI1JPhYkUEsvynR
                                    ADSgFq/kj1RsNu/j2dIgFWggxZZqAVCGRZo2Ykem1Rv2K2ajLOgtTIia2RVrdbuCpH4we+mlw8JL
                                    Y13Zju7t3u52qfwGp80kc4C3HQ09eVtl2qKgcT4A66asahFONE5CigudA7H8ZYknWd/k+2j7OnZg
                                    W843UIJglaXctZXpXfjTUeXiSCWCUVRx/QfQR3jQi6hjpOq/IJqGWpBNrrRlrQVod9LKmApZeAke
                                    SRdxTdJHZT8I15zkf+v81zvLUX6jmX8u35PydqcNRdPxosd4YbrGkVy3rsXNSsiji3o1Phyw4yx5
                                    EbROyJJcFcFTSspFaHSyRsUdCGVlNCpG4II79U5GIfGyT3upOn5MOOkMpUs0auH9Rg4oWkYcR6NC
                                    GGYT44FFgyAZFTgBaQVYUA4A08NKJumq8oAvZJiik95CmNiPjOiMbpyRTbWvJKZFG+9UVIz/AItN
                                    1XJKRzRxPM6RqQpoi4oUVYkbOD2ZkMLifCBirjSbqKxRFrGG6nj4VNaHW3S9+79Y/Q6Xz0gESG6O
                                    CMWxqaUrTck/nE6OTgsPWFskT1Mcg7rlBHDu30om6arygC9kmKKT3kKY2I+M6XyyR4kKSJIFUszs
                                    EIayR6rVSeNANttfZ8T5knvtftjlY/mPL+Vstfl8u/m8OZdW7x19nxPmSe+075QXMx5HZzC1VKXF
                                    mtjk9YgVPBrqAUFNEY3Tkim2teSUyKN96oqRn/FoT58vMK1EaABUjUmtFUf08fSdQYcUOM0ePGsS
                                    M6SXFUAUVpKBWg1L0/Jix0hmtvaNXDeowcULSMOK+jVORiHxsk97pMTMjgjijkEoMSuCWCsu97t3
                                    MdN5GQGJzdJBILo2NKVpsQfzSNKJumq8oAvZJiik95CmNiPjOl8lhQwbG/ms0xPott5VP5/4rI+6
                                    P7SHs6n97n9o38sb94fVN+6/tHFeP9z0/Br/AOs1kfW/Wv8AX/XfKP1v9/8AK8f5J//Z" transform="matrix(1 0 0 1 249 26.377)"></image></g></mask><g opacity="0.12" mask="url(#SVGID_4_)"><g><path d="M264.56,37.737c-0.651,10.415-0.947,20.884-1.064,31.36H251.18c1.369-12.313,1.841-23.799,1.901-39.686
                                    h21c2.859,0,14.275,0.297,14.275,10.534c0,6.246-3.686,9.636-9.28,11.601c2.324,5.946,5.239,11.657,7.731,17.551h-13.205
                                    c-2.142-7.561-4.937-14.872-7.675-22.257c0.957,0.187,1.966,0.3,2.914,0.3c3.454,0,7.554-1.307,7.554-5.412
                                    c0-3.991-3.988-3.991-6.718-3.991H264.56z"></path><path d="M297.821,50.594c0.293-2.56,2.075-5.238,5.284-5.238c2.861,0,4.29,1.783,4.29,5.238H297.821z
                                     M317.928,56.006c0.295-1.49,0.418-2.974,0.418-4.46c0-8.273-5.359-12.849-15.121-12.849c-15.821,0-17.067,13.38-17.067,16.535
                                    c0,11.724,8.274,14.579,17.734,14.579c3.438,0,6.952-0.424,10.352-1.132l1.421-8.332c-3.337,0.951-6.9,1.965-10.41,1.965
                                    c-3.927,0-7.797-1.668-7.797-6.307H317.928z"></path><path d="M331.374,47.438c1.427-0.361,2.85-0.655,4.34-0.655c4.402,0,6.607,2.738,6.607,7.023
                                    c0,3.51-1.603,7.907-5.83,7.907c-4.046,0-5.709-3.924-5.709-7.378C330.782,52.016,331.017,49.699,331.374,47.438z
                                     M329.827,82.663c0-5.478,0.302-11.011,0.474-16.545c3.034,2.44,6.666,3.692,10.532,3.692c8.565,0,12.785-7.911,12.785-15.586
                                    c0-8.093-4.043-15.528-16.178-15.528c-6.658,0-11.958,0.652-17.305,1.541c0,14.161-0.846,28.321-2.095,42.425H329.827z"></path><path d="M376.76,65.289l-0.112-0.126c-2.44,3.57-6.132,4.647-10.407,4.647c-8.274,0-10.655-4.054-10.655-9.046
                                    c0-1.903,1.069-15.467,1.069-21.358h11.658c-0.227,5.296-1.065,10.589-1.065,15.825c0,2.856,0.952,5.295,4.222,5.295
                                    c3.038,0,4.709-2.375,5.291-5.055c0.778-3.333,0.899-10.173,1.074-16.065h11.547c-0.955,9.871-1.432,19.812-1.669,29.69H376.76
                                    V65.289z"></path><path d="M403.125,47.438c1.428-0.361,2.854-0.655,4.338-0.655c4.405,0,6.601,2.738,6.601,7.023
                                    c0,3.51-1.6,7.907-5.83,7.907c-4.042,0-5.709-3.924-5.709-7.378C402.524,52.016,402.761,49.699,403.125,47.438z M401.69,65.347
                                    h0.12c2.317,3.039,5.357,4.464,9.289,4.464c9.574,0,14.265-8.034,14.265-16.778c0-9.342-5.463-14.335-14.626-14.335
                                    c-1.196,0-2.385,0.056-3.515,0.173c-1.186,0.118-2.318,0.298-3.511,0.536c0.237-4.226,0.479-7.14,0.895-9.996h-11.837
                                    c-0.178,13.271-1.075,26.473-2.024,39.686h10.89L401.69,65.347z"></path><path d="M440.253,29.411c-0.653,6.664-1.971,29.273-2.151,39.686h-11.836
                                    c1.126-13.213,1.785-26.415,2.144-39.686H440.253z"></path><path d="M441.02,69.097c1.008-8.983,1.426-17.85,1.549-29.69h11.891c-0.998,9.871-1.068,19.812-1.068,29.69
                                    H441.02z M442.863,35.72l0.118-7.023h11.548l-0.306,7.023H442.863z"></path><path d="M482.247,48.627c-2.44-0.834-4.997-1.425-7.548-1.425c-4.593,0-7.499,2.674-7.499,7.313
                                    c0,4.463,2.376,6.782,6.838,6.782c2.499,0,5.052-0.594,7.379-1.426l-1.429,8.861c-2.919,0.716-5.893,1.077-8.865,1.077
                                    c-9.698,0-15.235-5.237-15.235-15.056c0-3.149,0.774-16.058,15.774-16.058c3.859,0,7.02,0.35,10.054,1.126L482.247,48.627z"></path></g></g></g></g><g><g><path d="M495.859,68.106c-1.011,0.98-2.226,1.469-3.639,1.469c-1.466,0-2.697-0.499-3.701-1.502
                            c-1.001-1.005-1.502-2.235-1.502-3.7c0-1.52,0.54-2.784,1.625-3.789c1.015-0.941,2.208-1.413,3.578-1.413
                            c1.438,0,2.661,0.508,3.677,1.524c1.017,1.017,1.525,2.242,1.525,3.678C497.423,65.855,496.905,67.098,495.859,68.106z
                             M489.176,61.357c-0.828,0.847-1.241,1.852-1.241,3.013c0,1.204,0.419,2.226,1.261,3.069c0.837,0.842,1.846,1.26,3.032,1.26
                            c1.181,0,2.188-0.421,3.024-1.263c0.835-0.854,1.254-1.879,1.254-3.066c0-1.158-0.419-2.16-1.246-3.013
                            c-0.845-0.865-1.852-1.297-3.032-1.297C491.032,60.06,490.019,60.492,489.176,61.357z M489.94,67.273V61.5
                            c0.357,0,0.894,0.002,1.608,0.005c0.709,0,1.104,0.004,1.188,0.01c0.453,0.032,0.837,0.133,1.135,0.295
                            c0.512,0.286,0.77,0.747,0.77,1.382c0,0.485-0.137,0.841-0.406,1.059c-0.271,0.22-0.604,0.35-1,0.391
                            c0.362,0.073,0.632,0.187,0.816,0.333c0.336,0.272,0.506,0.704,0.506,1.285v0.518c0,0.057,0.004,0.115,0.013,0.169
                            c0.007,0.059,0.021,0.109,0.046,0.17l0.056,0.158h-1.442c-0.046-0.181-0.08-0.446-0.099-0.792
                            c-0.016-0.344-0.054-0.584-0.099-0.708c-0.076-0.196-0.214-0.339-0.417-0.418c-0.113-0.046-0.288-0.077-0.517-0.094l-0.33-0.021
                            h-0.314v2.033H489.94z M492.692,62.628c-0.208-0.087-0.497-0.126-0.874-0.126h-0.365v1.695h0.584c0.351,0,0.629-0.07,0.825-0.216
                            c0.197-0.141,0.299-0.376,0.299-0.692C493.161,62.972,493.005,62.747,492.692,62.628z"></path></g><g><g><path d="M495.859,67.606c-1.011,0.98-2.226,1.469-3.639,1.469c-1.466,0-2.697-0.499-3.701-1.502
                                c-1.001-1.005-1.502-2.235-1.502-3.7c0-1.52,0.54-2.784,1.625-3.79c1.015-0.941,2.208-1.413,3.578-1.413
                                c1.438,0,2.661,0.508,3.677,1.524c1.017,1.017,1.525,2.243,1.525,3.678C497.423,65.355,496.905,66.598,495.859,67.606z
                                 M489.176,60.857c-0.828,0.847-1.241,1.852-1.241,3.013c0,1.204,0.419,2.226,1.261,3.069c0.837,0.842,1.846,1.26,3.032,1.26
                                c1.181,0,2.188-0.421,3.024-1.263c0.835-0.854,1.254-1.879,1.254-3.066c0-1.158-0.419-2.16-1.246-3.013
                                c-0.845-0.866-1.852-1.297-3.032-1.297C491.032,59.56,490.019,59.992,489.176,60.857z M489.94,66.773V61
                                c0.357,0,0.894,0.002,1.608,0.005c0.709,0,1.104,0.004,1.188,0.01c0.453,0.032,0.837,0.133,1.135,0.295
                                c0.512,0.286,0.77,0.747,0.77,1.382c0,0.485-0.137,0.841-0.406,1.059c-0.271,0.22-0.604,0.35-1,0.391
                                c0.362,0.073,0.632,0.187,0.816,0.333c0.336,0.272,0.506,0.704,0.506,1.285v0.518c0,0.057,0.004,0.115,0.013,0.169
                                c0.007,0.059,0.021,0.109,0.046,0.17l0.056,0.158h-1.442c-0.046-0.181-0.08-0.446-0.099-0.792
                                c-0.016-0.344-0.054-0.584-0.099-0.708c-0.076-0.196-0.214-0.339-0.417-0.418c-0.113-0.046-0.288-0.077-0.517-0.094l-0.33-0.021
                                h-0.314v2.033H489.94z M492.692,62.128c-0.208-0.087-0.497-0.126-0.874-0.126h-0.365v1.695h0.584
                                c0.351,0,0.629-0.07,0.825-0.216c0.197-0.141,0.299-0.376,0.299-0.692C493.161,62.472,493.005,62.247,492.692,62.128z"></path></g></g></g></g></symbol></svg><div id="nav-ad-5aefa3ecd9e90" class="ad-nav-ad" data-ad="nav-ad">
    <script>
        window.console && console.log && console.log("ADS: queuing nav-ad-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("nav-ad-5aefa3ecd9e90");
    </script></div>
    
            

<header id="mainHeader" class="page-header"><div id="secondary">
            <div class="editions">
                <ul><li class="editionsDrop">
                        <a aria-haspopup="true" class="arrow">
                            Edition: <span data-label="edition"></span>
                        </a>
                        
<ul data-component="editionToggler" class="menu-editions"><li>
        <a class="editionSwitch" data-edition="as" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Asia
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="au" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Australia
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="eu" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Europe
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="in" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            India
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="uk" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            United Kingdom
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="us" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            United States
        </a>
    </li>

    <li class="subDiv"><span class="label">ZDNet around the globe:</span></li>
                    <li class="subDiv">
        <a href="http://www.zdnet.com.cn/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet China
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.fr/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet France
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.de/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Germany
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.co.kr/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Korea
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://japan.zdnet.com/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Japan
        </a>
    </li>

</ul></li>
                </ul></div>

                                                <div class="headerTextAd">
                            <div class="sponsored-text-link">
        <div id="sponsored-text-link-5aefa3ecd9e90" class="ad-sponsored-text-link" data-ad="sponsored-text-link">
    <script>
        window.console && console.log && console.log("ADS: queuing sponsored-text-link-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("sponsored-text-link-5aefa3ecd9e90");
    </script></div>

    </div>
                    </div>
                                    </div>

        <div class="fixation" data-component="fixate" data-fixate-options='{"offset":{"top":0,"bottom":0},"guideTop":"#secondary"}'>
    
    <div id="primary" data-component="smartSearch">
        <a id="zdLogoLarge" title="ZDNet" href="https://www.zdnet.com/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Logo", "pageType": "article"}'>
            <svg class="svg-logo-header" viewbox="0 0 120 84" enable-background="new 0 0 120 84"><lineargradient id="zdlogo" gradientunits="userSpaceOnUse" x1="38.9038" y1="-1.7476" x2="38.9038" y2="81.0522" gradienttransform="matrix(0.9997 0.025 -0.025 0.9997 4.1309 1.418)"><stop offset="0" style="stop-color:#07111A;stop-opacity:0"></stop><stop offset="0.7998" style="stop-color:#07111A"></stop><stop offset="1" style="stop-color:#000000;stop-opacity:0"></stop></lineargradient><path opacity="0.4" fill="url(#zdlogo)" d="M81.783,59.255c1.078-0.467,1.573-1.732,1.106-2.81L59.259,2.28
	c-0.467-1.077-1.733-1.573-2.811-1.102L2.281,24.8c-1.076,0.47-1.574,1.734-1.104,2.813l23.627,54.168
	c0.472,1.075,1.736,1.571,2.813,1.103L81.783,59.255z"></path><path fill="#DE1400" d="M75.949,56.728c0.919-0.399,1.343-1.479,0.943-2.398L56.731,8.114c-0.399-0.919-1.479-1.342-2.4-0.941
			L8.116,27.329c-0.918,0.401-1.343,1.48-0.942,2.4l20.16,46.216c0.402,0.919,1.481,1.343,2.4,0.941L75.949,56.728z"></path><path fill="#FFFFFF" d="M53.456,23.18H42.001v19.714h-13.74L41.573,23.18H21.364l-3.731,5.568h12.238l-13.38,19.714H43.77
				l4.803-7.087V28.748h3.677c4.225,0,7.208,2.544,7.208,7.071c0,4.932-3.354,7.075-7.276,7.075h-2.904v5.568h4.178
				c7.006,0,12.842-5.534,12.842-12.643S60.498,23.18,53.456,23.18z"></path><path fill="#D4DEE4" d="M68.52,22.892h5.684l4.872,10.188c1.287,2.712,2.274,5.389,2.786,7.219c-0.185-1.978-0.366-5.241-0.403-7
			L81.35,22.892h4.874v25.473H80.87l-4.359-9.751c-1.391-3.188-2.97-6.778-3.447-8.355c0.186,2.09,0.225,5.096,0.258,7.221
			l0.147,10.886H68.52V22.892z"></path><path fill="#D4DEE4" d="M102.745,43.38l1.906,2.933c-2.163,1.757-4.436,2.604-7.074,2.604c-5.388,0-8.869-3.812-8.869-9.714
			c0-3.371,0.695-5.608,2.344-7.442c1.541-1.722,3.41-2.53,5.902-2.53c2.161,0,4.216,0.734,5.423,1.983
			c1.722,1.758,2.493,4.287,2.493,8.211c0,0.4,0,0.546,0,1.133H94.02v0.148c0,2.893,1.432,4.544,3.961,4.544
			C99.667,45.25,101.242,44.627,102.745,43.38z M94.096,36.966h5.682v-0.219c0-1.392-0.147-2.126-0.588-2.824
			c-0.479-0.732-1.174-1.1-2.163-1.1c-1.867,0-2.931,1.466-2.931,4.07V36.966z"></path><path fill="#D4DEE4" d="M117.733,29.564l-1.244,3.258h-3.153v9.57c0,2.382,0.44,3.007,2.127,3.007c0.439,0,0.878-0.114,1.76-0.37
			l0.623,2.931c-1.429,0.589-2.714,0.846-3.995,0.846c-2.492,0-4.51-1.101-5.059-2.748c-0.293-0.808-0.33-1.176-0.33-2.897V32.822
			h-1.869v-3.187h1.869c0-1.832,0-3.077,0.186-4.47l4.981-1.247c-0.186,1.721-0.293,3.739-0.293,5.645H117.733z"></path></svg></a>
        <div class="searchLarge">
            <a data-item="trigger" class="searchTrigger hide-text">Search</a>
            <div class="dropDown">
                
<div class="container search-overlay-container">
    <form class="headerSearch active" method="get" action="https://www.zdnet.com/search/">
        <div class="box">
            <input type="search" title="query" autocomplete="off" placeholder="What are you looking for?" tabindex="1" name="q" value="" class="search-expand smart-search-input"><button type="submit" class="search-button" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Search", "pageType": "article"}'>
                    <svg class=" mag-red"><use xlink:href="#mag-red"></use></svg><span class="search-go">Go</span>
            </button>
        </div>
    </form>

    <div class="smart-search-results">
        <span class="closeDropdown screen-large" data-item="close">
                <svg class=" close-gray"><use xlink:href="#close-gray"></use></svg></span>
        <div class="smart-search-results-list"></div>
        <div class="smart-search-trending-content"></div>
                </div>
</div>            </div>
        </div>
        
<nav class="primaryNav" data-component="headerNav"><ul class="navList"><li class="alpha"><a href="https://www.zdnet.com/video/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Videos
            </a></li><li class="beta"><a href="https://www.zdnet.com/topic/smart-cities/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Smart Cities
            </a></li><li class="gamma"><a href="https://www.zdnet.com/topic/windows-10/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Windows 10
            </a></li><li class="delta"><a href="https://www.zdnet.com/topic/cloud/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Cloud
            </a></li><li class="epsilon"><a href="https://www.zdnet.com/topic/innovation/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Innovation
            </a></li><li class=""><a href="https://www.zdnet.com/topic/security/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Security
            </a></li><li class=""><a href="http://www.techproresearch.com/" target='"_blank"' data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Tech Pro
            </a></li><li class="hasDrop"><a class="arrow moreText">more</a><ul class="menu-topics"><li class="alphaDrop"><a href="https://academy.zdnet.com/" target='"_blank"' data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                ZDNet Academy
            </a></li><li class=""><a href="https://www.zdnet.com/topic/microsoft/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Microsoft
            </a></li><li class=""><a href="https://www.zdnet.com/topic/mobility/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Mobility
            </a></li><li class=""><a href="https://www.zdnet.com/topic/internet-of-things/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                IoT
            </a></li><li class=""><a href="https://www.zdnet.com/topic/hardware/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Hardware
            </a></li><li class=""><a href="https://www.zdnet.com/topic/executive-guides/" executive guides data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Executive Guides
            </a></li><li class=""><a href="https://www.zdnet.com/article/vpn-services-2018-the-ultimate-guide-to-protecting-your-data-on-the-internet/" target='"_blank"' data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Best VPN Services
            </a></li><li class="seeAll"><a href="https://www.zdnet.com/topic/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                See All Topics 
            </a></li><li class="subDiv"><a href="https://www.techrepublic.com/resource-library/whitepapers/" target="'_blank'" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                White Papers
            </a></li><li class="subDiv"><a href="https://downloads.zdnet.com/" data-download-link="'true'" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Downloads
            </a></li><li class="subDiv"><a href="https://www.zdnet.com/reviews/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}' data-vanity-rewritten="true">
                Reviews
            </a></li><li class="subDiv"><a href="https://www.zdnet.com/pictures/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Galleries
            </a></li><li class="subDiv"><a href="https://www.zdnet.com/video/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Videos
            </a></li><li class="subDiv"><a href="https://www.techrepublic.com/forums/" target="'_blank'" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "header_tr_forum", "pageType": "article"}'>
                TechRepublic Forums
            </a></li></ul></li><li><a href="https://www.zdnet.com/newsletters/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Newsletter", "pageType": "article"}' class="linkAlt" data-vanity-rewritten="true">Newsletters</a></li><li><a href="https://www.zdnet.com/blog/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-AllWriters", "pageType": "article"}' class="linkAlt">All Writers</a></li><li class="hasDrop"><a class="linkAlt"><span class="zduser"><svg class=" user_alt"><use xlink:href="#user_alt"></use></svg></span></a><span class="loggedOut"><ul class="menu-user" data-component="userTracking"><li><a href="https://www.zdnet.com/user/login/?appId=1101" rel="nofollow" data-user-show='{"action":"login","params":{"appId":1101,"position":"Header"}}'>Log In to ZDNET</a></li><li><a href="https://www.zdnet.com/user/registration/?appId=1101" rel="nofollow" data-user-show='{"action":"register","params":{"appId":1101,"position":"Header"}}'>Join ZDNet</a></li><li><a href="https://www.zdnet.com/about/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "header-about", "pageType": "article"}' data-vanity-rewritten="true">About ZDNet</a></li></ul></span><span class="loggedIn"><ul class="menu-user"><li><a href="https://www.zdnet.com/members/preferences/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "header-personicon-manage", "pageType": "article"}' rel="nofollow">Preferences</a></li><li><a href="https://www.zdnet.com/members/community/" rel="nofollow">Community</a></li><li><a href="https://www.zdnet.com/members/newsletters/" rel="nofollow">Newsletters</a></li><li><a href="https://www.zdnet.com/user/logout/" data-omniture-track="trackLogout" data-omniture-track-data='{"moduleInfo": "header-personicon", "pageType": "article"}' rel="nofollow" data-user-action="logout">Log Out</a></li></ul></span></li>    </ul><ul class="navListMobile"><li class="backgroundLogo">
        <a id="zdLogoSmall" href="https://www.zdnet.com/" title="ZDNet">
            <svg class="svg-logo-header" viewbox="0 0 120 84" enable-background="new 0 0 120 84"><lineargradient id="zdlogo" gradientunits="userSpaceOnUse" x1="38.9038" y1="-1.7476" x2="38.9038" y2="81.0522" gradienttransform="matrix(0.9997 0.025 -0.025 0.9997 4.1309 1.418)"><stop offset="0" style="stop-color:#07111A;stop-opacity:0"></stop><stop offset="0.7998" style="stop-color:#07111A"></stop><stop offset="1" style="stop-color:#000000;stop-opacity:0"></stop></lineargradient><path opacity="0.4" fill="url(#zdlogo)" d="M81.783,59.255c1.078-0.467,1.573-1.732,1.106-2.81L59.259,2.28
	c-0.467-1.077-1.733-1.573-2.811-1.102L2.281,24.8c-1.076,0.47-1.574,1.734-1.104,2.813l23.627,54.168
	c0.472,1.075,1.736,1.571,2.813,1.103L81.783,59.255z"></path><path fill="#DE1400" d="M75.949,56.728c0.919-0.399,1.343-1.479,0.943-2.398L56.731,8.114c-0.399-0.919-1.479-1.342-2.4-0.941
			L8.116,27.329c-0.918,0.401-1.343,1.48-0.942,2.4l20.16,46.216c0.402,0.919,1.481,1.343,2.4,0.941L75.949,56.728z"></path><path fill="#FFFFFF" d="M53.456,23.18H42.001v19.714h-13.74L41.573,23.18H21.364l-3.731,5.568h12.238l-13.38,19.714H43.77
				l4.803-7.087V28.748h3.677c4.225,0,7.208,2.544,7.208,7.071c0,4.932-3.354,7.075-7.276,7.075h-2.904v5.568h4.178
				c7.006,0,12.842-5.534,12.842-12.643S60.498,23.18,53.456,23.18z"></path><path fill="#D4DEE4" d="M68.52,22.892h5.684l4.872,10.188c1.287,2.712,2.274,5.389,2.786,7.219c-0.185-1.978-0.366-5.241-0.403-7
			L81.35,22.892h4.874v25.473H80.87l-4.359-9.751c-1.391-3.188-2.97-6.778-3.447-8.355c0.186,2.09,0.225,5.096,0.258,7.221
			l0.147,10.886H68.52V22.892z"></path><path fill="#D4DEE4" d="M102.745,43.38l1.906,2.933c-2.163,1.757-4.436,2.604-7.074,2.604c-5.388,0-8.869-3.812-8.869-9.714
			c0-3.371,0.695-5.608,2.344-7.442c1.541-1.722,3.41-2.53,5.902-2.53c2.161,0,4.216,0.734,5.423,1.983
			c1.722,1.758,2.493,4.287,2.493,8.211c0,0.4,0,0.546,0,1.133H94.02v0.148c0,2.893,1.432,4.544,3.961,4.544
			C99.667,45.25,101.242,44.627,102.745,43.38z M94.096,36.966h5.682v-0.219c0-1.392-0.147-2.126-0.588-2.824
			c-0.479-0.732-1.174-1.1-2.163-1.1c-1.867,0-2.931,1.466-2.931,4.07V36.966z"></path><path fill="#D4DEE4" d="M117.733,29.564l-1.244,3.258h-3.153v9.57c0,2.382,0.44,3.007,2.127,3.007c0.439,0,0.878-0.114,1.76-0.37
			l0.623,2.931c-1.429,0.589-2.714,0.846-3.995,0.846c-2.492,0-4.51-1.101-5.059-2.748c-0.293-0.808-0.33-1.176-0.33-2.897V32.822
			h-1.869v-3.187h1.869c0-1.832,0-3.077,0.186-4.47l4.981-1.247c-0.186,1.721-0.293,3.739-0.293,5.645H117.733z"></path></svg></a>
    </li>

        <li class="searchMobileWrapper">
        <a data-item="trigger" class="search-trigger">
            <svg viewbox="0 0 16 16"><g><path class="st1" d="M15.9,14.3l-3.5-3.5c0.7-1.1,1.1-2.4,1.1-3.8c0-3.8-3-6.9-6.7-6.9C3,0,0,3.1,0,6.9s3,6.9,6.7,6.9
        c1.6,0,3-0.5,4.1-1.5l3.5,3.5c0.1,0.1,0.2,0.1,0.3,0.1c0,0,0,0,0,0c0.1,0,0.3-0.1,0.3-0.2l0.8-0.9C16,14.8,16,14.5,15.9,14.3z
         M6.7,11.6c-2.6,0-4.6-2.1-4.6-4.7s2.1-4.7,4.6-4.7c2.6,0,4.6,2.1,4.6,4.7S9.3,11.6,6.7,11.6z"></path></g></svg></a>
        <ul class="dropDown forSearch"><li>
                <div class="searchSmall">
                    
<div class="container search-overlay-container">
    <form class="headerSearch active" method="get" action="https://www.zdnet.com/search/">
        <div class="box">
            <input type="search" title="query" autocomplete="off" placeholder="What are you looking for?" tabindex="1" name="q" value="" class="search-expand smart-search-input"><button type="submit" class="search-button" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Search", "pageType": "article"}'>
                    <svg class=" mag-red"><use xlink:href="#mag-red"></use></svg><span class="search-go">Go</span>
            </button>
        </div>
    </form>

    <div class="smart-search-results">
        <span class="closeDropdown screen-large" data-item="close">
                <svg class=" close-gray"><use xlink:href="#close-gray"></use></svg></span>
        <div class="smart-search-results-list"></div>
        <div class="smart-search-trending-content"></div>
                </div>
</div>                </div>
            </li>
        </ul><span class="closeDropdown screen-small" data-item="close">
                <svg class=" close-gray"><use xlink:href="#close-gray"></use></svg></span>
    </li>

        <li data-component="dropdown">
        <a data-item="trigger">Menu</a>

        <ul class="dropDown mobileLinks"><li class="alpha">
            <a href="https://www.zdnet.com/video/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Videos
            </a>
        </li>
    
                                                        
                
        
                                    <li class="beta">
            <a href="https://www.zdnet.com/topic/smart-cities/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Smart Cities
            </a>
        </li>
    
                                                        
                
        
                                    <li class="gamma">
            <a href="https://www.zdnet.com/topic/windows-10/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Windows 10
            </a>
        </li>
    
                                                        
                
        
                                    <li class="delta">
            <a href="https://www.zdnet.com/topic/cloud/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Cloud
            </a>
        </li>
    
                                                        
                
        
                                    <li class="epsilon">
            <a href="https://www.zdnet.com/topic/innovation/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Innovation
            </a>
        </li>
    
                                    
                
        
                                    <li class="">
            <a href="https://www.zdnet.com/topic/security/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Security
            </a>
        </li>
    
                                    
                
        
                                    <li class="">
            <a href="http://www.techproresearch.com/" target='"_blank"' data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-TopicNav", "pageType": "article"}'>
                Tech Pro
            </a>
        </li>
    
                                                        
                                    
        
                            
                                    <li class="alphaDrop">
            <a href="https://academy.zdnet.com/" target='"_blank"' data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                ZDNet Academy
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="https://www.zdnet.com/topic/microsoft/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Microsoft
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="https://www.zdnet.com/topic/mobility/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Mobility
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="https://www.zdnet.com/topic/internet-of-things/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                IoT
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="https://www.zdnet.com/topic/hardware/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Hardware
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="https://www.zdnet.com/topic/executive-guides/" executive guides data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Executive Guides
            </a>
        </li>
    
                                    
                
                            
                                    <li class="">
            <a href="https://www.zdnet.com/article/vpn-services-2018-the-ultimate-guide-to-protecting-your-data-on-the-internet/" target='"_blank"' data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Best VPN Services
            </a>
        </li>
    
    
                    <li class="seeAll">
            <a href="https://www.zdnet.com/topic/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                See All Topics 
            </a>
        </li>
    
                    <li class="subDiv">
            <a href="https://www.techrepublic.com/resource-library/whitepapers/" target="'_blank'" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                White Papers
            </a>
        </li>
    
                    <li class="subDiv">
            <a href="https://downloads.zdnet.com/" data-download-link="'true'" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Downloads
            </a>
        </li>
    
                                <li class="subDiv">
            <a href="https://www.zdnet.com/reviews/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}' data-vanity-rewritten="true">
                Reviews
            </a>
        </li>
    
                    <li class="subDiv">
            <a href="https://www.zdnet.com/pictures/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Galleries
            </a>
        </li>
    
                    <li class="subDiv">
            <a href="https://www.zdnet.com/video/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-MoreMenu", "pageType": "article"}'>
                Videos
            </a>
        </li>
    
                    <li class="subDiv">
            <a href="https://www.techrepublic.com/forums/" target="'_blank'" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "header_tr_forum", "pageType": "article"}'>
                TechRepublic Forums
            </a>
        </li>
    




        </ul></li>

        <li data-component="dropdown">
        <a class="zd-user" data-item="trigger">
            <span class="zduser">
                    <svg class=" user_alt"><use xlink:href="#user_alt"></use></svg></span>
        </a>

        <ul class="dropDown"><li>
                
<span class="loggedOut">
    <ul class="menu-user" data-component="userTracking"><li><a href="https://www.zdnet.com/user/login/?appId=1101" rel="nofollow" data-user-show='{"action":"login","params":{"appId":1101,"position":"Header"}}'>Log In to ZDNET</a>
        </li>
        <li><a href="https://www.zdnet.com/user/registration/?appId=1101" rel="nofollow" data-user-show='{"action":"register","params":{"appId":1101,"position":"Header"}}'>Join ZDNet</a></li>
        <li><a href="https://www.zdnet.com/about/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "header-about", "pageType": "article"}' data-vanity-rewritten="true">About ZDNet</a></li>
    </ul></span>

<span class="loggedIn">
    <ul class="menu-user"><li><a href="https://www.zdnet.com/members/preferences/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "header-personicon-manage", "pageType": "article"}' rel="nofollow">Preferences</a></li>
        <li><a href="https://www.zdnet.com/members/community/" rel="nofollow">Community</a></li>
        <li><a href="https://www.zdnet.com/members/newsletters/" rel="nofollow">Newsletters</a></li>
        <li><a href="https://www.zdnet.com/user/logout/" data-omniture-track="trackLogout" data-omniture-track-data='{"moduleInfo": "header-personicon", "pageType": "article"}' rel="nofollow" data-user-action="logout">Log Out</a></li>
    </ul></span>
            </li>
        </ul></li>

        <li data-component="dropdown">
        
        <a data-item="trigger">us</a>

        <div class="dropDown">
            
<ul data-component="editionToggler" class="menu-editions"><li>
        <a class="editionSwitch" data-edition="as" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Asia
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="au" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Australia
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="eu" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            Europe
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="in" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            India
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="uk" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            United Kingdom
        </a>
    </li>

                    <li>
        <a class="editionSwitch" data-edition="us" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            United States
        </a>
    </li>

    <li class="subDiv"><span class="label">ZDNet around the globe:</span></li>
                    <li class="subDiv">
        <a href="http://www.zdnet.com.cn/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet China
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.fr/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet France
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.de/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Germany
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://www.zdnet.co.kr/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Korea
        </a>
    </li>

                    <li class="subDiv">
        <a href="http://japan.zdnet.com/" target="_blank" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Header-Editions", "pageType": "article"}'>
            ZDNet Japan
        </a>
    </li>

</ul></div>
    </li>
</ul></nav></div>

        </div>
</header><div class="intromercial">
        <div id="intromercial-5aefa3ecd9e90" class="ad-intromercial" data-ad="intromercial">
    <script>
        window.console && console.log && console.log("ADS: queuing intromercial-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("intromercial-5aefa3ecd9e90");
    </script></div>

    </div>
            

                        <div class="hpto">
	
</div>
            
    
    
        <div data-item-id="a15c0fe4-e42b-48c8-bcee-e8420d4f8870">
    <div class="topContent container">
        <div class="breakingNewsContainer"></div>
                        <div class="row">
                <div class="row">
        <div class="col-12">
                                                    
                                                        
                                            

    <div data-component="loadAsync" data-load-async-options='{"url":"https:\/\/www.zdnet.com\/components\/breaking-news\/xhr\/","replace":true,"relocate":".breakingNewsContainer","data":{"slug":"breaking-news-banner"}}'></div>                                                                                
                                                        
                                            		

<header class="storyHeader article"><h1 itemprop="headline">Android P to stop apps from monitoring network activity</h1>

				<p class="summary" itemprop="description alternativeHeadline">It's about time Google patches this nasty security flaw where any Android app can monitor network access of another app.</p>
	    
    
	        





    
<div class="byline">
                        <div class="thumb">
                <a rel="author" itemprop="author" href="https://www.zdnet.com/meet-the-team/us/jake-smith/" data-vanity-rewritten="true">
                                                                    <span class="img "><img src="https://zdnet2.cbsistatic.com/hub/i/r/2016/04/06/54334579-deec-4704-bace-11b928b7a6f3/thumbnail/40x40/9959ed7d17f2dc8a462a1a57793ec322/jake-smith-author-mug.jpg" class="" alt="Jake Smith" height="40" width="40"></span>
            
                </a>
            </div>
                <p class="meta">
                                   By <a rel="author" itemprop="author" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "byline-author", "pageType": "article"}' href="https://www.zdnet.com/meet-the-team/us/jake-smith/" data-vanity-rewritten="true">Jake Smith</a>
            
                    
                    for <a href="https://www.zdnet.com/blog/igeneration/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "byline-blog", "pageType": "article"}'>iGeneration</a>
        
                                        |            <time datetime="2018-05-07 00:54:38">May 7, 2018 -- 00:54 GMT (17:54 PDT)</time>
                
                                                                                            | Topic: <a href="https://www.zdnet.com/topic/mobility/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "byline-topic", "pageType": "article"}'>Mobility</a>
            </p>

</div>
    </header></div>
            </div>
    </div>

    </div>
    <div id="mantle_skin" data-article-num="1">
        <span id="adSkinLeft"></span>
        <span id="adSkinRight"></span>
            <div id="skin-5aefa3ecd9e90" class="ad-skin" data-ad="skin">
    <script>
        window.console && console.log && console.log("ADS: queuing skin-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("skin-5aefa3ecd9e90");
    </script></div>


                
    <section class="leader leader-top" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_top_leaderboard_desktop","spot":"content-top-leaderboard"}'><div id="leader-plus-top-5aefa3ecd9e90" class="ad-leader-plus-top" data-ad="leader-plus-top">
    <script>
        window.console && console.log && console.log("ADS: queuing leader-plus-top-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("leader-plus-top-5aefa3ecd9e90");
    </script></div>

            </section><div class="contentWrapper ">
                <div class="container ">
            
    <div class="row">
                <div class="row">
        <div class="col-12">
                                            <div class="row">
                                        <div class="row">
        <div class="col-12">
                                            <div class="row">
                                    <div class="col-8">
                                                    
                                                        
                                            
    
        


<article><script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "Article",
        "headline": "Android P to stop apps from monitoring network activity",
        "datePublished": "2018-05-07 00:54:38",
        "image": {
            "@type": "ImageObject",
            "url": "https://zdnet3.cbsistatic.com/hub/i/2018/03/07/95edb2dc-c3bb-4385-b850-1d9bda1883f2/ceb9dde0c62c0416d60d2a4a910fbe21/google-pixel-2-0490-025.jpg",
            "height": 578,
            "width": 770
        },
        "author": {
            "@type": "Person",
            "name": "Jake Smith"
        },
        "publisher": {
            "@type": "Organization",
            "name": "ZDNet",
            "logo": {
                "@type": "ImageObject",
                "url": "http://www.zdnet.comhttps://zdnet3.cbsistatic.com/fly/bundles/zdnetcss/images/core/logo.png",
                "height": 60,
                "width": 600
            }
        },
        "dateModified": "2018-05-07 00:54:38",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://www.zdnet.com/article/android-p-to-restrict-apps-from-monitoring-network-access/"
        }
    }
</script><div itemscope itemtype="http://schema.org/NewsArticle">
    <meta itemprop="thumbnailUrl" content="https://zdnet3.cbsistatic.com/hub/i/2018/03/07/95edb2dc-c3bb-4385-b850-1d9bda1883f2/ceb9dde0c62c0416d60d2a4a910fbe21/google-pixel-2-0490-025.jpg"><meta itemprop="url mainEntityOfPage" content="https://www.zdnet.com/article/android-p-to-restrict-apps-from-monitoring-network-access/"><meta itemprop="headline" content="Android P to stop apps from monitoring network activity"><meta itemprop="description" content="It's about time Google patches this nasty security flaw where any Android app can monitor network access of another app."><meta itemprop="author" itemtype="person" content="Jake Smith"><meta itemprop="datePublished" content="2018-05-07 00:54:38"><meta itemprop="dateModified" content="2018-05-07 00:54:38"><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <meta itemprop="url" content="https://zdnet.com/"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="http://www.zdnet.comhttps://zdnet3.cbsistatic.com/fly/bundles/zdnetcss/images/core/logo.png"><meta itemprop="width" content="600"><meta itemprop="height" content="60"></div>
        <meta itemprop="name" content="ZDNet"></div>
</div>
    


        

    

    
<div class="shareBar" data-component="shareBar" data-share-bar-options='{"showCounts":true,"title":"Android P to stop apps from monitoring network activity","description":"It\u0027s about time Google patches this nasty security flaw where any Android app can monitor network access of another app.","shortUrl":"https:\/\/zd.net\/2HVNv3d","author":{"socialProfiles":{"facebookProfile":null,"facebookPage":null,"twitter":"jakeosmith","googlePlus":null}},"location":"top","url":"https:\/\/www.zdnet.com\/article\/android-p-to-restrict-apps-from-monitoring-network-access\/"}'>
    
    <ul><li class="comments">
                <a href="#comments-a15c0fe4-e42b-48c8-bcee-e8420d4f8870" data-location="topsharebar-comment">
                        <svg class=" comment-bubble"><use xlink:href="#comment-bubble"></use></svg><span class="disqus-comment-count social-count loaded" data-component="disqusCount" data-disqus-count-options='{"disqusIdentifier":"a15c0fe4-e42b-48c8-bcee-e8420d4f8870"}'>0</span>
</a>
            </li>
                <li class="facebook">
            <a class="social-share" data-popup="facebook" data-location="topsharebar-fb-like" data-counts="facebook">    <svg class=" facebook"><use xlink:href="#facebook"></use></svg><span class="social-count"></span></a>
        </li>
        <li class="linkedin">
            <a class="social-share" data-popup="linkedin" data-location="topsharebar-linkedin-share" data-counts="linkedin">    <svg class=" linkedin"><use xlink:href="#linkedin"></use></svg><span class="social-count"></span></a>
        </li>
        <li class="twitter">
            <a class="social-share" data-popup="twitter" data-location="topsharebar-twitter-tweet" data-counts="twitter">    <svg class=" twitter"><use xlink:href="#twitter"></use></svg></a>
        </li>
                <li class="email">
            <a data-component="emailContact" data-email-contact-options='{"trackClickText":"email-friend-submit","isDesktopGallery":false,"modalAsync":{"url":"\/user\/email-friend\/xhr\/","requestData":{"contentTitle":"Android P to stop apps from monitoring network activity","contentUrl":"https:\/\/www.zdnet.com\/article\/android-p-to-restrict-apps-from-monitoring-network-access\/"}}}'>
                    <svg class=" envelope"><use xlink:href="#envelope"></use></svg></a>
        </li>
                    </ul></div>

    <div class="storyBody" data-component="lazyloadImages" data-lazyload-images-options='{"threshold":500}'>
                                    
                    <figure class="image  image-full-width shortcode-image"><span class="img aspect-set " style="padding-bottom: 72%"><img src="https://zdnet2.cbsistatic.com/hub/i/r/2018/03/07/95edb2dc-c3bb-4385-b850-1d9bda1883f2/resize/770xauto/6e1c8229bcd1b1727e01ffa31075d23b/google-pixel-2-0490-025.jpg" class="" alt="google-pixel-2-0490-025.jpg" height="auto" width="770"></span><figcaption><span class="caption"><p>Android P may not yet have a name, but unofficially it could be named for "privacy." (Image: file photo)</p></span></figcaption></figure><p>In the future, it looks like Android apps will no longer be able to detect when other apps on your device are connecting to the internet. </p><div data-shortcode></div>
    

        
                <div class="relatedContent alignRight">
                                        	<h3 class="heading">
		<span class="int">SECURITY</span>
	</h3>
            
                            <div class="thumb">
                    <a href="https://www.zdnet.com/article/quadrooter-security-flaws-affect-over-900-million-android-phones/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "pinbox", "pageType": "article"}'>
                                                                        <span class="img "><img src="https://zdnet3.cbsistatic.com/hub/i/r/2016/08/06/59d934d6-1249-4fe5-87ca-e7b5c46478c4/resize/220x165/8d9136c314d25b359948e84ed96bdbd7/zdnet-hero-pic.jpg" class="" alt="'Quadrooter' flaws affect over 900 million Android phones" height="165" width="220"></span>
            
                    </a>
                </div>
            
                            <p class="title">
                    <a href="https://www.zdnet.com/article/quadrooter-security-flaws-affect-over-900-million-android-phones/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "pinbox", "pageType": "article"}'>
                        'Quadrooter' flaws affect over 900 million Android phones
                    </a>
                </p>
            
                            <p class="dek">Researchers revealed the flaws at the Def Con security conference.</p>
            
            <p class="read-more">
                <a href="https://www.zdnet.com/article/quadrooter-security-flaws-affect-over-900-million-android-phones/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "pinbox", "pageType": "article"}'>Read More</a>
            </p>
        </div><p>It's about time Google patches this nasty privacy flaw. Any app can monitor your network activity without your knowledge to see when you connect with a competing app, or perhaps worse.</p><p><em>XDA Developers </em><a href="https://www.xda-developers.com/android-restrict-apps-monitor-network-activity/" target="_blank">first noticed</a> the new changes coming to Android's SELinux rules for apps targeting API level 28 running on <a href="https://www.zdnet.com/article/android-p-new-features-release-date-and-everything-you-need-to-know/" target="_blank">Android P</a>:</p><blockquote>A new commit has appeared in the Android Open Source Project to "start the process of locking down proc/net." /proc/net contains a bunch of output from the kernel related to network activity. There's currently no restriction on apps accessing /proc/net, which means they can read from here (especially the TCP and UDP files) to parse your device's network activity. <br></blockquote><p>The SELinux changes only enable designated VPN apps to access some networking information, according to the code. As <em>XDA Developers </em>points out, Android apps won't have to target API level 28 until 2019 -- meaning the flaw could still be accessed for some time. </p><p>We'll be looking for changes in the next release of the Android Open Source Project. Hopefully Google will jump in and patch things before Android P's future release. </p><div class="shortcodeGalleryWrapper">
            <div class="gallery-details">
            <a class="gallery-title" href="https://www.zdnet.com/pictures/galaxy-s9-best-and-worst-features-about-samsungs-phone/" data-component="imageGalleryModal"><span>Galaxy S9: Best and worst features about...</span></a>
            <a class="full-gallery" href="https://www.zdnet.com/pictures/galaxy-s9-best-and-worst-features-about-samsungs-phone/" data-component="imageGalleryModal">SEE FULL GALLERY</a>
        </div>
    
    <div class="shortcode-gallery" data-component="shortcodeGallery" data-shortcode-gallery-options='{"count":8,"preloadThreshold":9}'>

        <div data-item="window">
            <div data-item="viewport" class="row viewport">
                                    <div data-item="image" class="thumbnail selected" section="galleryItem.1">
                                                <a class="image-link-wrapper" href="https://www.zdnet.com/pictures/galaxy-s9-best-and-worst-features-about-samsungs-phone/" data-component="imageGalleryModal">
                                                                                                            <span class="img "><img src="https://zdnet3.cbsistatic.com/hub/i/r/2018/03/09/1e06c779-fea0-4032-8e05-0afe3c70943b/thumbnail/170x128/a2dccccc1ec9ea4b25c9c6114bef8571/samsung-galaxy-s9-2400-6455.jpg" class="" alt="samsung-galaxy-s9-best-worst.jpg" height="128" width="170"></span>
            
                                                    </a>
                    </div>
                                    <div data-item="image" class="thumbnail " section="galleryItem.2">
                                                <a class="image-link-wrapper" href="https://www.zdnet.com/pictures/galaxy-s9-best-and-worst-features-about-samsungs-phone/2/" data-component="imageGalleryModal">
                                                                                                            <span class="img "><img src="https://zdnet2.cbsistatic.com/hub/i/r/2018/03/05/77f01abd-8e2a-4be8-95c9-7d90303b535e/thumbnail/170x128/85c20637a87c23c31a14488656ae089c/.jpg" class="" alt="samsung-galaxy-s9-best-worst.jpg" height="128" width="170"></span>
            
                                                    </a>
                    </div>
                                    <div data-item="image" class="thumbnail " section="galleryItem.3">
                                                <a class="image-link-wrapper" href="https://www.zdnet.com/pictures/galaxy-s9-best-and-worst-features-about-samsungs-phone/3/" data-component="imageGalleryModal">
                                                                                                            <span class="img "><img src="https://zdnet2.cbsistatic.com/hub/i/r/2018/03/04/1af5cc1c-66bd-48db-9fcd-de142745a8bf/thumbnail/170x128/8e3a8132d2e8d3c00263e8d8156b152f/galaxy-s9-camera-close-up.png" class="" alt="samsung-galaxy-s9-best-worst.jpg" height="128" width="170"></span>
            
                                                    </a>
                    </div>
                                    <div data-item="image" class="thumbnail " section="galleryItem.4">
                                                <a class="image-link-wrapper" href="https://www.zdnet.com/pictures/galaxy-s9-best-and-worst-features-about-samsungs-phone/4/" data-component="imageGalleryModal">
                                                                                                            <span class="img "><img src="https://zdnet3.cbsistatic.com/hub/i/r/2018/03/26/bedfbd62-a127-41ca-ba15-e2f933c24eb5/thumbnail/170x128/1f801b3a5f8454c2bf82c7a3eb193f5d/gsocho-6835-037.jpg" class="" alt="samsung-galaxy-s9-best-worst.jpg" height="128" width="170"></span>
            
                                                    </a>
                    </div>
                                    <div data-item="image" class="thumbnail " section="galleryItem.5">
                                                <a class="image-link-wrapper" href="https://www.zdnet.com/pictures/galaxy-s9-best-and-worst-features-about-samsungs-phone/5/" data-component="imageGalleryModal">
                                                                                                            <span class="img "><img src="https://zdnet4.cbsistatic.com/hub/i/r/2018/03/04/1c80413d-1218-42f0-ac30-3d82e39e5644/thumbnail/170x128/a2860542bfd0b3642318354d83ad5361/samsung-galaxy-s9-camera-up-close.png" class="" alt="samsung-galaxy-s9-best-worst.jpg" height="128" width="170"></span>
            
                                                    </a>
                    </div>
                                    <div data-item="image" class="thumbnail " section="galleryItem.6">
                                                <a class="image-link-wrapper" href="https://www.zdnet.com/pictures/galaxy-s9-best-and-worst-features-about-samsungs-phone/6/" data-component="imageGalleryModal">
                                                                        <span class="img "><img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="" alt="samsung-galaxy-s9-best-worst.jpg" data-src="https://zdnet1.cbsistatic.com/hub/i/r/2018/03/26/a09b7291-662e-43d0-a2f9-e14a02daf1ed/thumbnail/170x128/e4aa54467ecebebaa06e53eb506dd28c/samsung-galaxy-s9-plus-18.jpg"></span>
                                                    </a>
                    </div>
                                    <div data-item="image" class="thumbnail " section="galleryItem.7">
                                                <a class="image-link-wrapper" href="https://www.zdnet.com/pictures/galaxy-s9-best-and-worst-features-about-samsungs-phone/7/" data-component="imageGalleryModal">
                                                                        <span class="img "><img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="" alt="samsung-galaxy-s9-best-worst.jpg" data-src="https://zdnet1.cbsistatic.com/hub/i/r/2018/03/26/8da93c4f-5d00-4c0f-9542-57f945a13442/thumbnail/170x128/e1af5fbd6473aecb8178e7ca171f4c28/samsung-galaxy-s9-plus-15.jpg"></span>
                                                    </a>
                    </div>
                                    <div data-item="image" class="thumbnail " section="galleryItem.8">
                                                <a class="image-link-wrapper" href="https://www.zdnet.com/pictures/galaxy-s9-best-and-worst-features-about-samsungs-phone/8/" data-component="imageGalleryModal">
                                                                        <span class="img "><img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="" alt="samsung-galaxy-s9-best-worst.jpg" data-src="https://zdnet2.cbsistatic.com/hub/i/r/2018/03/26/339e0dcc-a015-48aa-9a9b-6fc550851bd7/thumbnail/170x128/56e366b64d0b08e7528db4607a74f0fb/.jpg"></span>
                                                    </a>
                    </div>
                            </div>
        </div>

        <div class="gallery-controls">
                        <div data-item="image-count"><span class="first">1</span> - <span class="last">5</span> of <span class="count">8</span></div>

            <span section="auxnext" class="auxnext">
                <a class="next" data-to-image="next">
                    NEXT     <svg class=" caret"><use xlink:href="#caret"></use></svg></a>
            </span>

            <span section="auxprev" class="auxprev">
                <a class="prev disabled" data-to-image="previous">
                       <svg class=" caret"><use xlink:href="#caret"></use></svg>
 PREV
                </a>
            </span>
        </div>
    </div>
</div>
            </div>

    
<section class="related-topics"><h3>Related Topics:</h3>
        
                    <a href="https://www.zdnet.com/topic/google/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}'>
                Google
            </a>
                    <a href="https://www.zdnet.com/topic/smartphones/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}'>
                Smartphones
            </a>
                    <a href="https://www.zdnet.com/topic/mobile-os/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}'>
                Mobile OS
            </a>
                    <a href="https://www.zdnet.com/topic/security/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}'>
                Security
            </a>
                    <a href="https://www.zdnet.com/topic/hardware/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}'>
                Hardware
            </a>
                    <a href="https://www.zdnet.com/reviews/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "article_related_topic", "pageType": "article"}' data-vanity-rewritten="true">
                Reviews
            </a>
            </section><div class="shareBar" data-component="shareBar" data-share-bar-options='{"showCounts":true,"title":"Android P to stop apps from monitoring network activity","description":"It\u0027s about time Google patches this nasty security flaw where any Android app can monitor network access of another app.","shortUrl":"https:\/\/zd.net\/2HVNv3d","author":{"socialProfiles":{"facebookProfile":null,"facebookPage":null,"twitter":"jakeosmith","googlePlus":null}},"location":"bottom","url":"https:\/\/www.zdnet.com\/article\/android-p-to-restrict-apps-from-monitoring-network-access\/"}'>
    
    <ul><li class="comments">
                <a href="#comments-a15c0fe4-e42b-48c8-bcee-e8420d4f8870" data-location="bottomsharebar-comment">
                        <svg class=" comment-bubble"><use xlink:href="#comment-bubble"></use></svg><span class="disqus-comment-count social-count loaded" data-component="disqusCount" data-disqus-count-options='{"disqusIdentifier":"a15c0fe4-e42b-48c8-bcee-e8420d4f8870"}'>0</span>
</a>
            </li>
                <li class="facebook">
            <a class="social-share" data-popup="facebook" data-location="bottomsharebar-fb-like" data-counts="facebook">    <svg class=" facebook"><use xlink:href="#facebook"></use></svg><span class="social-count"></span></a>
        </li>
        <li class="linkedin">
            <a class="social-share" data-popup="linkedin" data-location="bottomsharebar-linkedin-share" data-counts="linkedin">    <svg class=" linkedin"><use xlink:href="#linkedin"></use></svg><span class="social-count"></span></a>
        </li>
        <li class="twitter">
            <a class="social-share" data-popup="twitter" data-location="bottomsharebar-twitter-tweet" data-counts="twitter">    <svg class=" twitter"><use xlink:href="#twitter"></use></svg></a>
        </li>
                <li class="email">
            <a data-component="emailContact" data-email-contact-options='{"trackClickText":"email-friend-submit","isDesktopGallery":false,"modalAsync":{"url":"\/user\/email-friend\/xhr\/","requestData":{"contentTitle":"Android P to stop apps from monitoring network activity","contentUrl":"https:\/\/www.zdnet.com\/article\/android-p-to-restrict-apps-from-monitoring-network-access\/"}}}'>
                    <svg class=" envelope"><use xlink:href="#envelope"></use></svg></a>
        </li>
                    </ul></div>
</article><div id="inpage-video-top-5aefa3ecd9e90" class="ad-inpage-video-top" data-ad="inpage-video-top">
    <script>
        window.console && console.log && console.log("ADS: queuing inpage-video-top-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("inpage-video-top-5aefa3ecd9e90");
    </script></div>


                                                                                
                                                        
                                            								  				                                                                                
                                                        
                                            


		<div id="taboola-below-article-thumbnails-android-p-to-restrict-apps-from-monitoring-network-access" data-component="taboola" data-taboola-options='{"mode":"alternating-thumbnails-a","container":"taboola-below-article-thumbnails-android-p-to-restrict-apps-from-monitoring-network-access","placement":"ZDNETarticleDesktop\/Tablet-Below Article Thumbnails","isXhr":false}' om-event="ZDNETarticleDesktop/Tablet-Below Article Thumbnails"></div>
                                                                                
                                                        
                                                                                                    
                    

<!-- General comments -->
<div id="comments-a15c0fe4-e42b-48c8-bcee-e8420d4f8870" class="postComments">
    <div class="disqus-details">
                <div class="disqus-login-button loggedOut" data-component="userTracking">
            <a class="btn btn-primary" href="https://www.zdnet.com/user/registration/?appId=1109&amp;redirectUrl=https%3A//www.zdnet.com/article/android-p-to-restrict-apps-from-monitoring-network-access/%23comments-a15c0fe4-e42b-48c8-bcee-e8420d4f8870&amp;showUserName=1" data-user-show='{"action":"register","params":{"appId":1109,"position":"comments","redirectUrl":"https:\/\/www.zdnet.com\/article\/android-p-to-restrict-apps-from-monitoring-network-access\/#comments-a15c0fe4-e42b-48c8-bcee-e8420d4f8870","showUserName":1}}'>LOG IN TO COMMENT</a>
        </div>
                <div class="disqus-user-dropdown loggedIn">
            <span class="disqus-username" id="disqusUsername-a15c0fe4-e42b-48c8-bcee-e8420d4f8870" data-user-var="userName"></span>
                        <ul class="menu-disqus-user"><li><a href="http://www.zdnet.com/members/preferences/">My Profile</a></li>
                <li><a href="http://www.zdnet.com/user/logout/">Log Out</a></li>
            </ul></div>
                <span class="disqus-faq-guidlines">
            | <a href="http://cbsi.force.com/CBSi/zdnetcommunityfaq">Community Guidelines</a>
        </span>
    </div>
    <div id="disqusContainer-a15c0fe4-e42b-48c8-bcee-e8420d4f8870">
        <a name="zdnet_core.anchor.comments"></a>

        <h3>
            <span>Join Discussion</span>
        </h3>

        <div data-social="disqus" data-id="a15c0fe4-e42b-48c8-bcee-e8420d4f8870" data-title="Android P to stop apps from monitoring network activity" data-url="https://www.zdnet.com/article/android-p-to-restrict-apps-from-monitoring-network-access/" data-load-on-init="true"></div>
    </div>
</div>

<div class="add-comment loggedOut" data-component="userTracking">
    <a class="btn btn-primary" href="https://www.zdnet.com/user/registration/?appId=1109&amp;redirectUrl=https%3A//www.zdnet.com/article/android-p-to-restrict-apps-from-monitoring-network-access/%23comments-a15c0fe4-e42b-48c8-bcee-e8420d4f8870&amp;showUserName=1" data-user-show='{"action":"register","params":{"appId":1109,"position":"comments","redirectUrl":"https:\/\/www.zdnet.com\/article\/android-p-to-restrict-apps-from-monitoring-network-access\/#comments-a15c0fe4-e42b-48c8-bcee-e8420d4f8870","showUserName":1}}'>Add Your Comment</a>
</div>

<div class="add-comment loggedIn">
    <a class="btn btn-primary" href="#comments-a15c0fe4-e42b-48c8-bcee-e8420d4f8870">Add Your Comment</a>
</div>                                                                                            
                                                        
                                            

        <div id="6387021" class="yahoo-sponsored-bottom" data-component="yahooTags" data-yahoo-tags-options='{"netseer_tag_id":"21103","netseer_ad_width":"770","netseer_ad_height":"240","netseer_task":"ad","netseer_imp_type":"1","netseer_imp_src":"2","netseer_placement_id":6387021}'></div>
                                                                    </div>
            <div class="col-4">
                                                    
                                                        
                                            

                    	<div class="ad-wrap" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_top_mpu_desktop","spot":"content-top-mpu"}'>
	    <section class="mpu"><div id="mpu-plus-top-5aefa3ecd9e90" class="ad-mpu-plus-top" data-ad="mpu-plus-top">
    <script>
        window.console && console.log && console.log("ADS: queuing mpu-plus-top-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("mpu-plus-top-5aefa3ecd9e90");
    </script></div>

	    </section></div>
                                                                                    
                                                        
                                            

                        <section class="vendor-text-link"><div id="vendor-text-link-5aefa3ecd9e90" class="ad-vendor-text-link" data-ad="vendor-text-link">
    <script>
        window.console && console.log && console.log("ADS: queuing vendor-text-link-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("vendor-text-link-5aefa3ecd9e90");
    </script></div>

    </section><section data-module="Related Stories" class="module relatedStories"><h2 class="heading">
		<span class="int">Related Stories</span>
	</h2>
	<div class="box">
		<ul><li>
					<div>
					    <a class="thumb" title="MacTel deploys SD-WAN services for potato farms" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/article/mactel-deploys-sd-wan-services-for-potato-farms/">
					                                                        <span class="img "><img src="https://zdnet4.cbsistatic.com/hub/i/r/2018/05/07/6234cbfb-6bdd-4f46-9b91-97e3e97db149/thumbnail/170x128/3a32af1faee4563a43a25b97c9ee8b69/spud-king.jpg" class="" alt="MacTel deploys SD-WAN services for potato farms" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Mobility</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/article/mactel-deploys-sd-wan-services-for-potato-farms/">MacTel deploys SD-WAN services for potato farms</a></p>
					</div>
				</li>
																			<li>
					<div>
					    <a class="thumb" title="LG G7 ThinQ, T-Mobile &amp; Sprint, last mile commuting (MobileTechRoundup show #431)" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/article/lg-g7-thinq-t-mobile-sprint-last-mile-commuting-mobiletechroundup-show-431/">
					                                                        <span class="img "><img src="https://zdnet3.cbsistatic.com/hub/i/r/2014/12/21/46d52dea-870f-4436-a914-5f8883b38900/thumbnail/170x128/27ba6028c41e1f7d3aa6a13764b1b0de/motr-logo1-199x199.jpg" class="" alt="LG G7 ThinQ, T-Mobile &amp; Sprint, last mile commuting (MobileTechRoundup show #431)" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Mobility</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/article/lg-g7-thinq-t-mobile-sprint-last-mile-commuting-mobiletechroundup-show-431/">LG G7 ThinQ, T-Mobile &amp; Sprint, last mile commuting (MobileTechRoundup show #431)</a></p>
					</div>
				</li>
																			<li>
					<div>
					    <a class="thumb" title="InvisibleShield Glass Curve Elite for Samsung Galaxy S9 Plus: Bubbles, breakage, and broken promises" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/article/invisibleshield-glass-curve-elite-for-samsung-galaxy-s9-plus-bubbles-breakage-and-broken-promises/">
					                                                        <span class="img "><img src="https://zdnet3.cbsistatic.com/hub/i/r/2018/05/06/bf3596bf-1884-46af-977b-58e80b8b0ad8/thumbnail/170x128/7ec79f6207642952f4833a714549be69/is-curve-elite-s9plus-8.jpg" class="" alt="InvisibleShield Glass Curve Elite for Samsung Galaxy S9 Plus: Bubbles, breakage, and broken promises" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Mobility</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/article/invisibleshield-glass-curve-elite-for-samsung-galaxy-s9-plus-bubbles-breakage-and-broken-promises/">InvisibleShield Glass Curve Elite for Samsung Galaxy S9 Plus: Bubbles, breakage, and broken promises</a></p>
					</div>
				</li>
																			<li>
					<div>
					    <a class="thumb" title="Make the Kessel Run in Solo's new Millennium Falcon Otterbox Symmetry Apple iPhone X case" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/pictures/make-the-kessel-run-in-solos-new-millennium-falcon-otterbox-symmetry-apple-iphone-x-case/" data-component="imageGalleryModal">
					                                                        <span class="img "><img src="https://zdnet4.cbsistatic.com/hub/i/r/2018/05/06/c7b17972-37a1-4a8b-b6e6-7cbe8bd462cb/thumbnail/170x128/232b779a089018260f7d73f02cb0aa62/otterbox-mil-falcon-iphone-x-1.jpg" class="" alt="Make the Kessel Run in Solo's new Millennium Falcon Otterbox Symmetry Apple iPhone X case" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Mobility</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/pictures/make-the-kessel-run-in-solos-new-millennium-falcon-otterbox-symmetry-apple-iphone-x-case/" data-component="imageGalleryModal">Make the Kessel Run in Solo's new Millennium Falcon Otterbox Symmetry Apple iPhone X case</a></p>
					</div>
				</li>
											</ul></div>
</section><div id="newsletter-terms-of-service" data-component="modal" class="modal hide">
        <div class="modalHeader">
            <a class="close" data-close="modal">×</a>
            <h4 class="heading"><span class="modalTitle">Thank You</span></h4>
        </div>
        <div class="modalBody">

            <div class="terms-of-service">
                <h2>Please review our terms of service to complete your newsletter subscription.</h2>

                <form method="post" action="#">
                     <div style="font: inherit; font-size:7pt;">
                         By registering you become a member of the CBS Interactive family of sites and you have read and agree to the <a href="http://www.cbsinteractive.com/legal/cbsi/terms-of-use" target="_blank">Terms of Use</a>, <a href="https://cbsi.secure.force.com/CBSi/articles/FAQ/Privacy-Policy?categories=CBS_Interactive%3AmPrivacy&amp;template=template_mobilePrivacy&amp;referer=mobileprivacy.com&amp;data=&amp;cfs=default" target="_blank">Privacy Policy</a> and <a href="https://cbsi.secure.force.com/CBSi/articles/FAQ/mThird-Party-Social-Networking-Services?template=template_mobilepp&amp;referer=mobilepp.com&amp;data=&amp;cfs=default" target="_blank">Video Services Policy</a>. You agree to receive updates, alerts and promotions from CBS and that CBS may share information about you with our marketing partners so that they may contact you by email or otherwise about their products or services.
                         You will also receive a complimentary subscription to the ZDNet's Tech Update Today and ZDNet Announcement newsletters. You may unsubscribe from these newsletters at any time.
                         <br><br></div>

                    <button type="submit" class="btn btn-block btn-primary" id="newsletter-terms-of-service-submit">ACCEPT &amp; CLOSE</button>
                </form>
            </div>

        </div>
    </div>
<div id="newsletter-widget-2599" data-component="newsletterWidget" data-newsletter-widget-options='{"errorMessage":"Something has gone awry. Please contact &lt;a href=\u0022https:\/\/cbsi.secure.force.com\/CBSi\/submitcase?template=template_zdnet&amp;referer=zdnet.com&amp;cfs=SFS_3\u0022&gt;&lt;b&gt;customer service&lt;\/b&gt;&lt;\/a&gt; to confirm your request.","position":"newsletter-sub-widget"}'>
    <section class="keepUp"><h2 class="heading"><span class="int">Newsletters</span></h2>
        <div class="box" data-component="userTracking">
            <div class="newsletterWidgetSuccessMessage hide">You have been successfully signed up. To sign up for more newsletters or to manage your account, visit the <a href="http://www.zdnet.com/members/newsletters/">Newsletter Subscription Center</a>.</div>
            <div class="newsletterWidgetErrorMessage hide">
                <div class="alert alert-error"></div>
            </div>


            <div class="newsletters">
                <div id="widget-2928" data-component="loadNewsletterAsync" data-load-newsletter-async-options='{"loggedUrl":"https:\/\/www.zdnet.com\/newsletter\/xhr\/widget\/","loginUrl":"https:\/\/www.zdnet.com\/newsletter\/xhr\/widget-login\/","data":{"topic":"mobility"}}'>
                </div>
            </div>
                        <span class="loggedOut">
                <a href="https://www.zdnet.com/newsletters/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "newsletter-seeall", "pageType": "article"}' class="btn-circle" data-vanity-rewritten="true">
                  <div class="btn-circle-text">
                    <span>See</span>
                    All
                  </div>
                </a>
            </span>

            <span class="loggedIn">
                <a href="http://www.zdnet.com/members/newsletters/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "newsletter-seeall", "pageType": "article"}' class="btn-circle">
                  <div class="btn-circle-text">
                    <span>See</span>
                    All
                  </div>
                </a>
            </span>
        </div>
    </section></div>


                                                                                
                                                        
                                            

                    
    <section class="dynamic-showcase-top"><div id="dynamic-showcase-top-5aefa3ecd9e90" class="ad-dynamic-showcase-top" data-ad="dynamic-showcase-top">
    <script>
        window.console && console.log && console.log("ADS: queuing dynamic-showcase-top-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("dynamic-showcase-top-5aefa3ecd9e90");
    </script></div>

    </section><section class="mpu" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_middle_mpu_desktop","spot":"content-middle-mpu"}'><div id="mpu-middle-5aefa3ecd9e90" class="ad-mpu-middle" data-ad="mpu-middle">
    <script>
        window.console && console.log && console.log("ADS: queuing mpu-middle-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("mpu-middle-5aefa3ecd9e90");
    </script></div>

    </section><div id="uid-496007132" data-component="medusaAsync" data-medusa-async-options='{"url":"https:\/\/www.zdnet.com\/m3d0s1\/xhr\/right-rail\/","data":{"promo":2150,"count":3},"template":"right-rail"}'>
    </div>

						                                                                                
                                                        
                                            
    


<section data-module="Related Stories" class="module relatedStories"><h2 class="heading">
		<span class="int">Related Stories</span>
	</h2>
	<div class="box">
		<ul><li>
					<div>
					    <a class="thumb" title="Xiaomi selects Hong Kong exchange for IPO" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/video/xiaomi-selects-hong-kong-exchange-for-ipo/">
					                                                        <span class="img "><img src="https://zdnet1.cbsistatic.com/hub/i/r/2018/05/04/2ab7d542-3d4b-4266-9dec-18169cd5295d/thumbnail/170x128/93341d3008aac6b3b93b3c37a2f55ce9/5aebf94b60b27a4b2bee775d-1280x7201may04201863616poster.jpg" class="" alt="Xiaomi selects Hong Kong exchange for IPO" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Mobility</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/video/xiaomi-selects-hong-kong-exchange-for-ipo/">Xiaomi selects Hong Kong exchange for IPO</a></p>
					</div>
				</li>
																			<li>
					<div>
					    <a class="thumb" title="Nokia partners TeamTalk for connected critical services in NZ" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/video/nokia-partners-teamtalk-for-connected-critical-services-in-nz/">
					                                                        <span class="img "><img src="https://zdnet4.cbsistatic.com/hub/i/r/2018/05/04/7d9df6cd-d331-4fde-84da-7f40bde83597/thumbnail/170x128/11f18480cfc3d68b40f79b26ae0b08f3/5aebb0cd60b27a4b2bee773a-1280x7201may04201814053poster.jpg" class="" alt="Nokia partners TeamTalk for connected critical services in NZ" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Mobility</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/video/nokia-partners-teamtalk-for-connected-critical-services-in-nz/">Nokia partners TeamTalk for connected critical services in NZ</a></p>
					</div>
				</li>
																			<li>
					<div>
					    <a class="thumb" title="Spanish winery brings IoT tech to the vineyards" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/video/internet-of-wines/">
					                                                        <span class="img "><img src="https://zdnet1.cbsistatic.com/hub/i/r/2018/05/02/96f3a9f2-9d15-462e-88c6-f298e2f5ae86/thumbnail/170x128/f22ea2ba8404a9bb1c02053dabdd26b6/5ae9a18c60b27e5ce534fe35-1280x7201may022018215025poster.jpg" class="" alt="Spanish winery brings IoT tech to the vineyards" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Innovation</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/video/internet-of-wines/">Spanish winery brings IoT tech to the vineyards</a></p>
					</div>
				</li>
																			<li>
					<div>
					    <a class="thumb" title="China's smartphone market continues to fall" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/video/chinas-smartphone-market-continues-to-fall/">
					                                                        <span class="img "><img src="https://zdnet3.cbsistatic.com/hub/i/r/2018/05/02/b7e7f8bf-fba4-4a32-ba55-41e730b11b76/thumbnail/170x128/d761e353b180558d4e9d75f0c6ed847e/5ae956fc60b27a4b2bee71f4-1280x7201may02201863332poster.jpg" class="" alt="China's smartphone market continues to fall" height="128" width="170"></span>
            
					    </a>
					</div>
					<div class="content">
													<p class="topicName">Mobility</p>
												<p><a data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "related-stories", "pageType": "article"}' href="https://www.zdnet.com/video/chinas-smartphone-market-continues-to-fall/">China's smartphone market continues to fall</a></p>
					</div>
				</li>
																						</ul></div>
</section><section class="mpu scrolling-mpu" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_bottom_mpu_desktop","spot":"content-bottom-mpu"}'><div id="mpu-bottom-5aefa3ecd9e90" class="ad-mpu-bottom" data-ad="mpu-bottom">
    <script>
        window.console && console.log && console.log("ADS: queuing mpu-bottom-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("mpu-bottom-5aefa3ecd9e90");
    </script></div>

            </section></div>
                                </div>
                        </div>
            </div>
                <div class="row">
        <div class="col-12">
                                                    
                                                        
                                            

                        <section class="leader leader-bottom" data-component="medusaContentRecommendation" data-medusa-content-recommendation-options='{"promo":"promo_ZD_recommendation_bottom_leaderboard_desktop","spot":"content-bottom-leaderboard"}'><div id="leader-plus-bottom-5aefa3ecd9e90" class="ad-leader-plus-bottom" data-ad="leader-plus-bottom">
    <script>
        window.console && console.log && console.log("ADS: queuing leader-plus-bottom-5aefa3ecd9e90 for display");
        var cbsiGptDivIds = cbsiGptDivIds || [];
        cbsiGptDivIds.push("leader-plus-bottom-5aefa3ecd9e90");
    </script></div>

    </section><div data-component="magnet" data-magnet-options='{"data":[{"id":"9ca77949-b94e-4ce9-929a-83f2d175b954","title":"Technology News, Analysis, Comments and Product Reviews for IT Professionals | ZDNet","description":"ZDNet\u0027s breaking news, analysis, and research keeps business technology professionals in touch with the latest IT trends, issues and events.","slug":"homepage","ajaxUrl":"https:\/\/www.zdnet.com\/homepage\/xhr\/","url":"https:\/\/www.zdnet.com\/","typeName":"front_door"}],"currentItem":[{"id":"a15c0fe4-e42b-48c8-bcee-e8420d4f8870","title":"Android P to stop apps from monitoring network activity","description":"It\u0027s about time Google patches this nasty security flaw where any Android app can monitor network access of another app.","slug":"android-p-to-restrict-apps-from-monitoring-network-access","ajaxUrl":"https:\/\/www.zdnet.com\/article\/android-p-to-restrict-apps-from-monitoring-network-access\/xhr\/","url":"https:\/\/www.zdnet.com\/article\/android-p-to-restrict-apps-from-monitoring-network-access\/","typeName":"content_article"}],"hasToc":false}' data-waypoint="a15c0fe4-e42b-48c8-bcee-e8420d4f8870"></div>
	                                                                    </div>
            </div>
                                </div>
                        </div>
            </div>
    </div>


                
            	        </div>
            </div>

        </div>

    </div>

            
<footer role="contentinfo" class="footer-main"><div class="container">
        <div class="row">
            <div class="col-6 siteHighlights">
                
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "Organization",
  "url": "http://www.zdnet.com/",
  "contactPoint": [
    { "@type": "ContactPoint",
      "telephone": "+1-415-344-2000",
      "contactType": "customer service"
    }
  ]
}
</script><a id="zd-logo" href="https://www.zdnet.com/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_zdlogo", "pageType": "article"}'>ZDNet</a>
                <div class="connect">
                    <div class="connect-label">Connect with us</div>
                    <div class="social-links-wrapper" itemscope itemtype="http://schema.org/Organization">
                        <link itemprop="url" href="https://www.zdnet.com/"><a class="circle" target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/pages/ZDNet/5953112932" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_social", "pageType": "article"}' itemprop="sameAs">
                            <svg viewbox="0 0 15.2 32"><g><path d="M15.2,11.1H9.6V7c0-1.2,1.3-1.5,1.9-1.5c0.6,0,3.6,0,3.6,0V0L11,0C5.4,0,4.1,4.1,4.1,6.7v4.4H0v5.6h4.1
        c0,7.3,0,15.2,0,15.2h5.5c0,0,0-8.1,0-15.2h4.7L15.2,11.1z"></path></g></svg></a>
                        <a class="circle" target="_blank" rel="noopener noreferrer" href="http://twitter.com/zdnet" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_social", "pageType": "article"}' itemprop="sameAs">
                            <svg viewbox="0 0 32.5 28.4"><g><path d="M32.5,3.4c-0.5,0.3-2.2,1-3.7,1.1c1-0.6,2.4-2.4,2.8-3.9c-0.9,0.6-3.1,1.6-4.2,1.6c0,0,0,0,0,0
        C26.1,0.9,24.4,0,22.5,0c-3.7,0-6.7,3.2-6.7,7.2c0,0.6,0.1,1.1,0.2,1.6h0C11,8.7,5.1,6,1.8,1.3c-2,3.8-0.3,8,2,9.5
        c-0.8,0.1-2.2-0.1-2.9-0.8c0,2.5,1.1,5.8,5.2,7c-0.8,0.5-2.2,0.3-2.8,0.2c0.2,2.1,3,4.9,6,4.9c-1.1,1.3-4.7,3.8-9.3,3
        c3.1,2,6.7,3.2,10.5,3.2c10.8,0,19.2-9.4,18.7-21.1c0,0,0,0,0,0c0,0,0-0.1,0-0.1c0,0,0-0.1,0-0.1C30.2,6.4,31.5,5.1,32.5,3.4z"></path></g></svg></a>
                        <a class="circle" target="_blank" rel="noopener noreferrer" href="https://www.linkedin.com/company/zdnet-com" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_social", "pageType": "article"}' itemprop="sameAs">
                            <svg viewbox="0 0 31.9 32"><g><path d="M24,8c-5.1,0.1-7.7,3.8-8,4V8h-6v24h6V18c0-0.5,1.3-4.6,6-4c2.5,0.2,3.9,3.5,4,4v14l6,0V15.4
        C31.7,13,30.5,8.1,24,8z M0,32h6V8H0V32z M3,0C1.3,0,0,1.3,0,3s1.3,3,3,3c1.7,0,3-1.3,3-3S4.7,0,3,0z"></path></g></svg></a>
                        <a class="circle youtube" target="_blank" rel="noopener noreferrer" href="https://www.youtube.com/channel/UCr9QWb5RKLfaunjKHJZAdQQ" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_social", "pageType": "article"}' itemprop="sameAs">
                            <svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewbox="0 0 24 24"><path d="M4.652 0h1.44l.988 3.702.916-3.702h1.454l-1.665 5.505v3.757h-1.431v-3.757l-1.702-5.505zm6.594 2.373c-1.119 0-1.861.74-1.861 1.835v3.349c0 1.204.629 1.831 1.861 1.831 1.022 0 1.826-.683 1.826-1.831v-3.349c0-1.069-.797-1.835-1.826-1.835zm.531 5.127c0 .372-.19.646-.532.646-.351 0-.554-.287-.554-.646v-3.179c0-.374.172-.651.529-.651.39 0 .557.269.557.651v3.179zm4.729-5.07v5.186c-.155.194-.5.512-.747.512-.271 0-.338-.186-.338-.46v-5.238h-1.27v5.71c0 .675.206 1.22.887 1.22.384 0 .918-.2 1.468-.853v.754h1.27v-6.831h-1.27zm2.203 13.858c-.448 0-.541.315-.541.763v.659h1.069v-.66c.001-.44-.092-.762-.528-.762zm-4.703.04c-.084.043-.167.109-.25.198v4.055c.099.106.194.182.287.229.197.1.485.107.619-.067.07-.092.105-.241.105-.449v-3.359c0-.22-.043-.386-.129-.5-.147-.193-.42-.214-.632-.107zm4.827-5.195c-2.604-.177-11.066-.177-13.666 0-2.814.192-3.146 1.892-3.167 6.367.021 4.467.35 6.175 3.167 6.367 2.6.177 11.062.177 13.666 0 2.814-.192 3.146-1.893 3.167-6.367-.021-4.467-.35-6.175-3.167-6.367zm-12.324 10.686h-1.363v-7.54h-1.41v-1.28h4.182v1.28h-1.41v7.54zm4.846 0h-1.21v-.718c-.223.265-.455.467-.696.605-.652.374-1.547.365-1.547-.955v-5.438h1.209v4.988c0 .262.063.438.322.438.236 0 .564-.303.711-.487v-4.939h1.21v6.506zm4.657-1.348c0 .805-.301 1.431-1.106 1.431-.443 0-.812-.162-1.149-.583v.5h-1.221v-8.82h1.221v2.84c.273-.333.644-.608 1.076-.608.886 0 1.18.749 1.18 1.631v3.609zm4.471-1.752h-2.314v1.228c0 .488.042.91.528.91.511 0 .541-.344.541-.91v-.452h1.245v.489c0 1.253-.538 2.013-1.813 2.013-1.155 0-1.746-.842-1.746-2.013v-2.921c0-1.129.746-1.914 1.837-1.914 1.161 0 1.721.738 1.721 1.914v1.656z"></path></svg></a>
                    </div>
                </div>
                <p class="copyright">© 2018 CBS Interactive. All rights reserved.
                    <a href="http://legalterms.cbsinteractive.com/privacy" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_TOS", "pageType": "article"}' rel="nofollow" target="_blank">Privacy Policy</a> |
                    <a href="http://legalterms.cbsinteractive.com/cookies" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_TOS", "pageType": "article"}' rel="nofollow" target="_blank">Cookies</a> |
                    <a href="http://legalterms.cbsinteractive.com/adchoice" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_TOS", "pageType": "article"}' rel="nofollow" target="_blank">Ad Choice</a> |
                    <a href="https://www.zdnet.com/advertise/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_TOS", "pageType": "article"}' rel="nofollow" target="_blank" data-vanity-rewritten="true">Advertise</a> |
                    <a href="http://legalterms.cbsinteractive.com/terms-of-use" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_TOS", "pageType": "article"}' rel="nofollow" target="_blank">Terms of Use</a> |
                    <a href="http://legalterms.cbsinteractive.com/eula" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_TOS", "pageType": "article"}' rel="nofollow" target="_blank">Mobile User Agreement</a>
                </p>

                                    <div class="networkSites">
                        <form data-component="footerSites">
                            <label for="cbsiSites">Visit other CBS Interactive sites:</label>
                            <select id="cbsiSites"><option selected value="">Select Site</option><option value="http://www.cbs.com/cbs_cares/">CBS Cares</option><option value="http://www.cbsfilms.com">CBS Films</option><option value="http://www.cbsradio.com">CBS Radio</option><option value="http://www.cbs.com">CBS.com</option><option value="http://www.cbsinteractive.com">CBSInteractive</option><option value="http://www.cbsnews.com">CBSNews.com</option><option value="http://www.cbssports.com">CBSSports.com</option><option value="http://www.chowhound.com">Chowhound</option><option value="http://www.cnet.com">CNET</option><option value="http://www.cbsiam.com/">College Networks</option><option value="http://www.gamespot.com">GameSpot</option><option value="http://www.last.fm">Last.fm</option><option value="http://www.maxpreps.com">MaxPreps</option><option value="http://www.metacritic.com">Metacritic.com</option><option value="http://www.cbsnews.com/moneywatch/">Moneywatch</option><option value="http://www.mysimon.com">mySimon</option><option value="http://www.radio.com">Radio.com</option><option value="http://www.search.com">Search.com</option><option value="http://www.shopper.com">Shopper.com</option><option value="http://www.sho.com">Showtime</option><option value="http://www.techrepublic.com">TechRepublic</option><option value="http://theinsider.etonline.com/">The Insider</option><option value="http://www.tv.com">TV.com</option><option value="http://www.urbanbaby.com">UrbanBaby.com</option><option value="http://www.zdnet.com">ZDNet</option></select></form>
                    </div>
                            </div>

                        <div class="col-2 alpha">
                <ul><li><a href="https://www.zdnet.com/topic/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_topic", "pageType": "article"}'>Topics</a></li>
                    <li><a href="https://www.zdnet.com/blog/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_authors", "pageType": "article"}'>All Authors</a></li>
                    <li><a href="https://www.zdnet.com/pictures/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_galleries", "pageType": "article"}'>Galleries</a></li>
                    <li><a href="https://www.zdnet.com/video/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_videos", "pageType": "article"}'>Videos</a></li>
                    <li><a href="http://narratives.zdnet.com/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_sponsored", "pageType": "article"}'>Sponsored Narratives</a></li>
                </ul></div>

                        <div class="col-2 beta">
                <ul><li><a href="https://www.zdnet.com/about/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}' data-vanity-rewritten="true">About ZDNet</a></li>
                    <li><a href="https://www.zdnet.com/meet-the-team/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}' data-vanity-rewritten="true">Meet The Team</a></li>
                    <li><a href="https://www.zdnet.com/sitemap/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}' data-vanity-rewritten="true">Site Map</a></li>
                    <li><a href="https://www.zdnet.com/rssfeeds/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}' data-vanity-rewritten="true">RSS Feeds</a></li>
                    <li><a href="https://www.zdnet.com/reprints/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer-links", "pageType": "article"}' data-vanity-rewritten="true">Reprint Policy</a></li>
                </ul></div>

                        <div class="col-2 gamma">
                <ul data-component="userTracking"><li class="loggedIn">
                            <a href="https://www.zdnet.com/members/preferences/" rel="nofollow">Manage</a> | <a href="https://www.zdnet.com/user/logout/" rel="nofollow" data-member="submitLogOut" data-user-action="logout" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "trackLogout", "pageType": "article"}'>Log Out</a>

                            <span class="zduser">
                                    <svg class=" user_alt"><use xlink:href="#user_alt"></use></svg></span>
                        </li>
                    
                    <li class="loggedOut">
                        <a href="https://www.zdnet.com/user/registration/?appId=1101" rel="nofollow" data-user-show='{"action":"register","params":{"appId":1101,"position":"footer"}}'>Join</a>
                        |
                        <a href="https://www.zdnet.com/user/login/?appId=1101" rel="nofollow" data-user-show='{"action":"login","params":{"appId":1101,"position":"footer"}}'>Log In</a>
                        |
                        <a href="https://www.zdnet.com/members/" rel="nofollow" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "Footer-Services", "pageType": "article"}'>Membership</a>
                    </li>

                    <li><a href="https://www.zdnet.com/newsletters/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_newsletter", "pageType": "article"}' data-vanity-rewritten="true">Newsletters</a></li>
                    <li><a href="https://cbsi.secure.force.com/CBSi/knowledgehome?referer=zdnet.com" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_assistance", "pageType": "article"}'>Site Assistance</a></li>
                    <li><a href="https://academy.zdnet.com/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_academy", "pageType": "article"}'>ZDNet Academy</a></li>
                    <li><a href="https://www.techrepublic.com/forums/" data-omniture-track="moduleClick" data-omniture-track-data='{"moduleInfo": "footer_tr_forum", "pageType": "article"}' rel="nofollow" target="_blank">TechRepublic Forums</a></li>
                </ul></div>
        </div>
    </div>
</footer><script>
	// Source: https://gist.github.com/jcxplorer/823878/
	// Licence: Public Domain
	function UUIDv4 (){var b="",a,c;for(a=0;32>a;a++){c=16*Math.random()|0;if(8==a||12==a||16==a||20==a)b+="-";b+=(12==a?4:16==a?c&3|8:c).toString(16)}return b};

	var __tealium_data_guid = UUIDv4(),
		utag_data = {"isEnabled":true,"articleAuthorId":["0d101e4f-6b4c-4a70-b4b1-3a88995e9f45"],"articleAuthorName":["jake smith"],"articleId":"a15c0fe4-e42b-48c8-bcee-e8420d4f8870","articlePubDate":"2018-05-07 00:54:38","articleTitle":"android p to stop apps from monitoring network activity","articleType":"content_article","blogId":"bedf85d4-ed4a-11e3-95d2-02911863765e","blogName":"igeneration","deviceType":"desktop","isDev":"0","pageType":"article","siteHier":["mobility","google","mobile os","security","smartphones"],"siteSection":"editorial","siteType":"responsive web","topicId":["10d0341c-ec91-11e3-95d2-02911863765e","1050fa4d-ec91-11e3-95d2-02911863765e","10cdea3b-ec91-11e3-95d2-02911863765e","113c25b6-ec91-11e3-95d2-02911863765e","1147b242-ec91-11e3-95d2-02911863765e"],"topicName":["mobility","google","mobile os","security","smartphones"],"buyingCycle":"discover","siteId":2,"bkSiteId":3330,"limit":4,"rsid":"cnetzdnetglobalsite","siteName":"zdnet","tealium":{"profile":"zdnet","env":"prod"}};
    	utag_data.pageViewGuid = __tealium_data_guid;
</script><script data-main="https://zdnet3.cbsistatic.com/fly/1243-fly/js/main.default.js" src="https://zdnet2.cbsistatic.com/fly/1243-fly/js/libs/require-2.1.2.js"></script><script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js" async></script><script async src="https://ps.ns-cdn.com/dsatserving2/scripts/netseerads.js" type="text/javascript"></script><script>
    (function(){
        try {
        window.mPulseApp = mPulse.init("YZ2TK-PC7PJ-K64DL-L53CR-P2G4E", "22a34a7a-a08f-48ae-a20b-48d26cf7fbb0");
        } catch(e) {}
    })();
</script></body></html>
